Subject: [TLS] I-D Action: draft-ietf-tls-rfc4492bis-06.txt

From: [email-masked]
Date: Mon, 01 Feb 2016 15:01:27 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Transport Layer Security Working Group of the IETF.

        Title           : Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and Earlier
        Authors         : Yoav Nir
                          Simon Josefsson
                          Manuel Pegourie-Gonnard
	Filename        : draft-ietf-tls-rfc4492bis-06.txt
	Pages           : 31
	Date            : 2016-02-01

Abstract:
   This document describes key exchange algorithms based on Elliptic
   Curve Cryptography (ECC) for the Transport Layer Security (TLS)
   protocol.  In particular, it specifies the use of Ephemeral Elliptic
   Curve Diffie-Hellman (ECDHE) key agreement in a TLS handshake and the
   use of Elliptic Curve Digital Signature Algorithm (ECDSA) and Edwards
   Digital Signature Algorithm (EdDSA) as new authentication mechanisms.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tls-rfc4492bis/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-tls-rfc4492bis-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tls-rfc4492bis-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Yoav Nir <[email-masked]>
Date: Tue, 2 Feb 2016 01:15:05 +0200

Hi

No big changes:
 - Replaced the reference to the CFRG draft with RFC 7748
 - Some editorial improvements by Martin Thomson.

So there are still a few open issues (you can see them on github: https://github.com/tlswg/rfc4492bis/issues

We’re also waiting for the CFRG EdDSA draft (now in RGLC) to complete that part of the document.

Yoav

> On 2 Feb 2016, at 1:01 AM, [email-masked] wrote:
> 
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Ilari Liusvaara <[email-masked]>
Date: Tue, 2 Feb 2016 10:37:28 +0200

> We’re also waiting for the CFRG EdDSA draft (now in RGLC) to complete that part of the document.

Also, I would want the negotiation mechanisms for EdDSA in TLS 1.2 and
TLS 1.3 to be the same, so those should be decided.

-Ilari