Subject: [TLS] [Editorial Errata Reported] RFC4492 (4633)

From: RFC Errata System <[email-masked]>
Date: Wed, 2 Mar 2016 06:33:13 -0800 (PST)

The following errata report has been submitted for RFC4492,
"Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=4492&eid=4633

--------------------------------------
Type: Editorial
Reported by: Kurt Roeckx <[email-masked]>

Section: 5.1.1

Original Text
-------------
        struct {
            NamedCurve elliptic_curve_list<1..2^16-1>
        } EllipticCurveList;

Corrected Text
--------------
        struct {
            NamedCurve elliptic_curve_list<2..2^16-1>
        } EllipticCurveList;

Notes
-----
The count is in bytes, not items.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC4492 (draft-ietf-tls-ecc-12)
--------------------------------------
Title               : Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)
Publication Date    : May 2006
Author(s)           : S. Blake-Wilson, N. Bolyard, V. Gupta, C. Hawk, B. Moeller
Category            : INFORMATIONAL
Source              : Transport Layer Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Bodo Moeller <[email-masked]>
Date: Wed, 2 Mar 2016 21:59:05 +0100

> "Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer

I agree with this finding.  Each NamedCurve value takes exactly two bytes,
so the floor should have been specified as 2, not 1.

Bodo

---

From: Yoav Nir <[email-masked]>
Date: Fri, 4 Mar 2016 00:24:35 +0200

> On 2 Mar 2016, at 10:59 PM, Bodo Moeller <[email-masked]> wrote:
> 
> RFC Errata System <[email-masked] <mailto:[email-masked]>>:
> http://www.rfc-editor.org/errata_search.php?rfc=4492&eid=4633 <http://www.rfc-editor.org/errata_search.php?rfc=4492&eid=4633>
> 
> Reported by: Kurt Roeckx <[email-masked] <mailto:[email-masked]>>
> 
> Section: 5.1.1
> 
> Original Text
> -------------
>         struct {
> I agree with this finding.  Each NamedCurve value takes exactly two bytes, so the floor should have been specified as 2, not 1.
> 
> Bodo

Yup. This should be closed as “held for document update”.

Speaking of which:
https://github.com/tlswg/rfc4492bis/pull/21 <https://github.com/tlswg/rfc4492bis/pull/21>

Yoav

---

From: Bodo Moeller <[email-masked]>
Date: Fri, 4 Mar 2016 07:00:26 +0100

"Glen Knowles" <[email-masked]>:

> To be pedantic wouldn't it be:
> NamedCurve elliptic_curve_list<2..2^16-2>

Arguably so, but that's not how the TLS RFCs use the presentation language
in practice (see ClientHello.cipher_suites for just one example), and we'd
want to be consistent with that, not extra nitpicky.

Bodo

---

From: Glen Knowles <[email-masked]>
Date: Thu, 3 Mar 2016 18:49:51 -0800

On Wed, Mar 2, 2016 at 12:59 PM, Bodo Moeller <[email-masked]> wrote:

>> I agree with this finding.  Each NamedCurve value takes exactly two
> bytes, so the floor should have been specified as 2, not 1.
>

---

From: Kurt Roeckx <[email-masked]>
Date: Sun, 6 Mar 2016 12:49:09 +0100

> NamedCurve elliptic_curve_list<2..2^16-2>

It's a good point.  Looking at various RFCs, 2..2^16-1 and
2..2^16-2 seem to be mixed all over.

Kurt