Subject: [TLS] removing 128-bit ciphers in TLS 1.3

From: Fedor Brunner <[email-masked]>
Date: Thu, 12 May 2016 10:10:11 +0200

Because of this attacks:

https://blog.cr.yp.to/20151120-batchattacks.html

could please consider to obsoleting 128-bit ciphers in TLS 1.3.

For example AES-128 encryption has been removed from Suite B

https://www.nsa.gov/ia/programs/suiteb_cryptography/index.shtml

More discussions on AES-128 vs. AES-256

https://crypto.stackexchange.com/questions/5118/is-aes-256-weaker-than-192-and-128-bit-versions

https://www.schneier.com/blog/archives/2009/07/another_new_aes.html

https://www.reddit.com/r/crypto/comments/39211m/is_really_aes256_less_secure_than_aes128/

https://blog.agilebits.com/2013/03/09/guess-why-were-moving-to-256-bit-aes-keys/

Kind regards,
Fedor

---

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Thu, 12 May 2016 21:23:50 +0000

> -----Original Message-----
> From: TLS [mailto:[email-masked]] On Behalf Of Fedor Brunner
> Sent: Thursday, May 12, 2016 4:10 AM
> To: [email-masked]
> Subject: [TLS] removing 128-bit ciphers in TLS 1.3
> 
> Because of this attacks:
> 

But that attack isn't effective against the GCM-based cipher suite in TLS 1.2.

GCM (as implemented in TLS 1.2) has both sides agree on a 32 bit salt as a part of the key agreement; a batch attack (such as Bernstein describes) doesn't work unless you happen to guess the 128 bit key *and* the 32 bit salt; hence if you've collected 2**N TLS sessions, then the attacker would need a work effort of about 2**{160-N) to happen to be able to decrypt 1 random session.  If we estimate N=50 (literally, 1 quadrillion TLS sessions, which I suspect is in the ballpark for number of TLS sessions world-wide), this would put the work effort at 2**110.

I suspect that's a bit much, even for the NSA.

> https://www.nsa.gov/ia/programs/suiteb_cryptography/index.shtml

One could argue that perhaps the reason NSA removed it from Suite B because they couldn't break it; hence that would be an excellent reason to keep it :-)

Attempts at humor aside, I believe their reason was that they think AES-128 was insufficiently strong against a Quantum Computer.  Now, I rather think that we should be moving TLS to use Quantum Resistant cryptography; but as of right now, TLS is rather far from that goal, and the symmetric key size is a minor issue; how we perform key exchange and authentication are much harder, and much more immediately important.

Now, I wouldn't be against going only to AES-256 (the cost delta isn't that much); however if we do it, it should be for valid reasons...