Subject: [TLS] TLSv1.2 connection renegotiation to TLSv1.3

From: Hubert Kario <[email-masked]>
Date: Thu, 01 Sep 2016 18:07:50 +0200

I didn't notice in the -15 draft anything explicitly prohibiting sending a 
TLSv1.3 Client Hello inside established TLSv1.x connection (where x < 3).

Is this something that the protocol should allow? If yes, renegotiation_info 
extension status would probably need to be updated. If not, then I think the 
document should be a bit more explicit about it.
-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 1 Sep 2016 09:19:46 -0700

This should be prohibited. A PR for this would be welcome.

-Ekr

On Thu, Sep 1, 2016 at 9:07 AM, Hubert Kario <[email-masked]> wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
>

---

From: Hubert Kario <[email-masked]>
Date: Thu, 01 Sep 2016 18:38:21 +0200

done:
https://github.com/tlswg/tls13-spec/pull/614