Subject: [TLS] What is the meaning of three dots

From: Xiaoyin Liu <[email-masked]>
Date: Sat, 12 Nov 2016 01:37:37 +0000

Hi,

What is the meaning of three dots (…) in “ClientHello…ServerHello” and “ClientHello…Server Finished”, in section 7.1 Key Schedule? It seems this syntax is not defined in this document.

[1] https://tlswg.github.io/tls13-spec/#rfc.section.7.1

Thank you!

Best,
Xiaoyin

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 11 Nov 2016 17:40:09 -0800

It means "all the messages in between".

-Ekr

On Fri, Nov 11, 2016 at 5:37 PM, Xiaoyin Liu <[email-masked]> wrote:

> Hi,
>
>
>
> What is the meaning of three dots (…) in “ClientHello…ServerHello” and
> “ClientHello…Server Finished”, in section 7.1 Key Schedule? It seems this
> syntax is not defined in this document.
>
>
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
>

---

From: Xiaoyin Liu <[email-masked]>
Date: Sat, 12 Nov 2016 02:04:35 +0000

I see. Thank you, Eric!

Xiaoyin

From: Eric Rescorla<mailto:[email-masked]>
Sent: Friday, November 11, 2016 8:49 PM
To: Xiaoyin Liu<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [TLS] What is the meaning of three dots

-Ekr

On Fri, Nov 11, 2016 at 5:37 PM, Xiaoyin Liu <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

What is the meaning of three dots (...) in "ClientHello...ServerHello" and "ClientHello...Server Finished", in section 7.1 Key Schedule? It seems this syntax is not defined in this document.

Thank you!

Best,
Xiaoyin

_______________________________________________
TLS mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tls