Subject: [TLS] Uplifting 5289

From: Eric Rescorla <[email-masked]>
Date: Thu, 16 Mar 2017 08:17:27 -0700

Hi folks

I note that we are proposing to uplift RFC 5289 to PS, despite the fact
that it
standardizes some CBC cipher suites, which the WG is looking to move away
from. I recognize that these are the only cipher suites you can use in TLS
1.0
and 1.1, but we also want people to move away from them.

This problem is probably solvable by marking the registry as Not
Recommended, but I wondered if anyone had other thoughts on this topic?

-Ekr

---

From: Sean Turner <[email-masked]>
Date: Thu, 16 Mar 2017 11:35:19 -0400

ekr,

While we’re moving the entire document to PS, we’re also following it with https://datatracker.ietf.org/doc/draft-ietf-tls-iana-registry-updates/ that adds a “Recommended" column that is not (see s6) going to include marking “Y” for any of the CBC algorithms.  So, I think we’re okay.

spt

> On Mar 16, 2017, at 11:17, Eric Rescorla <[email-masked]> wrote:
> 
> Hi folks
> 
> I note that we are proposing to uplift RFC 5289 to PS, despite the fact that it
> from. I recognize that these are the only cipher suites you can use in TLS 1.0
> This problem is probably solvable by marking the registry as Not Recommended, but I wondered if anyone had other thoughts on this topic?
> 
> -Ekr
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Yoav Nir <[email-masked]>
Date: Thu, 16 Mar 2017 17:37:43 +0200

> On 16 Mar 2017, at 17:17, Eric Rescorla <[email-masked]> wrote:
> 
> Hi folks
> 

5289 applies to TLS 1.0, 1.1, and 1.2.  It seems strange to uplift a bunch of ciphersuites for 1.2 just as we’re publishing TLS 1.3 which obsoletes 5246.

Yoav

---

From: [email-masked]
Date: Thu, 16 Mar 2017 15:01:33 -0400

Please excuse typos, sent from handheld device 

> On Mar 16, 2017, at 11:37 AM, Yoav Nir <[email-masked]> wrote:
> 
> 

TLS 1.2 will be in use for a while unless major problems are found, so it's worthwhile IMO.

Kathleen

---

From: Yoav Nir <[email-masked]>
Date: Thu, 16 Mar 2017 21:16:42 +0200

> On 16 Mar 2017, at 21:01, [email-masked] wrote:
> 
> 
> 

I understand that. I’m wondering what message we are trying to convey by publishing or uplifting a full standard for a now-obsolete protocol.

The Internet works just fine on proposed standards (or even Internet Drafts)

Yoav

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 16 Mar 2017 12:23:19 -0700

This is actually uplift to PS.

On Thu, Mar 16, 2017 at 12:16 PM, Yoav Nir <[email-masked]> wrote:

> 5289 applies to TLS 1.0, 1.1, and 1.2.  It seems strange to uplift a bunch
> of ciphersuites for 1.2 just as we’re publishing TLS 1.3 which obsoletes
> 5246.
>
>
> I understand that. I’m wondering what message we are trying to convey by
> publishing or uplifting a full standard for a now-obsolete protocol.
>

---

From: Yoav Nir <[email-masked]>
Date: Thu, 16 Mar 2017 22:33:19 +0200

Oh, sorry. I missed that it was Informational.

In that case there’s just the issue that it has ECDH ciphersuites at a time where 4492bis is deprecating all the other ones.  But some of the ciphersuites in there are in wide enough use that it shouldn’t remain Informational.

Yes, it should be uplifted then.

Yoav

> On 16 Mar 2017, at 21:23, Eric Rescorla <[email-masked]> wrote:
> 
> On Thu, Mar 16, 2017 at 12:16 PM, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On 16 Mar 2017, at 21:01, [email-masked] <mailto:[email-masked]> wrote:
>> 
>> 
>> 
>>> On Mar 16, 2017, at 11:37 AM, Yoav Nir <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> 
>>>> On 16 Mar 2017, at 17:17, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> Hi folks
>>>>

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 17 Mar 2017 13:18:04 +0000

FWIW, the IETF LC for this has ended now and I plan
to send the approval message for the uplift to the
secretariat later today.

Thanks,
S.