Subject: [TLS] ITS ETSI/IEEE-TLS extension

From: Mounira Msahli <[email-masked]>
Date: Wed, 29 Mar 2017 14:41:33 +0200 (CEST)

Dear TLS list members, 

I have updated the draft: Transport Layer Security (TLS) Authentication using ITS ETSI and IEEE certificates, 
https://www.ietf.org/id/draft-serhrouchni-tls-certieee1609-01.txt 

My team and I currently working on three major secure vehicular communications projects in Europe: Intercor, SCOOP@F and C-Road. The purpose of this projects is the setting of public key infrastructure for vehicular network. we use the ETSI and IEEE-1609 certificates to make secure link inter-vehicles and between vehicle and its network infrastructure. 

In this context we propose the draft: "Transport Layer Security (TLS) Authentication using ITS ETSI and IEEE certificates". We extend TLS to support ETSI and IEEE-1609 certificates. This extension is very usefull and has become a pressing need. We already validated our proposal with two implementations over OPENSSL and GNUTLS librairies. Now we want to submit our work on your IETF working group for review. Your working group would be most appropriate for the proposed draft. Could you please send me your comments. 

Best regards
Mounira MSAHLI

---

From: Ilari Liusvaara <[email-masked]>
Date: Wed, 29 Mar 2017 17:19:01 +0300

On Wed, Mar 29, 2017 at 02:41:33PM +0200, Mounira Msahli wrote:
> Dear TLS list members, 
> 
> I have updated the draft: Transport Layer Security (TLS)
> Authentication using ITS ETSI and IEEE certificates, 

This uses *certificate_type extension, which is well-known to be
extremely poor match for TLS 1.3. And for application like this,
one wants something that is usable with TLS 1.3.

Furthermore, it doesn't specify how the certificate message is
interpretted.

Also, as of currently, the highest ECC performance in TLS
is X25519 for key exchange and Ed25519 for authentication.

-Ilari

---

From: Mounira Msahli <[email-masked]>
Date: Thu, 30 Mar 2017 07:01:16 +0200 (CEST)

Ok, thank you 

Mounira 

----- Mail original ----- 
De: "Ilari Liusvaara" <[email-masked]> 
À: "Mounira Msahli" <[email-masked]> 
Cc: [email-masked], "Houda Labiod" <[email-masked]>, "ahmed serhrouchni" <[email-masked]> 
Envoyé: Mercredi 29 Mars 2017 16:19:01 
Objet: Re: [TLS] ITS ETSI/IEEE-TLS extension 

-Ilari