Subject: [TLS] 4.1.2 Client Hello ammendment

From: Mark Dunn <[email-masked]>
Date: Tue, 28 Mar 2017 18:37:29 +0100

should the text that reads
     ClientHellos will contain at least two extensions, 
“supported_versions” and either “key_share” or “pre_shared_key”.
be changed to
     ClientHellos will always contain extensions.

Both "key_share" and "pre_shared_key" require other extensions, so "at 
least two extensions" is incorrect.

---

From: Dave Garrett <[email-masked]>
Date: Tue, 28 Mar 2017 16:09:19 -0400

> least two extensions" is incorrect.

Um, that's still "at least two". ;)

Taking a look at that section, there's a better line stating this just below in another paragraph on the same topic. I've posted a quick PR to rewrite this slightly to clean this up a bit.

https://github.com/tlswg/tls13-spec/pull/922

Dave