Subject: [TLS] FW: New Version Notification for draft-ietf-tls-ecdhe-psk-aead-04.txt

From: Daniel Migault <[email-masked]>
Date: Fri, 19 May 2017 20:18:03 +0000

Hi, 

Thank you to all reviewers for their feed backs. Please find the latest version, which as far as I know includes all comments. Comments were not controversial. In order to raise next reviews I am raising aspects that might need a bit more attention.  

1)  The current document mentions I-D.ietf-tls-rfc4492bis and I-D.ietf-tls-tls13 as normative. We can wait for these documents to become RFCs, but we can also dowref them to informational reference if we want to move that document forward. I will leave the AD to decide, and changes if needed can be done by the RFC -editor

2)  Section 4 has the following text:

"""In the case of ECDHE_PSK authentication, the PSK and pre-master are treated by distinct hash function with distinct properties.  This may introduce vulnerabilities over the expected security provided by the constructed pre-master. As such TLS 1.0 and TLS 1.1 should not be  used with ECDHE_PSK. """

With EDCHE_PSK being the ECDHE PSK method not restricted to the cipher suites defined in the document.  I just want to make sure we are ok with the last sentence. 

Yours, 
Daniel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, May 19, 2017 4:03 PM
To: John Mattsson <[email-masked]>; Daniel Migault <[email-masked]>; [email-masked]
Subject: New Version Notification for draft-ietf-tls-ecdhe-psk-aead-04.txt

A new version of I-D, draft-ietf-tls-ecdhe-psk-aead-04.txt
has been successfully submitted by Daniel Migault and posted to the IETF repository.

Name:		draft-ietf-tls-ecdhe-psk-aead
Revision:	04
Title:		ECDHE_PSK with AES-GCM and AES-CCM Cipher Suites for Transport Layer Security (TLS)
Document date:	2017-05-18
Group:		tls
Pages:		8
URL:            https://www.ietf.org/internet-drafts/draft-ietf-tls-ecdhe-psk-aead-04.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-tls-ecdhe-psk-aead/
Htmlized:       https://tools.ietf.org/html/draft-ietf-tls-ecdhe-psk-aead-04
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-tls-ecdhe-psk-aead-04
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-tls-ecdhe-psk-aead-04

Abstract:
   This document defines several new cipher suites for the Transport
   Layer Security (TLS) protocol.  The cipher suites are all based on
   the Ephemeral Elliptic Curve Diffie-Hellman with Pre-Shared Key
   (ECDHE_PSK) key exchange together with the Authenticated Encryption
   with Associated Data (AEAD) algorithms AES-GCM and AES-CCM.  PSK
   provides light and efficient authentication, ECDHE provides forward
   secrecy, and AES-GCM and AES-CCM provides encryption and integrity
   protection.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dave Garrett <[email-masked]>
Date: Fri, 19 May 2017 21:21:54 -0400

> 1)  The current document mentions I-D.ietf-tls-rfc4492bis and I-D.ietf-tls-tls13 as normative. We can wait for these documents to become RFCs, but we can also dowref them to informational reference…

Listing TLS 1.3 as normative when it explicitly doesn't affect/support it is weird. I don't see the need for this to not be an informational reference. 4492bis lists TLS 1.3 as informative as well, yet is more relevant to it. I think just downgrading the reference is fine.

Dave

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 22 May 2017 12:56:24 -0500

Thanks for the updates; the new revision addresses my concerns raised in
the secdir review.

However,

% In addition, it is worth noting that TLS 1.0 [RFC2246] and TL1.2
% [RFC4346] splits the pre-master in two parts.

s/TL1.2/TLS 1.1/, and maybe the ending as "split the pre-master secret
into two parts".

% the PSK and pre-master are treated by
% distinct hash function with distinct properties.

s/pre-master/ECDHE shared secret/?

-Ben

On 05/19/2017 03:18 PM, Daniel Migault wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Daniel Migault <[email-masked]>
Date: Tue, 23 May 2017 10:02:13 -0400

Thanks I will add these by the end of the day.
Yours,
Daniel

On Mon, May 22, 2017 at 1:56 PM, Benjamin Kaduk <[email-masked]> wrote:

> From: [email-masked] [mailto:[email-masked] <[email-masked]>]
> To: John Mattsson <[email-masked]> <[email-masked]>; Daniel Migault <[email-masked]> <[email-masked]>; [email-masked]
> TLS mailing [email-masked]://www.ietf.org/mailman/listinfo/tls
>
>
>