Subject: [TLS] Definition of cipher suites for TLS 1.2 still possible?

From: "Fries, Steffen" <[email-masked]>
Date: Tue, 2 May 2017 14:07:21 +0000

Hello all,

it may be a naïve question, but is it still possible to define and standardize new cipher suites for TLS 1.2 as an RFC, when TLS 1.3 is almost finished?

The reason for asking is the discussion I started two weeks ago regarding integrity only cipher suites, which are not longer supported in TLS 1.3. While we most likely can cope with this by utilizing TLS 1.2 further as suggested, one question remains regarding the hash functions in the existing integrity only cipher suites. Currently, there is no integrity only cipher suite defined that combines ECDSA and SHA 256. There are only combinations with SHA1. Interestingly, there is one combining RSA and SHA 256.

To no longer depend on SHA1, we would like to standardize a combination of ECDSA and SHA 256 for instance TLS_ECDHE_ECDSA_WITH_NULL_SHA256. Would this still be possible, given the fact, that TLS 1.3 is likely to be finished in near time. I know that this depends on the acceptance of the WG, but I would like to ask first, if there is any intention to close TLS 1.2 for changes and additions, once TLS 1.3 is ready.

Best regards
Steffen

--
Steffen Fries
Siemens AG
Corporate Technology
CT RDA ITS
Otto-Hahn-Ring 6
81739 Muenchen, Germany
Tel.: +49 89 636-633604
Fax: +49 89 636-48000
mailto:[email-masked]
www.siemens.com/ingenuityforlife<https://siemens.com/ingenuityforlife>

Siemens Aktiengesellschaft: Chairman of the Supervisory Board: Gerhard Cromme; Managing Board: Joe Kaeser, Chairman, President and Chief Executive Officer; Roland Busch, Lisa Davis, Klaus Helmrich, Janina Kugel, Siegfried Russwurm, Ralf P. Thomas; Registered offices: Berlin and Munich, Germany; Commercial registries: Berlin Charlottenburg, HRB 12300, Munich, HRB 6684; WEEE-Reg.-No. DE 23691322

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 2 May 2017 14:24:49 +0000

> it may be a naïve question, but is it still possible to define and standardize new cipher suites for TLS 1.2 as an RFC, when TLS 1.3 is almost finished? 

Yes it is.  It might be "informational" not "standards-track" but it's certainly possible/allowed/etc.

---

From: Kyle Rose <[email-masked]>
Date: Tue, 2 May 2017 11:25:40 -0400

On Tue, May 2, 2017 at 10:24 AM, Salz, Rich <[email-masked]> wrote:

> > it may be a naïve question, but is it still possible to define and
> standardize new cipher suites for TLS 1.2 as an RFC, when TLS 1.3 is almost
> finished?
>

Whether it's worth doing or not depends on the objective.

If the desire is to get support for a new TLS 1.2 cipher suite into
browsers or open source TLS stacks, well... good luck with that. If the
desire is to get something working for their own internal use,
standardization is not really necessary, though I would certainly advise
doing whatever is required to get a code point from IANA.

If the desire is somewhere in the middle, such as internal use plus interop
with other organizations within an industry or consortium, then publication
of an informational RFC might make sense. I'm skeptical, however, that they
will get a lot of attention from folks on this list as there seems to be
little interest in spending time on a legacy protocol; and pursuing
something standards track will probably go nowhere.

Kyle

---

From: Peter Gutmann <[email-masked]>
Date: Wed, 3 May 2017 00:27:54 +0000

>standardize new cipher suites for TLS 1.2 as an RFC, when TLS 1.3 is almost

Why not?  TLS 1.2 will be with us for many more years, possibly decades. There
are entire industry segments who are still in the process of moving off TLS
1.0 over the next 5-10 years.

Peter.