Subject: [TLS] Stopping retransmission DTLS 1.2

From: Simon Bernard <[email-masked]>
Date: Wed, 31 May 2017 18:36:23 +0200

Hi,

    The RFC6347, 4.2.4 [1] say :

         "3. The implementation receives the next flight of messages: if 
this
         is the final flight of messages, the implementation transitions to
         FINISHED. If the implementation needs to send a new flight, it
         transitions to the PREPARING state. Partial reads (whether
         partial messages or only some of the messages in the flight) do
         not cause state transitions or timer resets."

    I would like to know why "partial reads do not cause state timer 
resets".

    I mean if we receive the first "handshake message" of the expected 
"flight". we can assume that the foreign peer received our previous 
flight and so we can stop retransmissions of this flight.
    If the next message is lost, we will never respond and so the 
foreign peer should retransmit the whole flight. We don't need to 
retransmit on our side, so timer should be reset ?

    Did I missed something ?

Thx.

Simon

[1]https://tools.ietf.org/html/rfc6347#section-4.2.4

---

From: Raja ashok <[email-masked]>
Date: Thu, 1 Jun 2017 06:20:31 +0000

Hi Simon,

In case of partial read, after retransmit timeout if a DTLS receiver doesn’t retransmits then peer will retransmit its flight again only if it is not the final flight.

Consider a receiver is DTLS client, and peer (server) is sending its final flight (CCS and FM). If any one of the message is not received, then client has to retransmit its previous flight (CKE, CCS and FM) otherwise server wont retransmit its message.

Regards,

Ashok

________________________________
[Company_logo]

Raja Ashok V K
Huawei Technologies
Bangalore, India
http://www.huawei.com
________________________________
本邮件及其附件含有华为公司的保密信息，仅限于发送给上面地址中列出的个人或群组。禁
止任何其他人以任何形式使用（包括但不限于全部或部分地泄露、复制、或散发）本邮件中
的信息。如果您错收了本邮件，请您立即电话或邮件通知发件人并删除本邮件！
This e-mail and its attachments contain confidential information from HUAWEI, which
is intended only for the person or entity whose address is listed above. Any use of the
information contained herein in any way (including, but not limited to, total or partial
disclosure, reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by
phone or email immediately and delete it!

-----Original Message-----
From: TLS [mailto:[email-masked]] On Behalf Of Simon Bernard
Sent: 31 May 2017 22:06
To: [email-masked]
Subject: [TLS] Stopping retransmission DTLS 1.2

Hi,

         "3. The implementation receives the next flight of messages: if this

    I would like to know why "partial reads do not cause state timer resets".

    I mean if we receive the first "handshake message" of the expected "flight". we can assume that the foreign peer received our previous flight and so we can stop retransmissions of this flight.

    If the next message is lost, we will never respond and so the foreign peer should retransmit the whole flight. We don't need to retransmit on our side, so timer should be reset ?

    Did I missed something ?

Thx.

Simon

_______________________________________________

TLS mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/tls