Subject: [TLS] WG Call for adoption of draft-ghedini-tls-certificate-compression

From: Sean Turner <[email-masked]>
Date: Tue, 16 May 2017 08:52:26 -0400

All,

At the IETF 98 meeting in Chicago, there was support in the room to adopt https://datatracker.ietf.org/doc/draft-ghedini-tls-certificate-compression/. We are looking for feedback on adopting this draft form the list. Please respond if you support the draft and are willing to review it. If you object to its adoption, please let us know why. Please respond to the list by 20170530.

Cheers,

J&S

Apologies - we dropped the ball on this adoption call, the call should have gone out with the others.

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 16 May 2017 06:14:53 -0700

I am in favor of adoption

On Tue, May 16, 2017 at 5:52 AM, Sean Turner <[email-masked]> wrote:

> All,
>
> At the IETF 98 meeting in Chicago, there was support in the room to adopt
> https://datatracker.ietf.org/doc/draft-ghedini-tls-
> certificate-compression/. We are looking for feedback on adopting this
> draft form the list. Please respond if you support the draft and are
> willing to review it. If you object to its adoption, please let us know
> why. Please respond to the list by 20170530.
>
> Cheers,
>
> J&S
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 16 May 2017 13:20:45 +0000

In favor, will review.

---

From: David Benjamin <[email-masked]>
Date: Tue, 16 May 2017 18:17:00 +0000

I too am in favor and willing to review it.

---

From: Christopher Wood <[email-masked]>
Date: Tue, 16 May 2017 11:33:30 -0700

I am in favor and willing to review it.

Best,
Chris

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 16 May 2017 23:31:12 -0500

*adds to the chorus*
-Ben

---

From: Russ Housley <[email-masked]>
Date: Wed, 17 May 2017 11:54:20 -0400

I support adoption, and I am willing to review.

I note that this document defines the Certificate structure as:

       struct {
            uint24 uncompressed_length;
            opaque compressed_certificate_message<1..2^24-1>;
       } Certificate;

However, the current TLS 1.3 already defines a Certificate structure as:

      struct {
          opaque certificate_request_context<0..2^8-1>;
          CertificateEntry certificate_list<0..2^24-1>;
      } Certificate;

I think the one in this document should be renamed.

Russ

> On May 16, 2017, at 8:52 AM, Sean Turner <[email-masked]> wrote:
> 
> All,
>