Subject: [TLS] New version of draft-ietf-tls-record-limit

From: Martin Thomson <[email-masked]>
Date: Fri, 8 Sep 2017 15:54:58 +1000

I just posted draft-ietf-tls-record-limit-01.

The changes here are relatively small, but of note:

* endpoints are required to generate a record_overflow alert if the
other side exceeds a negotiated limit

* the size limit calculation is better defined in a few ways (this
includes PR#1 that we discussed during adoption, but the draft also
defines the limit as it applies to TLS 1.2 and earlier)

* there is a new paragraph describing what to do with renegotiation

This now has no open issues.  I'd like to see whether anyone
implements (and whether we can interoperate), but I consider this to
be basically done until reviews tell me otherwise.

---

From: Hubert Kario <[email-masked]>
Date: Mon, 11 Sep 2017 12:59:55 +0200

> * there is a new paragraph describing what to do with renegotiation

what about session resumption?
 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 115, 612 00  Brno, Czech Republic

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Sep 2017 09:52:27 +1000

> what about session resumption?

Fixed on the editor's copy.  Renegotiation and resumption can be the same.