Subject: Re: [TLS] Exported Authenticators proposed change to incorporate authenticator request

From: Nick Sullivan <[email-masked]>
Date: Wed, 06 Dec 2017 21:35:22 +0000

This is an uncontroversial change and nobody has responded from the list,
so unless someone has any objections I'm going to incorporate this change
(along with a change to address Benjamin Kaduk's comments) and publish a
new draft next week.

Nick

On Thu, Nov 23, 2017 at 1:18 PM Nick Sullivan <[email-masked]>
wrote:

> Martin Thomson raised an issue Github (Issue #5
> <https://github.com/tlswg/tls-exported-authenticator/issues/5>)
> suggesting that we modify the exported authenticators draft to include the
> ability to incorporate a CertificateRequest into an authenticator. I have
> put together a set of changes to the draft to incorporate this suggestion:
> https://github.com/tlswg/tls-exported-authenticator/pull/9
>
> The advantage of this change is that it provides a more explicit binding
> between a request for an authenticator (which includes TLS extensions) and
> the authenticator itself. This change also significantly simplifies the HTTP/2
> Additional Certificates draft
> <https://tools.ietf.org/html/draft-bishop-httpbis-http2-additional-certs-04>
> that depends on exported authenticators. I presented this change at IETF
> 100 and there were no objections.
>
> Comments welcome,
> Nick
>
>
>
>
>
>

---

From: Sean Turner <[email-masked]>
Date: Fri, 8 Dec 2017 13:10:01 -0500

Nick,

Agreed - it’s been a bit so merging next week seems good.  That way we might have a new version to read over the holidaze!

spt

> On Dec 6, 2017, at 16:35, Nick Sullivan <[email-masked]> wrote:
> 
> This is an uncontroversial change and nobody has responded from the list, so unless someone has any objections I'm going to incorporate this change (along with a change to address Benjamin Kaduk's comments) and publish a new draft next week.
> 
> Nick
> 
> On Thu, Nov 23, 2017 at 1:18 PM Nick Sullivan <[email-masked]> wrote:
> Martin Thomson raised an issue Github (Issue #5) suggesting that we modify the exported authenticators draft to include the ability to incorporate a CertificateRequest into an authenticator. I have put together a set of changes to the draft to incorporate this suggestion:
> The advantage of this change is that it provides a more explicit binding between a request for an authenticator (which includes TLS extensions) and the authenticator itself. This change also significantly simplifies the HTTP/2 Additional Certificates draft that depends on exported authenticators. I presented this change at IETF 100 and there were no objections.
> 
> Comments welcome,
> Nick
> 
>  
> 
> 
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls