Subject: Re: [TLS] WGLC for draft-ietf-tls-record-limit

From: Sean Turner <[email-masked]>
Date: Mon, 5 Feb 2018 09:19:28 -0500

Martin’s got an editor’s copy that incorporates all WGLC to date.  The WGLC for this draft ends tomorrow so if you have any more comments please send them in by then.

Note I’ve also uploaded the Shepherd’s write-up; I used the abbreviated version.

Cheers,

spt

> On Jan 22, 2018, at 18:41, Martin Thomson <[email-masked]> wrote:
> 
> On Tue, Jan 23, 2018 at 3:42 AM, Ilari Liusvaara
> <[email-masked]> wrote:
>> Since the count includes the content type byte in TLS 1.3, the maximum
>> value for TLS 1.3 is 16385 bytes, not 2^14=16384.
> 
> Yes, the editor's copy says:
> 
> For TLS 1.2 and earlier, that limit is 2^14 octets. TLS 1.3 uses a
> limit of 2^14+1 octets.

---

From: Sean Turner <[email-masked]>
Date: Mon, 5 Feb 2018 11:11:39 -0500

Martin,

This draft is probably going to arrive in the RFC Editor’s queue weeks before draft-ietf-tls-iana-registry-updates.  I’m thinking that it would be okay to add the text that indicates this a "Yes" for the newly minted Recommended column.  Along the same lines, I guess the question is should the value for max_fragment_length be “No" in this draft as well (I’ve got it as “Yes” right now)?

spt

> On Jan 22, 2018, at 00:12, Sean Turner <[email-masked]> wrote:
> 
> All,’
> 
> This is the working group last call for the "Record Size Limit Extension for TLS" draft available at http://datatracker.ietf.org/doc/draft-ietf-tls-record-limit/.  Please review the document and send your comments to the list by 6 February 2018.
> 
> Thanks your chairs: J&S

---

From: Sean Turner <[email-masked]>
Date: Mon, 5 Feb 2018 11:28:28 -0500

never mind. this is address in the IANA section:

   "it is recommended and marked as "Encrypted" in TLS 1.3."

> On Feb 5, 2018, at 11:11, Sean Turner <[email-masked]> wrote:
> 
> Martin,
>