Subject: [TLS] Genart last call review of draft-ietf-tls-iana-registry-updates-04

From: Stewart Bryant <[email-masked]>
Date: Tue, 20 Feb 2018 11:50:47 -0800

Reviewer: Stewart Bryant
Review result: Ready with Issues

I am the assigned Gen-ART reviewer for this draft. The General Area
Review Team (Gen-ART) reviews all IETF documents being processed
by the IESG for the IETF Chair.  Please treat these comments just
like any other last call comments.

For more information, please see the FAQ at

<https://trac.ietf.org/trac/gen/wiki/GenArtfaq>.

Document: draft-ietf-tls-iana-registry-updates-05
Reviewer: Stewart Bryant
Review Date: 2018-02-20
IETF LC End Date: 2018-03-01
IESG Telechat date: 2018-03-08

Summary: A well written document that is difficult to check and easy to make a
mistake with. There are a tiny number of editorial matters. The matter of the
semantics of Recommended = no may need to further thought and clarification.

Major issues: None

Minor issues:

I think convention is to list the documents being updated in the Abstract, but
cannot find any formal guidance.

======

  If an item is marked as not recommended it does not necessarily mean
SB> Do you mean "marked as not recommended" or "not marked as recommended".

=======
SB>  I am worried about the semantics of Recommended = no.
SB> Presumably there are three states: recommended, not recommended,
SB> and silent/don't know/don't care/not yet. Which of these
SB> states does Recommended = no represent?

Nits/editorial comments:
Abstract

   This document describes a number of changes to (D)TLS IANA registries

SB> TLS is not a well known abbreviation and so needs expanding

========

   This document instructs IANA to make changes to a number of (D)TLS-

SB> TLS needs expanding

---

From: Sean Turner <[email-masked]>
Date: Tue, 27 Feb 2018 09:11:28 -0500

> On Feb 20, 2018, at 14:50, Stewart Bryant <[email-masked]> wrote:
> 
> Reviewer: Stewart Bryant

You’re right that is the convention, but it’s not required.  draft-flanagan-7322bis is attempting to make including updates in the abstract a must, but it’s not been through any kind of LC yet.  There is a sentence there saying that a lot of RFCs are updated and to see the updates header so I think under the 7322 to balance concise and to not include references I’m thinking this is okay.

> SB> Do you mean "marked as not recommended" or "not marked as recommended”.

There are two states for the Recommended column: YES and NO.  I can go either way on whether
marked as not recommended = NO
not marked as recommended = NO

WG - thoughts?

> SB> states does Recommended = no represent?

There are two states and a draft that specifies a value in a registry that has a Recommended column needs to state which it is.  I’m not too concerned because we can change the column value later if it turns out a NO should have been a YES.

> SB> TLS is not a well known abbreviation and so needs expanding

Right well I should fix that ;)

I made the following tweak:

OLD:

  (D)TLS

NEW

  Transport Layer Security and Datagram Transport Layer Security ((D)TLS)

PR:
https://github.com/tlswg/draft-ietf-tls-iana-registry-updates/pull/63

>   This document instructs IANA to make changes to a number of (D)TLS-

See above.

spt

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 27 Feb 2018 08:51:59 -0600

> not marked as recommended = NO

I thought we had always been clear that it was "not marked as
recommended", i.e., "we make no comment about its status".

-Ben

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 27 Feb 2018 14:55:22 +0000

>   recommended", i.e., "we make no comment about its status".

That was my understanding to.  The choices are "recommended" or "no comment"

---

From: Sean Turner <[email-masked]>
Date: Tue, 27 Feb 2018 09:55:48 -0500

> On Feb 27, 2018, at 09:51, Benjamin Kaduk <[email-masked]> wrote:
> 

In s6 it is "marked as not recommended”.  This is easily changed.

spt

---

From: Sean Turner <[email-masked]>
Date: Tue, 27 Feb 2018 09:56:23 -0500

> On Feb 27, 2018, at 09:55, Salz, Rich <[email-masked]> wrote:
> 
> 
> That was my understanding to.  The choices are "recommended" or "no comment”

Yes, but we put “NO” as a column value.

spt

---

From: Sean Turner <[email-masked]>
Date: Tue, 27 Feb 2018 09:59:13 -0500

> On Feb 27, 2018, at 09:55, Sean Turner <[email-masked]> wrote:
> 
> 
>

---

From: Russ Housley <[email-masked]>
Date: Tue, 27 Feb 2018 11:21:57 -0500

> You’re right that is the convention, but it’s not required.  draft-flanagan-7322bis is attempting to make including updates in the abstract a must, but it’s not been through any kind of LC yet.  Th…

If another update top the document is needed, then it does not seem hard to comply with the coming convention.

======
> not marked as recommended = NO

I think the second wording is more clear.

> There are two states and a draft that specifies a value in a registry that has a Recommended column needs to state which it is.  I’m not too concerned because we can change the column value later i…

It would be more clear is Section 6 said that each parameter will have either "yes" or "no" in the new recommended column.

Russ

---

From: Sean Turner <[email-masked]>
Date: Tue, 27 Feb 2018 14:22:03 -0500

> On Feb 27, 2018, at 11:21, Russ Housley <[email-masked]> wrote:
> 
> 
>>> Minor issues:
>>> 

Just an FYI I plan to object to the coming convention :)

> I think the second wording is more clear.

fixed

> It would be more clear is Section 6 said that each parameter will have either "yes" or "no" in the new recommended column.

Can do:

OLD:

  The instructions in this document add a Recommended column to many of the
  TLS registries

NEW:

  The instructions in this document add a Recommended column with a value
  of YES or NO to many of the (D)TLS registries

PR: https://github.com/tlswg/draft-ietf-tls-iana-registry-updates/pull/63