Subject: [TLS] Recommended yes->no for max_fragment_length extension?

From: Sean Turner <[email-masked]>
Date: Wed, 7 Feb 2018 15:33:59 -0500

All,

Prior to pushing draft-ietf-tls-record-limit [0] to the IESG, the WG needs to confirm that draft-ietf-tls-record-limit should change max_fragment_length [1] from “Yes” in our soon to be created Recommended column (see [2]) to a “No”.  Please indicate by 2359 UTC on 14 Feb whether you are for or against this change; and if you are against please indicate why.

spt

[0] https://datatracker.ietf.org/doc/draft-ietf-tls-record-limit/
[1] https://datatracker.ietf.org/doc/rfc6066/
[2] https://datatracker.ietf.org/doc/draft-ietf-tls-iana-registry-updates/

---

From: Russ Housley <[email-masked]>
Date: Wed, 7 Feb 2018 15:37:48 -0500

If the WG is going to publish the standards track RFC, then the extension it defines should say 'Yes' in the recommended column.

Russ

> On Feb 7, 2018, at 3:33 PM, Sean Turner <[email-masked]> wrote:
> 
> All,
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 7 Feb 2018 12:55:30 -0800

I am for this change.

-Ekr

On Wed, Feb 7, 2018 at 12:33 PM, Sean Turner <[email-masked]> wrote:

> All,
>
> Prior to pushing draft-ietf-tls-record-limit [0] to the IESG, the WG needs
> to confirm that draft-ietf-tls-record-limit should change
> max_fragment_length [1] from “Yes” in our soon to be created Recommended
> column (see [2]) to a “No”.  Please indicate by 2359 UTC on 14 Feb whether
> you are for or against this change; and if you are against please indicate
> why.
>
> spt
>

---

From: Martin Thomson <[email-masked]>
Date: Thu, 8 Feb 2018 07:56:36 +1100

This is about the OLD extension.  I think that NO is appropriate for
something we deprecate.

https://github.com/tlswg/tls-record-limit/pull/14

---

From: Russ Housley <[email-masked]>
Date: Wed, 7 Feb 2018 16:11:01 -0500

I misread the question.  You are right, is should be "No".

Russ

> On Feb 7, 2018, at 3:56 PM, Martin Thomson <[email-masked]> wrote:
>

---

From: Sean Turner <[email-masked]>
Date: Tue, 13 Feb 2018 18:15:48 -0500

Just a reminder ...

> On Feb 7, 2018, at 15:33, Sean Turner <[email-masked]> wrote:
> 
> All,
>

---

From: Sean Turner <[email-masked]>
Date: Thu, 15 Feb 2018 08:35:58 -0500

There were a few yeses and no nos.  I”m going to go ahead and declare this rough consensus, with the thought that if there are those who object there is still time during the IETF LC.

Martin - please spin a new version incorporating PR#14 to address this issue.

Once I see a new version I’ll push it towards Kathleen.

spt