Subject: Re: [TLS] Middlebox Security Protocol initial drafts

From: Eric Rescorla <[email-masked]>
Date: Fri, 13 Apr 2018 08:36:07 -0700

Hi Tony,

Thanks for forwarding these.

I haven't had time to give them a thorough review, but on a quick skim I
notice that this seems to be based on TLS 1.2 and to use a bunch of
algorithms we are trying to deprecate (e.g., CBC). Is there a reason not to
start with TLS 1.3 and more modern algorithms?

-Ekr

On Fri, Apr 13, 2018 at 8:07 AM, Tony Rutkowski <
[email-masked]> wrote:

> As everyone is aware, the decision was taken
> within the IETF TLS community not to undertake
> work perceived to compromise TLS 1.3 and related
> protocols.  At the same time, there has been
> recognition that a considerable number of use
> cases exist where alternative transport, network
> and application layer implementations are
> necessary in both network infrastructures and data
> centres.
>
> The work on those alternative implementations has
> proceeded over a two year period in ETSI's Cyber
> Security Technical Committee (TC CYBER). In the
> spirit of some level of collaboration between ETSI
> and the IETF community, as well as public
> transparency, CYBER is making available two draft
> parts of a Technical Specification called the
> Middlebox Security Protocol.  The motivation is to
> address one of the most difficult security
> challenges today: how to enable network operators
> and end-users to cooperate in managing encryption
> security for their applications.  The drafts are
> available at:
>
> https://docbox.etsi.org/CYBER/CYBER/Open/Latest_Drafts
>
> Note that there are two problems being pursued
> here.  The Middlebox Security Protocol enables the
> existence of a “smart proxy” where end-users can
> be potentially aware of a middlebox in their
> traffic stream (visibility) and control what that
> middlebox sees for different purposes
> (observability). The result allows for balancing
> privacy, network operations, and security for
> different applications. With the Protocol, both
> users and providers gain the ability to grant or
> restrict the permissions for visibility and
> observability.
>
> Part 1 of the Middlebox Security Protocol
> specification defines the generic capabilities and
> security requirements. Additional parts define
> specific implementations in the form of profiles
> for different use cases that can be mapped to the
> Part 1 requirements.
>
> Part 2 provides a common profile for widespread
> network use known in the research community as
> mcTLS.  Included with Part 2 are a patch for a
> known vulnerability as well as an exemplar of use
> by Mobile Network Operators. Other profiles will
> be released over the coming months – especially
> one for data centre access control to meet the
> critical needs of enterprise network communities.
>
> These initial two draft specifications are
> relatively complete and stable, and derived from
> best-of-breed solutions drawn from extensive
> surveys and evaluation of the considerable
> published technical literature. However, this
> work is new, complex, and unique.
>
> In addition, TC CYBER is proactively sending the
> drafts to other industry standards bodies as well
> as holding a Hot Middlebox Workshop (12 June 2018)
> and Hackathon (12-13 June 2018), in Sophia-Antipolis
> France, where the coding community can seek to
> implement and hack a test implementation of Part 2.
> It is all open, and free.
>
> In addition to collaboration and comments on this list,
> comments are also solicited at [email-masked]
>
> --tony r
>
>
>

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 13 Apr 2018 09:26:07 -0700

n Fri, Apr 13, 2018 at 9:19 AM, Tony Rutkowski <
[email-masked]> wrote:

> Good observation. When the work started, 1.3 was a work in progress and
> the rapporteurs wanted to move forward with an initial test of concept
> based on considerable published work out there.  In addition, the use of
> 1.2 will be around for many years if not forever in some environments.
>

I certainly agree that this is true, but given that you're designing a new
protocol, it's not clear to me that the installed base is that relevant.

I also don't think this addresses the question of algorithms, given that
TLS 1.2 supports modern algorithms

-Ekr

The idea is to start a momentum for enabling middlebox visibility and
> traffic observability (Part 1), and then rolling out and encouraging
> multiple profiles.
>
> To give credit here, the concepts are those of pioneers like David Naylor
> and Justine Sherry. (Her slogan that "middleboxes are the drama queens of
> networking" has become legend.)
>
> Tony
>
> On Apr 13, 2018 11:36 AM, Eric Rescorla <[email-masked]> wrote:
>
> Hi Tony,
>