Subject: [TLS] OID for delegated credentials

From: Subodh Iyengar <[email-masked]>
Date: Thu, 9 Aug 2018 05:07:43 +0000

We've been kicking this can down the road for a while, but we probably should choose an OID for Delegated credentials

So far we've been doing interop with Cloudflare's OID of 1.3.6.1.4.1.44363.44.  I'd be fine with putting that as the final OID the draft. Does anyone have any thoughts on whether we should / should not do this and use a different OID instead.

Cheers,

Subodh

---

From: Sean Turner <[email-masked]>
Date: Thu, 9 Aug 2018 08:37:50 -0400

Ah okay you didn’t put that OID in the draft (excellent)!

The other option is to get it from the PKIX id-pe arc (https://www.iana.org/assignments/smi-numbers/smi-numbers.xhtml#smi-numbers-1.3.6.1.5.5.7.1)*.  Whatever you do don’t use 30 or 31 ;). To get an early assignment, we basically just need to figure out whether you think this is stable enough to go through the early assignment process.

spt

* Russ Housley is the designated expert for the arc.

> On Aug 9, 2018, at 01:07, Subodh Iyengar <[email-masked]> wrote:
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Melinda Shore <[email-masked]>
Date: Sat, 11 Aug 2018 12:56:13 -0800

On 8/8/18 9:07 PM, Subodh Iyengar wrote:
> So far we've been doing interop with Cloudflare's OID of
> 1.3.6.1.4.1.44363.44.  I'd be fine with putting that as the final OID
> the draft. Does anyone have any thoughts on whether we should / should
> not do this and use a different OID instead.

One thing we've found is that it's inevitable that when an OID
is chosen from a private arc, it's raised as an issue during
various last calls, but I've never seen it be a show-stopper.

Melinda

-- 
Software longa, hardware brevis

PGP fingerprint: 4F68 2D93 2A17 96F8 20F2
                 34C0 DFB8 9172 9A76 DB8F