Subject: [TLS] 0-RTT profiles

From: Joseph Birr-Pixton <[email-masked]>
Date: Mon, 6 Aug 2018 19:01:42 +0100

Hello,

> Application protocols MUST NOT use 0-RTT data without a profile that defines its use.
> That profile needs to identify which messages or interactions are safe to use with 0-RTT
> and how to handle the situation when the server rejects 0-RTT and falls back to 1-RTT.

0-RTT has now at least two large deployments on the public internet
that I know of. Are there any such "profiles" published or being
worked on?

Thanks for any pointers.

Cheers,
Joe

---

From: Ilari Liusvaara <[email-masked]>
Date: Mon, 6 Aug 2018 21:16:33 +0300

> that I know of. Are there any such "profiles" published or being

The HTTP profile is in RFC-Editor queue (draft-ietf-httpbis-replay).

-Ilari

---

From: Benjamin Kaduk <[email-masked]>
Date: Mon, 6 Aug 2018 13:20:33 -0500

> that I know of. Are there any such "profiles" published or being

draft-ietf-httpbis-replay is in the RFC Editor's queue.

-Ben