Subject: [TLS] Uniqueness of values in lists?

From: Hubert Kario <[email-masked]>
Date: Thu, 09 Aug 2018 16:41:58 +0200

I've noticed that while there is an explicit requirement for extension types 
to be unique for any given message:

https://tools.ietf.org/html/draft-ietf-tls-tls13-28#page-43:

   There MUST NOT be more than one extension of the
   same type in a given extension block.

and for key_shares:

https://tools.ietf.org/html/draft-ietf-tls-tls13-28#page-54

   Clients MUST NOT offer multiple KeyShareEntry values
   for the same group.

I don't see a similar requirement for other lists of values: 
signature_algorithms, supported_groups, cipher_suites, etc.

Did I miss something?
-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 115, 612 00  Brno, Czech Republic

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 9 Aug 2018 07:44:24 -0700

> signature_algorithms, supported_groups, cipher_suites, etc.

Nope. I don't believe it's a current requirement.

-Ekr

-- 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>
>

---

From: Viktor Dukhovni <[email-masked]>
Date: Thu, 9 Aug 2018 11:35:32 -0400

> On Aug 9, 2018, at 10:41 AM, Hubert Kario <[email-masked]> wrote:
> 

Those can be in conflict if repeated, because they (often)
carry parameters.

> signature_algorithms, supported_groups, cipher_suites, etc.

These are simple lists of values with no parameters, and mere
duplication, though pointless, creates no ambiguity.

-- 
	Viktor.