Subject: [TLS] draft-ietf-tls-subcerts-01: some nits a question

From: Sean Turner <[email-masked]>
Date: Thu, 9 Aug 2018 14:34:17 -0400

Hi,

I submitted a PR to address some nits I noticed:
https://github.com/tlswg/tls-subcerts/pull/17

One question:

In s3, public_key is the same thing as RawPublicKey in RFC 7250, i.e., they are both DER-encoded SPKI from RFC5280? If it is, does it make sense to reuse:
opaque ASN.1_subjectPublicKeyInfo<1..2^24-1> ?
If not, shouldn’t
public_key<0..2^16-1>;
be
public_key<1..2^16-1>;
or
public_key<1..2^24-1>

spt

---

From: Subodh Iyengar <[email-masked]>
Date: Thu, 9 Aug 2018 21:41:54 +0000

Ya you're right here it is the DER-encoded SPKI and opaque ASN.1_subjectPublicKeyInfo is the right way to go.

Thanks,

Subodh

________________________________
From: TLS <[email-masked]> on behalf of Sean Turner <[email-masked]>
Sent: Thursday, August 9, 2018 11:34:17 AM
To: [email-masked]
Subject: [TLS] draft-ietf-tls-subcerts-01: some nits a question

Hi,

One question:

spt

_______________________________________________
TLS mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_tls&d=DwIGaQ&c=5VD0RTtNlTh3ycd41b3MUw&r=h3Ju9EBS7mHtwg-wAyN7fQ&m=IrOKyHv0mMG3XQlDR58bcZJrllo1irdlbauz8t892yI&s=WCIr65m_Feq1ii72j9Ec0ftL44J0j4f-3zWbbZgcAjU&e=