Subject: [TLS] [Editorial Errata Reported] RFC8422 (5468)

From: RFC Errata System <[email-masked]>
Date: Thu, 16 Aug 2018 19:21:37 -0700 (PDT)

The following errata report has been submitted for RFC8422,
"Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and Earlier".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5468

--------------------------------------
Type: Editorial
Reported by: Masato Gosui <[email-masked]>

Section: 5.4

Original Text
-------------
   namedCurve: Specifies a recommended set of elliptic curve domain

Corrected Text
--------------
   namedcurve: Specifies a recommended set of elliptic curve domain

Notes
-----
This fixes mismatched names of the variable "namedcurve" in the "Structure of this message" paragraph.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8422 (draft-ietf-tls-rfc4492bis-17)
--------------------------------------
Title               : Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and Earlier
Publication Date    : August 2018
Author(s)           : Y. Nir, S. Josefsson, M. Pegourie-Gonnard
Category            : PROPOSED STANDARD
Source              : Transport Layer Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Simon Josefsson <[email-masked]>
Date: Fri, 17 Aug 2018 10:25:47 +0200

I think “namedCurve” is better, it matches ASN.1 usage.

/Simon

> 17 aug. 2018 kl. 04:21 skrev RFC Errata System <[email-masked]>:
>

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 17 Aug 2018 17:37:35 -0500

> I think “namedCurve” is better, it matches ASN.1 usage.

So you want me to change the PDU to be "namedCurve" instead?

-Ben

---

From: Masato Gosui <[email-masked]>
Date: Tue, 21 Aug 2018 05:05:57 +0000

If a new errata proposing the PDU change is needed, I gladly submit it.

--
Masato Gosui

    
    -Ben

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 22 Aug 2018 17:57:57 -0500

No need to submit a new one -- I can edit it as needed.

-Ben