Subject: [TLS] WGLC for draft-ietf-tls-dtls-connection-id-03

From: Joseph Salowey <[email-masked]>
Date: Mon, 4 Mar 2019 08:42:40 -0800

This is a working group last call
for draft-ietf-tls-dtls-connection-id-03.  The last working group last call
resulted in some issues.  The authors worked with the reviewers to publish
a new draft to address these issue. Please focus your review on the changes
since the previous last call.  You can find a link to a diff with the
previous draft on the tools page [1].  Please response to the list with any
comments by 2359 UTC on 12 March 2019.

Thanks,

Chris, Joe and Sean

[1] https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-03

---

From: "Martin Thomson" <[email-masked]>
Date: Mon, 04 Mar 2019 21:23:10 -0500

LGTM.

I would strike ", if these privacy properties are important in a given deployment" from the acknowledgments section (which is an odd place for the accompanying statement. 

I would add an explicit note about the lack of CID update making this unsuitable for mobility scenarios.  That's a common use case for this sort of mechanism, but this design lacks any defense against linkability.

On Tue, Mar 5, 2019, at 03:43, Joseph Salowey wrote:
> This is a working group last call for 
> draft-ietf-tls-dtls-connection-id-03. The last working group last call 
> resulted in some issues. The authors worked with the reviewers to 
> publish a new draft to address these issue. Please focus your review on 
> the changes since the previous last call. You can find a link to a diff 
> with the previous draft on the tools page [1]. Please response to the 
> list with any comments by 2359 UTC on 12 March 2019. 
> 
> Thanks,
> 
> Chris, Joe and Sean
> 
> [1] https://tools..ietf.org/html/draft-ietf-tls-dtls-connection-id-03 
> <https://tools.ietf.org/html/draft-ietf-tls-dtls-connection-id-03>
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Thomas Fossati <[email-masked]>
Date: Tue, 5 Mar 2019 06:53:22 +0000

On Mon, Mar 4, 2019 at 4:43 PM Joseph Salowey <[email-masked]> wrote:
> This is a working group last call for draft-ietf-tls-dtls-connection-id-03.  The last working group last call resulted in some issues.  The authors worked with the reviewers to publish a new draft to address these issue. Please focus your review on the changes since the previous last call.  You can find a link to a diff with the previous draft on the tools page [1].  Please response to the list with any comments by 2359 UTC on 12 March 2019.
> Thanks,
>
> Chris, Joe and Sean
>

-05 describes CID processing with AEAD ciphersuites only, which seems
to imply that CID modifies ciphersuite's selection -- and it's
incompatible with EtM.

I looks like the interaction between CID, non-AEAD modes and EtM
should be clarified.

Cheers,