Subject: [TLS] [Technical Errata Reported] RFC8448 (5720)

From: RFC Errata System <[email-masked]>
Date: Sun, 5 May 2019 15:36:20 -0700 (PDT)

The following errata report has been submitted for RFC8448,
"Example Handshake Traces for TLS 1.3".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5720

--------------------------------------
Type: Technical
Reported by: Martin Thomson <[email-masked]>

Section: GLOBAL

Original Text
-------------
00 0d 00 20 00 1e 04 03 05 03 06 03 02 03 08 04 08 05
08 06 04 01 05 01 06 01 02 01 04 02 05 02 06 02 02 02 

Corrected Text
--------------
00 0d 00 18 00 16 04 03 05 03 06 03 02 03 08 04 08 05
08 06 04 01 05 01 06 01 02 01

Notes
-----
The traces all show DSA signature schemes in ClientHello messages.  The use of these is prohibited by RFC 8446.  To be compliant, these would be removed.

Note that this isn't a simple substitution as implied above.  The length fields on all of the messages would also need to be reduced by 8 in addition to making the substitution.  The value of the PSK binders used in the resumption case in Section 4 would need to be recalculated also.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8448 (draft-ietf-tls-tls13-vectors-07)
--------------------------------------
Title               : Example Handshake Traces for TLS 1.3
Publication Date    : January 2019
Author(s)           : M. Thomson
Category            : INFORMATIONAL
Source              : Transport Layer Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 5 May 2019 18:12:12 -0500

I guess we want Hold For Document Update?

-Ben

---

From: Martin Thomson <[email-masked]>
Date: Mon, 6 May 2019 13:32:22 +1000

That would work for me.

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 08 May 2019 10:27:47 -0400

+1