Subject: [TLS] External PSK design team

From: Sean Turner <[email-masked]>
Date: Mon, 20 Jan 2020 23:01:05 -0500

At IETF 106, we discussed forming a design team to focus on external PSK management and usage for TLS. The goal of this team would be to produce a document that discusses considerations for using external PSKs, privacy concerns (and possible mitigations) for stable identities, and more developed mitigations for deployment problems such as Selfie. If you have an interest in participating on this design team, please reply to this message and state so by 2359 UTC 31 January 2020.

Cheers,

Joe and Sean

---

From: Rob Sayre <[email-masked]>
Date: Mon, 20 Jan 2020 20:54:00 -0800

On Mon, Jan 20, 2020 at 8:01 PM Sean Turner <[email-masked]> wrote:

> At IETF 106, we discussed forming a design team to focus on external PSK
> management and usage for TLS. The goal of this team would be to produce a
> document that discusses considerations for using external PSKs, privacy
> concerns (and possible mitigations) for stable identities, and more
> developed mitigations for deployment problems such as Selfie. If you have
> an interest in participating on this design team, please reply to this
> message and state so by 2359 UTC 31 January 2020.
>

Today is a holiday in the US, so you might not hear back until folks in the
US catch up tomorrow.

thanks,
Rob

---

From: Colm MacCárthaigh <[email-masked]>
Date: Mon, 20 Jan 2020 21:33:20 -0800

Interested, as it happens - this is something I've been working on at Amazon.

On Mon, Jan 20, 2020 at 8:01 PM Sean Turner <[email-masked]> wrote:
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

-- 
Colm

---

From: Mohit Sethi M <[email-masked]>
Date: Tue, 21 Jan 2020 09:45:06 +0000

I am certainly interested and willing to contribute. We need some 
consensus on whether PSKs can be shared with more than 2 parties, 
whether the parties can switch roles, etc.

EMU is going to work on EAP-TLS-PSK and the question of 
privacy/identities will pop-up there too.

--Mohit

---

From: Björn Haase <[email-masked]>
Date: Tue, 21 Jan 2020 09:52:19 +0000

Hello to all,

I am also willing to contribute. My concern is that I observe that in some industrial control applications, PSK mechanisms (that actually require high-entropy keys) are (mis)-used in conjunction with TLS, where the PSK is actually of insufficient entropy (maybe derived only from a 4 digit PIN).

In order to fix this issue, I'd really appreciate to have an PSK-style TLS operation using a balanced PAKE (note that this could be implemented with virtually no computational overhead in comparison to conventional ECDH session key generation).

Yours,

Björn.

Mit freundlichen Grüßen I Best Regards 

Dr. Björn Haase 

Senior Expert Electronics | TGREH Electronics Hardware
Endress+Hauser Conducta GmbH+Co.KG | Dieselstrasse 24 | 70839 Gerlingen | Germany
Phone: +49 7156 209 377 | Fax: +49 7156 209 221
[email-masked] |  www.conducta.endress.com 

Endress+Hauser Conducta GmbH+Co.KG
Amtsgericht Stuttgart HRA 201908
Sitz der Gesellschaft: Gerlingen
Persönlich haftende Gesellschafterin:
Endress+Hauser Conducta Verwaltungsgesellschaft mbH
Sitz der Gesellschaft: Gerlingen
Amtsgericht Stuttgart HRA 201929
Geschäftsführer: Dr. Manfred Jagiella

Gemäss Datenschutzgrundverordnung sind wir verpflichtet, Sie zu informieren, wenn wir personenbezogene Daten von Ihnen erheben.
Dieser Informationspflicht kommen wir mit folgendem Datenschutzhinweis (https://www.endress.com/de/cookies-endress+hauser-website) nach.

Disclaimer: 

The information transmitted is intended only for the person or entity to which it is addressed and may contain confidential, proprietary, and/or privileged material. Any review, retransmission, dissemination or other use of, or taking of any action in reliance upon, this information by persons or entities other than the intended recipient is prohibited. If you receive this in error, please contact the sender and delete the material from any computer. This e-mail does not constitute a contract offer, a contract amendment, or an acceptance of a contract offer unless explicitly and conspicuously designated or stated as such.

-----Ursprüngliche Nachricht-----
Von: TLS <[email-masked]> Im Auftrag von Mohit Sethi M
Gesendet: Dienstag, 21. Januar 2020 10:45
An: Colm MacCárthaigh <[email-masked]>; Sean Turner <[email-masked]>
Cc: TLS List <[email-masked]>
Betreff: Re: [TLS] External PSK design team

--Mohit

On 1/21/20 7:33 AM, Colm MacCárthaigh wrote:
>> https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftls&amp;data=02%7C01%7Cbjoern.haase%40endress.com%7C5af7f9dcd2f746b6638a08d79e56a7dc%7C52daf2a93b734da4ac6a3f81adc92b7e%7C1%7C0%7C637151967330246544&amp;sdata=xtt%2F1mxS0XbrTQ8mExdzUP%2F%2BHSJKrXANsVqsX%2F4sUZA%3D&amp;reserved=0
>
>
_______________________________________________
TLS mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Ftls&amp;data=02%7C01%7Cbjoern.haase%40endress.com%7C5af7f9dcd2f746b6638a08d79e56a7dc%7C52daf2a93b734da4ac6a3f81adc92b7e%7C1%7C0%7C637151967330246544&amp;sdata=xtt%2F1mxS0XbrTQ8mExdzUP%2F%2BHSJKrXANsVqsX%2F4sUZA%3D&amp;reserved=0

---

From: Mohit Sethi M <[email-masked]>
Date: Tue, 21 Jan 2020 10:04:10 +0000

I would let CFRG deal with the PAKE selection process: 
https://mailarchive.ietf.org/arch/msg/cfrg/-a1sW3jK_5avmb98zmFbCNLmpAs 
and not have this design team spend time and energy on designing PAKEs.

--Mohit

---

From: Jonathan Hoyland <[email-masked]>
Date: Tue, 21 Jan 2020 10:49:42 +0000

Hi All,

This is something I'm very interested in.

Definitely want to participate.

Regards,

Jonathan

On Tue, 21 Jan 2020 at 10:04, Mohit Sethi M <mohit.m.sethi=
[email-masked]> wrote:

> > I am also willing to contribute. My concern is that I observe that in
> some industrial control applications, PSK mechanisms (that actually require
> high-entropy keys) are (mis)-used in conjunction with TLS, where the PSK is
> actually of insufficient entropy (maybe derived only from a 4 digit PIN).
> >
> > In order to fix this issue, I'd really appreciate to have an PSK-style
> TLS operation using a balanced PAKE (note that this could be implemented
> with virtually no computational overhead in comparison to conventional ECDH
> session key generation).
> >
> > Yours,
> >
> > Björn.
> >
> >
> >
> > Gemäss Datenschutzgrundverordnung sind wir verpflichtet, Sie zu
> informieren, wenn wir personenbezogene Daten von Ihnen erheben.
> > Dieser Informationspflicht kommen wir mit folgendem Datenschutzhinweis (
> https://www.endress.com/de/cookies-endress+hauser-website) nach.
> >
> >
> >
> >
> >
> > Disclaimer:
> >
> > The information transmitted is intended only for the person or entity to
> which it is addressed and may contain confidential, proprietary, and/or
> privileged material. Any review, retransmission, dissemination or other use
> of, or taking of any action in reliance upon, this information by persons
> or entities other than the intended recipient is prohibited. If you receive
> this in error, please contact the sender and delete the material from any
> computer. This e-mail does not constitute a contract offer, a contract
> amendment, or an acceptance of a contract offer unless explicitly and
> conspicuously designated or stated as such.
> >
> >
> >
> >>> At IETF 106, we discussed forming a design team to focus on external
> PSK management and usage for TLS. The goal of this team would be to produce
> a document that discusses considerations for using external PSKs, privacy

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 21 Jan 2020 06:52:22 -0800

I am willing to contribute.

-Ekr

On Tue, Jan 21, 2020 at 2:50 AM Jonathan Hoyland <[email-masked]>
wrote:

>> > The information transmitted is intended only for the person or entity
>> to which it is addressed and may contain confidential, proprietary, and/or

---

From: Russ Housley <[email-masked]>
Date: Tue, 21 Jan 2020 10:10:33 -0500

Sean:

I can help with this design team.

Russ

> On Jan 20, 2020, at 11:01 PM, Sean Turner <[email-masked]> wrote:
>