Subject: Re: [TLS] comments on draft-subcerts

From: "Salz, Rich" <[email-masked]>
Date: Tue, 14 Jul 2020 19:37:57 +0000

I would love to see a sample cert and private key in “PEM format” and samples of the TLS extensions encoded, or even a simplified handshake dump.

---

From: Watson Ladd <[email-masked]>
Date: Tue, 14 Jul 2020 15:51:24 -0400

> I would love to see a sample cert and private key in “PEM format” and samples of the TLS extensions encoded, or even a simplified handshake dump.

https://github.com/tlswg/tls-subcerts/pull/77
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Russ Housley <[email-masked]>
Date: Tue, 14 Jul 2020 17:56:24 -0400

Watson:

This does not look right to me.  The extensions in the certificate are:

  extensions=Extensions:
   Extension:
    extnID=2.5.29.15
    critical=True
    extnValue=0x03020780
   Extension:
    extnID=2.5.29.37
    critical=False
    extnValue=0x300a06082b06010505070301
   Extension:
    extnID=2.5.29.19
    critical=True
    extnValue=0x3000
   Extension:
    extnID=2.5.29.17
    critical=False
    extnValue=0x300687047f000001
   Extension:
    extnID=1.3.6.1.4.1.44363.44
    critical=False
    extnValue=

The last one should have a value of 0x0500.

Russ

> On Jul 14, 2020, at 3:51 PM, Watson Ladd <watson=[email-masked]> wrote:
>