Subject: [TLS] OpSec WGLC for draft-ietf-opsec-ns-impact

From: Jen Linkova <[email-masked]>
Date: Tue, 28 Jul 2020 23:05:34 +1000

This email starts the WG Last Call for draft-ietf-opsec-ns-impact ,

Impact of TLS 1.3 to Operational Network Security Practices,

https://datatracker.ietf.org/doc/draft-ietf-opsec-ns-impact/.

Taking into account  IETF108, the WGLC is extended to 3 weeks and ends
on Aug 18th, 23:59:59 UTC.

Please review the document and express your support or concerns/comments.

Thanks!

-- 
SY, Jen Linkova aka Furry on behalf of the OpSec Chairs.

---

From: tom petch <[email-masked]>
Date: Tue, 28 Jul 2020 16:07:52 +0000

From: OPSEC <[email-masked]> on behalf of Jen Linkova <[email-masked]>
Sent: 28 July 2020 14:05

<tp>
OPPOSE (yes, I am shouting)

This is nowhere near ready and putting it forward so soon is ... well ludicrous comes to mind.

After WG adoption, comments were made to which there was no acknowledgement, no response,  I was about to oppose the adoption of the other I-D from these authors on the grounds that until they respond to comments nothing else should happen because when they do there are more comments waiting to be aired.  I am still of that view.

I do see that a revised I-D has just appeared in among the thousand or so I-D that appear around the time of an IETF meeting, a timing that I sometimes think is designed to let it slip through unnoticed.  Given all those other I-D - silly authors - it may be more than three weeks before I get my thoughts together.

Tom Petch

Thanks!

_______________________________________________
OPSEC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/opsec

---

From: Jen Linkova <[email-masked]>
Date: Wed, 29 Jul 2020 08:14:38 +1000

> After WG adoption, comments were made to which there was no acknowledgement, no response,  I was about to oppose the adoption of the other I-D from these authors on the grounds that until they resp…

Sorry, it's partially my fault. I did explicitly ask the authors to
address your comments and submit a new version. I should have
double-checked that the new version incorporates the feedback.

Dear authors, would you be able to address Tom's comments ASAP so the
new revision can be reviewed during the WGLC?

> I do see that a revised I-D has just appeared in among the thousand or so I-D that appear around the time of an IETF meeting, a timing that I sometimes think is designed to let it slip through unno…

Just to clarify: would you prefer not to have the WGLC around IETF
weeks at all?

-- 
SY, Jen Linkova aka Furry

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Tue, 28 Jul 2020 22:40:58 +0000

Hi Jen,
Yes, yes....and again apologies for missing Tom's comments.  For some reason we (the authors) did not see his email come thru, but I did cover Kathleen's and Jason's comments (and did respond to them when their comments came in).

Will try to do it in the next day or so....
Best, Nancy

On 7/28/20, 3:15 PM, "TLS on behalf of Jen Linkova" <[email-masked] on behalf of [email-masked]> wrote:

    

    

    _______________________________________________
    TLS mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/tls

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 29 Jul 2020 02:12:25 +0100

IMO this document is absolutely not ready to become an
RFC. It basically ignores the purpose of TLS which is
to prevent exactly the MITM attacks being espoused
here (IMO). In ignoring that, it ignores all of the bad
consequences of such MITM attacks.

As evidence:

"To proxy a TLS session, a TLS Proxy must be able to
present a valid X.509 certificate to the TLS client to appear as a valid
TLS Server;"

That assumes that an x.509 data structure created on
the fly, with no interaction with the named subject
can be "valid." That is antithetical to the intent of
x.509 and TLS.

That is such a fundamental misconstruction of x.509,
of PKI and of TLS that it alone means that the draft
is sufficiently inaccurate to be unworthy of publication
as an IETF consensus RFC.

If really necessary I'm sure many other related
problems can and will be found in the text. I hope
that waste of effort is not needed.

The basic problem here seem to me to be an effort to
justify (and perhaps promote?) existing MITM practices
without fairly or accurately describing their downsides.

As I also commented on a related document: the effort
expended on attempts to garner IETF consensus on such
text is not worthwhile.

If someone actually wrote truly objective text on the
reasons why people deploy TLS MITM attack boxes and on
the real downsides that would be different. This is
nowhere near such objective text.

My recommendation: declare this document dead. And
don't bother with the supposed BCP. Instead, try to
find someone who can write an evidence-based description
of the falsifiable pros and cons of these TLS MITM
products. And then send that to the ISE.

S.

PS: I'm sure someone will claim that being logical about
this "ignores reality" so just to get in a comment on
that ahead of time: reality includes lots of bad
engineering - if and when we want to document that, there
is an onus on us to say why it is bad and how to do better.
That would require offering evidence as to the efficacy
or otherwise of TLS MTIM boxes when compared to the
benefits of using TLS as-designed. That evidence, in my
experience, never seems to actually be offered by those
who espouse these MITM attack products.

---

From: Rob Sayre <[email-masked]>
Date: Tue, 28 Jul 2020 18:52:04 -0700

On Tue, Jul 28, 2020 at 6:13 PM Stephen Farrell <[email-masked]>
wrote:

> engineering...

I agree with this comment. In particular, I object to phrases along the
lines of:

"TLS 1.3 considerations: reduced effectiveness"

Ignoring their aims, I don't think these products work, and I don't think
the IETF should publish documents that make it seem like they do.

I would support an ISE submission.

thanks,
Rob

---

From: tom petch <[email-masked]>
Date: Wed, 29 Jul 2020 08:41:01 +0000

From: Jen Linkova <[email-masked]>
Sent: 28 July 2020 23:14
To: tom petch

<tp>
Jen, it is more than that. I think that the IETF way of working is to make comments, get an acknowledgement and a response, from author, others, Chair, AD i.a., discuss the issues, accept or reject changes, new version, rinse and repeat.  In this case, the next post after my comments was WGLC.  This is not the process I expect. ( I thought there were other comments at adoption but cannot see them now).  I did see Kathleen promising a further review; that would be helpful.

And as I alluded to, four weeks ago was a quiet time, a time to progress this.  Now, cut-off and post cut-off, it is that time of madness in the IETF when everyone comes out of hibernation and posts revised I-D.  I track TEAS and they have just posted 484 - yes four hundred and eighty four - pages of revised I-Ds which will keep me quiet for much of August. Interesting as TLS is, it is behind them in the queue.

Tom Petch

---

From: Jen Linkova <[email-masked]>
Date: Wed, 29 Jul 2020 19:20:32 +1000

On Wed, Jul 29, 2020 at 6:41 PM tom petch <[email-masked]> wrote:
> Jen, it is more than that. I think that the IETF way of working is to make comments, get an acknowledgement and a response, from author, others, Chair, AD i.a., discuss the issues, accept or reject changes, new version, rinse and repeat.  In this case, the next post after my comments was WGLC.

Just to clarify:
- I saw your comments not being acknowledged/confirmed so we discussed
it with the authors and the proposed course of actions was: -01 is
posted to incorporate your comments and then we issue the WGLC. So
strictly speaking the next port after your comments was -01 (which was
*suppossed* to address your comments) and then WGLC.

>This is not the process I expect. ( I thought there were other comments at adoption but cannot see them now).  I did see Kathleen promising a further review; that would be helpful.

As I can see Kathleen confirmed that her comments had been addressed.

> And as I alluded to, four weeks ago was a quiet time, a time to progress this.  Now, cut-off and post cut-off, it is that time of madness in the IETF when everyone comes out of hibernation and post…

I'm sorry about adding more stuff onto your plate. Lesson learner,
we'll try to avoid issuing adoption/WGLC around IETF week.
On the other hand...I have a weird feeling that a lot of people: 1) do
not comment outside of adoption call//WGLC 2) are more active around
the IETF week.
So issuing the WGLC in the trough between IETF meetings caused an
undesirable outcome of people not paying enough attention.
But thanks for the comments, I'll take it into account - let's
consider it my learning curve..

BTW -02 has been posted so I hope your comments have been incorporated.

---

From: Bill Frantz <[email-masked]>
Date: Wed, 29 Jul 2020 10:42:13 -0400

>consider it my learning curve..

As a long-time lurker on the TLS list, I don't think these 
comments apply to the TLS working group. I see the ongoing 
business of draft, comment, new draft etc. going on 
continuously, only to be interrupted with email about IETF 
scheduling and agendas.

I would suggest that anything requiring input from the TLS 
working group be presented between IETF meetings, when there are 
many TLS experts who will take the time to review and comment.

Cheers - Bill

---------------------------------------------------------------------------
Bill Frantz        | "I wish there was a knob on the TV to turn 
up the
408-348-7900       | intelligence.  There's a knob called 
"brightness", but
www.pwpconsult.com | it doesn't work. -- Gallagher