Subject: Re: [TLS] TLS Opaque

From: "Scott Fluhrer (sfluhrer)" <[email-masked]>
Date: Thu, 1 Apr 2021 13:08:22 +0000

On Tue, Mar 30, 2021 at 9:39 PM Joseph Salowey <[email-masked]<mailto:[email-masked]>> wrote:

There is at least one question on the list that has gone unanswered for some time [1].

[1] https://mailarchive.ietf.org/arch/msg/tls/yCBYp10QuYPSu5zOoM3v84SAIZE/

I've found most of the OPAQUE drafts are pretty confusing / incorrect / or typo'd when it comes to lines like these. Describing these calculations seems difficult in ASCII, so I don't fault anyone for making mistakes here. The authors have also been pretty responsive in adding test vectors and such.

If the answer is “it’s a typo”, that’s fine – I agree that RFCs are a horrid format for expressing equations.  However, it would be good if there were to state what is the correct relationship here (and possibly update the draft with the corrected versions)

---

From: Rob Sayre <[email-masked]>
Date: Thu, 1 Apr 2021 07:51:00 -0700

Sorry, I was thinking of the wrong draft. See:

https://tools.ietf.org/html/draft-irtf-cfrg-opaque-03#section-4.2.2

and

https://tools.ietf.org/html/draft-irtf-cfrg-opaque-03#appendix-C

thanks,
Rob

On Thu, Apr 1, 2021 at 6:08 AM Scott Fluhrer (sfluhrer) <[email-masked]>
wrote:

>
>
> On Tue, Mar 30, 2021 at 9:39 PM Joseph Salowey <[email-masked]> wrote:
>
>
>
> I've found most of the OPAQUE drafts are pretty confusing / incorrect / or
> typo'd when it comes to lines like these. Describing these calculations
> seems difficult in ASCII, so I don't fault anyone for making mistakes here.
> The authors have also been pretty responsive in adding test vectors and
> such.
>
>
>
> If the answer is “it’s a typo”, that’s fine – I agree that RFCs are a
> horrid format for expressing equations.  However, it would be good if there
> were to state what is the correct relationship here (and possibly update
> the draft with the corrected versions)
>
>
>
>
>

---

From: Hugo Krawczyk <[email-masked]>
Date: Thu, 1 Apr 2021 11:53:14 -0400

Thanks Bob for pointing to the "real" ongoing specification of OPAQUE in
https://tools.ietf.org/html/draft-irtf-cfrg-opaque-03
and its careful specification of OPAQUE-3DH, including test vectors (and
sorry Scott for the typos in the other draft).
draft-irtf-cfrg-opaque is still work in process and comments on it are
welcome. It is intended as a standalone specification of OPAQUE.

In contrast, draft-sullivan-tls-opaque-01 is a very preliminary document to
show ways in which OPAQUE can be combined within and transported by TLS
1.3, e.g., using the exported authentication mechanisms from
draft-ietf-tls-exported-authenticator. It will be developed into a
document  compatible with the definition of OPAQUE in
draft-irtf-cfrg-opaque.

Hugo

On Thu, Apr 1, 2021 at 10:51 AM Rob Sayre <[email-masked]> wrote:

> On Thu, Apr 1, 2021 at 6:08 AM Scott Fluhrer (sfluhrer) <
> [email-masked]> wrote:
>
>>
>>
>> [1]
>> https://mailarchive.ietf.org/arch/msg/tls/yCBYp10QuYPSu5zOoM3v84SAIZE/
>>
>>
>>
>> I've found most of the OPAQUE drafts are pretty confusing / incorrect /
>> or typo'd when it comes to lines like these. Describing these calculations
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>