Subject: [TLS] Using ECHO mechanisms in QUIC

From: Martin Duke <[email-masked]>
Date: Wed, 5 May 2021 08:42:15 -0700

Hello TLS,

I just published an individual draft in QUIC that tries to take the ECHO
mechanism and use it to protect the entire Initial packet exchange in QUIC,
instead of just selected fields in the client hello. It is reliant on QUIC
version negotiation to recover from config mismatches:

https://datatracker.ietf.org/doc/draft-duke-quic-protected-initial/

Thoughts from the experts here would be welcome.

---

From: "Christopher Wood" <[email-masked]>
Date: Wed, 05 May 2021 10:51:36 -0700

Hi Martin,

I've not read the draft (yet!), but can you comment on the delta between your proposal and the one from Christian and Kazuho? Here's a link to their work
  
   https://datatracker.ietf.org/doc/draft-kazuho-quic-authenticated-handshake/

Thanks,
Chris

On Wed, May 5, 2021, at 8:42 AM, Martin Duke wrote:
> Hello TLS,
> 
> I just published an individual draft in QUIC that tries to take the 
> ECHO mechanism and use it to protect the entire Initial packet exchange 
> in QUIC, instead of just selected fields in the client hello. It is 
> reliant on QUIC version negotiation to recover from config mismatches:
> 
> _______________________________________________
> TLS mailing list
> [email-masked] <mailto:TLS%40ietf.org>
> https://www.ietf.org/mailman/listinfo/tls
>