Subject: [Tools-discuss] multiple formats of the same internet-draft submitted?

From: "Salz, Rich" <[email-masked]>
Date: Wed, 25 Aug 2021 17:46:19 +0000

I am reading https://github.com/ietf/id-guidelines carefully.

What happens if a user submits multiple formats of the same document at the same time?

If they submit XML, it appears the TXT version is ignored and overwritten. What happens to the PDF and PS versions? What happens when a new version is submitted, do draft-xxxx-…..-01.* get removed?

If the subject just plaintext, I assume the PDF and PS are handled as above?

If they submit just PDF and/or PS what happens?  Are both stored?

Tnx.

---

From: Robert Sparks <[email-masked]>
Date: Wed, 25 Aug 2021 13:22:29 -0500

On 8/25/21 12:46 PM, Salz, Rich wrote:
>
> I am reading https://github.com/ietf/id-guidelines 
> <https://github.com/ietf/id-guidelines> carefully.
>
> If they submit XML, it appears the TXT version is ignored and 
> overwritten.
>
No it doesn't. If both are submitted, both are kept. (See the 
conditional at 
https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/submit/forms.py#L256)
>
> What happens to the PDF and PS versions?
>
If they are provided, they are kept. If they are not provided, they are 
not generated. (The pdf-ization at the datatracker is done on demand).
>
> What happens when a new version is submitted, do draft-xxxx-…..-01.* 
> get removed?
>
 From the Repository, yes, but not from the Archive.

See https://trac.ietf.org/trac/ietfdb/browser/trunk/ietf/doc/expire.py#L140

> If the subject just plaintext, I assume the PDF and PS are handled as 
I assume you meant "If they submit just plaintext" of version N+1, then 
yes, all formats of version N are removed from the repository (but not 
the archive).
>
> If they submit just PDF and/or PS what happens?
>
The submission fails. At least one of xml or txt is required.
>
> Are both stored?
>
> Tnx.
>
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 25 Aug 2021 18:29:33 +0000

Thanks for the detailed reply.