Subject: [Tools-discuss] example of RFC with Errata applied

From: Michael Richardson <[email-masked]>
Date: Thu, 05 Aug 2021 10:13:12 -0400

Is there an RFC that we can look at that has XML errata applied that we can
look at?

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 5 Aug 2021 16:46:37 +0200

What are “XML errata“?

Sent from mobile, sorry for terse

> On 5. Aug 2021, at 16:13, Michael Richardson <[email-masked]> wrote:
> 
> XML errata

---

From: Robert Sparks <[email-masked]>
Date: Thu, 5 Aug 2021 10:56:49 -0500

There are no inline-errata views for v3 era RFCs at this time.

For older RFCs, we have this: 
https://www.rfc-editor.org/rfc/inline-errata/rfc3261.html

Is that what you are asking about?

RjS

On 8/5/21 9:13 AM, Michael Richardson wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 5 Aug 2021 18:26:35 +0200

Michael, *

Adding [email-masked] mailing list as i think this is a clear cutover:

a.1) I do not think that this will end up giving us necessarily what we may hope
for, because it only seems to render "verified" errata and not "hold for document 
update" errata. 

a.2) I would really like to see renderings also for "hold for document update"
errata, because this would help WGs to vet the need and scope of  writing
-bis documents.

b.1) I could not find any XML example, but it does not even seem to be required to
get a rendering with the applied errata:

https://www.rfc-editor.org/rfc/inline-errata/rfc7950.html

This is only html, not text, so it can not be fed to rfcdiff, but
once you know that you have to look for the word "Expand" in the html,
yo will find all those places, where "Expand" is actually a label on a button
for each errata text block.

b.2) It is hard to find:
  https://datatracker.ietf.org/doc/html/rfc7950
    -> Errata exists: 
        https://www.rfc-editor.org/errata_search.php?rfc=7950&rec_status=0

     This at least is where you should be able to find the
     inlined rendering, but you need to now click onto any of the
     verified errata and only then will you be given the rendered
     Errata URL.

  I would suggest that the rfc-editor errata page for a document
  prominently features the inline-rendered URL. 

c) I could not find any info about if/what the XML version improved
over the above, so i am also still curious about that.

Cheers
    Toerless

---

From: Michael Richardson <[email-masked]>
Date: Thu, 05 Aug 2021 12:58:35 -0400

> There are no inline-errata views for v3 era RFCs at this time.

Oh. I would have thought that was easier :-)

    > Is that what you are asking about?

Yes, that's what I meant.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Robert Sparks <[email-masked]>
Date: Thu, 5 Aug 2021 12:16:05 -0500

> Oh. I would have thought that was easier :-)
Maybe, but it's not done yet.