Subject: Re: [Tools-discuss] Tools info on the main IETF web site

From: Michael Richardson <[email-masked]>
Date: Sun, 01 Aug 2021 16:44:38 -0400

Brian E Carpenter <[email-masked]> wrote:
    > Who keeps an eye on the tools material on the IETF web site?

AMSL can do updates, and emails to [email-masked] work well for this.

    > While trying to assist a possible new contributor, I fell upon:
    > https://www.ietf.org/about/participate/tutorials/process/creating-internet-drafts-and-rfcs/
    > which looks badly in need of a refresh to me. For example, it misses the excellent tutorial at:
    > https://datatracker.ietf.org/meeting/104/materials/slides-104-edu-sessf-how-to-create-an-internet-draft-using-xml-or-markdown-markdown-01

    > We can have the best tools in the world, but they are no good to
    > newcomers unless the main IETF web site is actively maintained.

I'd put the ietf.org contents on a gitlab and take pull requests.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 1 Aug 2021 23:39:43 +0200

> I'd put the ietf.org contents on a gitlab and take pull requests.

This is the right model (s/gitlab/github/ because that’s the way we do it).

I’m afraid there may be some technical details in the way (a description of which might need words like wagtail and streamfield, which I’m not fluent in).

We *do* want someone to exercise some editorial control (otherwise I’d might dump my life story in there).

Grüße, Carsten

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 2 Aug 2021 09:51:53 +1200

> AMSL can do updates, and emails to [email-masked] work well for this.

Yes, but I think that they can't be expected to be proactive in
identifying gaps and updates. When I was in the EDU team (the ancestor
of EMO) I tried to do this, but I'm not sure we really have a mechanism
 
>     > https://datatracker.ietf.org/meeting/104/materials/slides-104-edu-sessf-how-to-create-an-internet-draft-using-xml-or-markdown-markdown-01

Who decides that this is the latest & best material to promote
on the site? Not my job, and probably not AMSL's.

> I'd put the ietf.org contents on a gitlab and take pull requests.

I don't know if the content management system could work like that,
but I agree that crowdsourcing of some kind would be handy.

   Brian

---

From: Jay Daley <[email-masked]>
Date: Mon, 2 Aug 2021 10:02:42 +1200

> On 2/08/2021, at 9:51 AM, Brian E Carpenter <[email-masked]> wrote:
> 

The outline plan that a bunch of us are putting together for community consultation is for a new wiki to be added at authors.ietf.org <http://authors.ietf.org/> that 

- replaces the current info on www.ietf.org <http://www.ietf.org/> and tools.ietf.org <http://tools.ietf.org/> and so becomes the one stop shop for authors (at this stage, not planning to recommend that AUTH48 documentation also moves from rfc-editor.org <http://rfc-editor.org/>) 

- has a mix of 'official' and community content 

- encourages the developers of tools to maintain a part of this site about their tool so that we always have up to date info

- uses wiki.js so that it can have it’s content synchronised with GitHub as per all the discussions above, all written in markdown, etc

It would be useful to hear if this is on the right lines before the proposal is fully fleshed out?

Jay

> 
>   Brian
> 
> _______________________________________________
> Emo-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/emo-dir
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Sun, 01 Aug 2021 18:29:15 -0400

Jay Daley <[email-masked]> wrote:
    > The outline plan that a bunch of us are putting together for community
    > consultation is for a new wiki to be added at authors.ietf.org
    > <http://authors.ietf.org/> that

I like it.

    > proposal is fully fleshed out?

I think so.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 2 Aug 2021 10:59:13 +1200

>     > proposal is fully fleshed out?

I agree, for experienced users. My immediate concern is helping an
absolute beginner, and they need something kinder and gentler such
as an up to date tutorial. But I'm sure EMO is thinking about this.

   Brian

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 2 Aug 2021 15:00:54 +0000

*   It would be useful to hear if this is on the right lines before the proposal is fully fleshed out?

Sounds like a great improvement.  Do it, and then we can iterate.

---

From: Joey Salazar <[email-masked]>
Date: Tue, 3 Aug 2021 12:25:49 -0600

> >     > <http://authors.ietf.org/> that
Me too, very looking forward to collaborating on that.

> >     > proposal is fully fleshed out?
I think the 'mix of 'official' and community content' is a great idea as it
gives flexibility on approaching topics like "working as part of a team"
and "how to deal with dissent/disagreement" that new authors might find
challenging. Having the authors guidance centralized is a very good step
imo.

> as an up to date tutorial. But I'm sure EMO is thinking about this.
Indeed emodir is thinking along those lines. We'll aim to complement what
the community consultation focuses on. I agree guidance for beginners and
first-time would-be-authors is very much needed.

-- 
Joey Salazar
IETF emodir
Co-coordinator