Subject: [Tools-discuss] d3.min.js and jquery.js for an htmlized rendering of the RFC?

From: Lars Eggert <[email-masked]>
Date: Fri, 20 Aug 2021 13:29:52 +0300

Hi,

I just came across this Tweet (https://twitter.com/dret/status/1428455182397054981):
> call me old-fashioned, but what's the reason why @ietf RFCs like datatracker.ietf.org/doc/html/rfc72… aren't self-contained HTML? they reference #D3 and #jQuery and it's not quite clear why these would be needed for TXT with embedded HTML anchors and links.

that made me check the posted link, and the person is correct in that we do access d3.min.js and jquery.js for that htmlized rendering of the RFC. Any reason why?

Thanks,
Lars

---

From: Robert Sparks <[email-masked]>
Date: Sat, 21 Aug 2021 11:39:56 -0500

> that made me check the posted link, and the person is correct in that we do access d3.min.js and jquery.js for that htmlized rendering of the RFC. Any reason why?

What we currently have is a quick port from what existed at tools. In 
that port, we dropped some functionality that may have removed any use 
of d3, but the page does still use jquery.

One of the bits of functionality we dropped was some manipulation of the 
dom to insert tags at places identified by some classes. Right now, the 
code generates stanzas that look like '''<span class="h2"><a 
class="selflink" id="section-1" href="#section-1">1</a> 
Introduction</span>'''. Javascript at tools used to rewrite this to be 
'''<span class="h2"><h2><a class="selflink" id="section-1" 
href="#section-1">1</a> Introduction</h2></span>'''. We've received one 
request to put it back.

We could, fairly easily remove the library dependencies if we continue 
to not do that rewriting.

We could look at moving that rewriting into the rfc2html library, but 
there are other users of that library that such a change could disrupt.

>
> Thanks,
> Lars
>
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss