Subject: Re: [Tools-discuss] Why do we even have text formats any more?

From: Michael Richardson <[email-masked]>
Date: Sun, 01 Aug 2021 11:26:11 -0400

Julian Reschke <[email-masked]> wrote:
    >> I also don't want paste to include any extra stuff.

    > "extra stuff" such as?

font changes, etc.
Depending on what the recipient (pastee?) program accomodates.

---

From: Julian Reschke <[email-masked]>
Date: Sun, 1 Aug 2021 17:35:21 +0200

> Depending on what the recipient (pastee?) program accomodates.

If you paste that *into* a text editor, it'll get stripped, no? (And if
you paste into things like Word, you should have an option to strip that...)

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 1 Aug 2021 17:55:18 +0200

> "extra stuff" such as?

Wrong question.

Currently, we generate a TXT format from the XML, which (possibly among other renditions) is checked by the authors during AUTH48.  This format is there guaranteed to have the information that should survive a copy/paste into another text document (e.g., the comments in a program).

The HTML plus the not further defined, platform specific conversion from HTML to TXT does not give us these assurances.  So removing the TXT format removes reliable copy/paste into other plaintext documents.

2⁶⁴ becomes 264.  “ “ becomes   .  Etc.

(Note that there are occasionally discussions to remove information from the TXT format to make it look more like the HTML, in particular because it would sometimes require information from the authors to always do this information generation properly for the TXT form.  These discussions need to be informed by the need to copy/paste RFC snippets into plaintext documents.)

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Mon, 2 Aug 2021 07:33:04 +0200

> On 2021-07-31, at 06:31, Julian Reschke <[email-masked]> wrote:

It's the question I was interested in.

> 2⁶⁴ becomes 264.  “ “ becomes   .  Etc.

And that actually is an answer to me question!

> (Note that there are occasionally discussions to remove information from the TXT format to make it look more like the HTML, in particular because it would sometimes require information from the aut…

I agree that it would be good to compile a list of use cases.

Best regards, Julian