Subject: [Tools-discuss] Upcoming change to the look of the datatracker

From: Robert Sparks <[email-masked]>
Date: Wed, 9 Mar 2022 18:25:05 -0600

All -

Lars began, and has done the majority of the work so far, on moving the 
datatracker from bootstrap3 to bootstrap5, avoiding customization as 
much as possible, and simplifying many dependencies along the way.

The conversion is not complete, but the general idea is far enough along 
to start collecting feedback - I've put a test instance up at 
https://sandbox-ng.ietf.org/. This is a development instance and any 
changes made there will not affect the real datatracker in any way.

Please look around - if you see something truly broken open an issue at 
https://github.com/ietf-tools/datatracker/issues/new?labels=new,bs5

If you are not happy with use of space or colors, send a note to this 
list (but please try not to bikeshed), and be aware that we are going to 
further refine it.

We are hoping sprinters at the upcoming codesprint will be able to focus 
on this branch.

RjS

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 10 Mar 2022 01:36:55 +0100

Fresh!

On the document page, the plethora of royal blue (#0d6efd) buttons beaming at me is a bit much.

I do like the colors of the bikeshed.

Grüße, Carsten

> On 2022-03-10, at 01:25, Robert Sparks <[email-masked]> wrote:
> 
> All -
> 
> Lars began, and has done the majority of the work so far, on moving the datatracker from bootstrap3 to bootstrap5, avoiding customization as much as possible, and simplifying many dependencies along the way.
> 
> The conversion is not complete, but the general idea is far enough along to start collecting feedback - I've put a test instance up at https://sandbox-ng.ietf.org/. This is a development instance and any changes made there will not affect the real datatracker in any way.
> 
> Please look around - if you see something truly broken open an issue at https://github.com/ietf-tools/datatracker/issues/new?labels=new,bs5
> 
> If you are not happy with use of space or colors, send a note to this list (but please try not to bikeshed), and be aware that we are going to further refine it.
> 
> We are hoping sprinters at the upcoming codesprint will be able to focus on this branch.
> 
> RjS
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Paul Hoffman <[email-masked]>
Date: Wed, 09 Mar 2022 16:48:05 -0800

The color scheme makes all the pages I've looked at *significantly* more 
readable. Kudos for this!

--Paul Hoffman

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 10 Mar 2022 13:55:35 +1300

Hi,

This looks pretty and from a quick glance, functionality is fine.
I really couldn't care less about the changed colours (you could
tune them to exactly match the Ukrainian flag), but there is more
wasted space than before - slightly larger font and unnecessary
white space; for example the "submit" button near the top of the
History page is on a line of its own for no good reason. As a result,
I can use the current tracker at default size, but I need to hit CTRL/-
two or three times with the sandbox version.

Regards
    Brian

---

From: Michael Richardson <[email-masked]>
Date: Wed, 09 Mar 2022 20:01:35 -0500

> If you are not happy with use of space or colors, send a note to this list
    > (but please try not to bikeshed), and be aware that we are going to further
    > refine it.

I know that some of the colours are chosen to make it clear it's the sandbox.
But, it seems like there are many changes in font styling and the like as well.

I looked at only two pages: my public profile page, and 6lo WG (it was the
first I could pick).
I didn't like the vertical-only layout on the public profile page.
The original layout fit more content on my screen.
The new layout feels very cartoon-ish....

I'm meh on the new stuff, but I could live with it.

https://www.sandelman.ca/tmp/dt/

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Lars Eggert <[email-masked]>
Date: Thu, 10 Mar 2022 12:18:05 +0200

Hi,

> If you are not happy with use of space or colors, send a note to this list (but please try not to bikeshed), and be aware that we are going to further refine it.

the colors and fonts come from the default bs5 theme.

The yellow menu bar would be blue in the non-dev-mode version though. (Similar how the current dt dev mode uses a red menu bar while the deployed instance uses blue).

There is some thinking about having a common bs5 theme designed for all IETF web presences that use bs5 (which is IIRC almost all of them).

Thanks,
Lars

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 10 Mar 2022 12:32:00 +0100

On Wed, Mar 09, 2022 at 06:25:05PM -0600, Robert Sparks wrote:
> datatracker from bootstrap3 to bootstrap5, avoiding customization as much as
> possible, and simplifying many dependencies along the way.

For those like me who have not tracked the posssibly explained history why
this was done and what the goal is:

-> Its primarily to simplify tooling around pre-existing tool "bootstrap" ?
-> Improvements such as better colors or the like are mostly coincidental ?
-> There are no significant usability improvement requirements that drove this?

Just guessing from that one paragraph you wrote. Could be completely wrong.
How do i score ? ;-)

> The conversion is not complete, but the general idea is far enough along to
> start collecting feedback - I've put a test instance up at
> https://sandbox-ng.ietf.org/. This is a development instance and any changes
> made there will not affect the real datatracker in any way.
> 

- Are we supposed to be able to login ? I can't. So i can not check
  WG chair specific experiences.

> (but please try not to bikeshed), and be aware that we are going to further

- I think the new column on WG main pages (e.g.: https://sandbox-ng.ietf.org/wg/anima/about/), which has "WG Name, Charter for WG, Milestones" - this new column is makin the page unnecessary more convoluted given how the info is already on the page. Maybe such a column is useful on other pages, but not here IMHO.

- The personal ID marking and review markers on the WG documents pages are missing,
  i guess this is just TBD, else it would be significant downgrade.

- The old font is more soothing to read. Its a font you'd also use in books.
  the new font is easier to read at smaller size. I guess as someone who
  uses a large screen to easier read i am not the target audience anymore,
  but younger people with tablets and phones are.

  I wish it was possible if there where user-account based rendering preferences.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Thu, 10 Mar 2022 15:05:29 +0200

Hi,

> this was done and what the goal is:

bs3 has been EOL'ed in 2019. bs4 will be EOL'ed later in 2022.

A lot of other third-party assets we currently use for the datatracker are similarly stale, and in order to benefit from security and bug fixes, we need to roll them forward (or replace them with better-supported alternatives).

>  WG chair specific experiences.

All passwords on the sandbox instances have been set to "password". (This should probably be mentioned prominently; I opened https://github.com/ietf-tools/datatracker/issues/3606)

> - I think the new column on WG main pages (e.g.: https://sandbox-ng.ietf.org/wg/anima/about/), which has "WG Name, Charter for WG, Milestones" - this new column is makin the page unnecessary more c…

This auto-generated navigation column is only shown when the main content extends past the viewport, and the viewport has a certain width. It is possible to turn this off completely for some pages - file a ticket?

>  i guess this is just TBD, else it would be significant downgrade.

They are only shown when you are logged in. (I don't think this is a regression.)

>  but younger people with tablets and phones are.

See my earlier message on the theme simply being the bs5 default.

Thanks,
Lars

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 10 Mar 2022 15:19:46 +0100

> A lot of other third-party assets we currently use for the datatracker are similarly stale, and in order to benefit from security and bug fixes, we need to roll them forward (or replace them with b…

Sure, this is all great, i was really just curious because i had no clue about the
motivation behind it. I still don't know what bs3...bs5 is ;-))

> All passwords on the sandbox instances have been set to "password". (This should probably be mentioned prominently; I opened https://github.com/ietf-tools/datatracker/issues/3606)

Thanks.

> This auto-generated navigation column is only shown when the main content extends past the viewport, and the viewport has a certain width. It is possible to turn this off completely for some pages…

Its a bikeshed what i think looks nice or not. Don't think this is up to the level of a ticket.

> They are only shown when you are logged in. (I don't think this is a regression.)

Ack.
> See my earlier message on the theme simply being the bs5 default.

Ok. I guess my point is that visualization is one of those things where i think there is
not one-presentation fits all. But i have no idea if the concept i was suggesting
(user based customization) is something the tool offers for free. If not, then of course
its not worth it (IMHO) to invest cycles.

-- 
---
[email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Thu, 10 Mar 2022 16:29:43 +0200

Hi,

> motivation behind it. I still don't know what bs3...bs5 is ;-))

ah: bs = bootstrap, i.e., the web UI framework we have been using for the datatracker (https://getbootstrap.com/)

> its not worth it (IMHO) to invest cycles.

It doesn't come with bs, but if you really care, you can use Greasemonkey or similar tools to override the relevant parts of the CSS for yourself locally.

Thanks,
Lars

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 10 Mar 2022 14:36:21 +0000

>    There is some thinking about having a common bs5 theme designed for all IETF web presences that use bs5 (which is IIRC almost all of them).

That would be great.

Perhaps engage a design firm (like the ones who did the TLS ACME etc shirts maybe).  Among other things, they'll know how to handle ADA (americans with disability act) and similar requirements.

It looks good.  I tried to fetch via mobile and got redirected to www.ietf.org with both Chrome and FFox.

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 10 Mar 2022 15:56:12 +0100

> It doesn't come with bs, but if you really care, you can use Greasemonkey or similar tools to override the relevant parts of the CSS for yourself locally.

Hah! I had this discussion some time back about the new rendering of RFCs on datatracker RFC-editor.
Don't think greasemonkey was mentioned. Thanks.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: Roger Price <[email-masked]>
Date: Thu, 10 Mar 2022 09:56:57 +0100 (CET)

On Wed, 9 Mar 2022, Robert Sparks wrote:

> - I've put a test instance up at 
> (but please try not to bikeshed), ...

I often read web pages referenced in e-mails with w3m, a text browser.  This 
gives me a view of the page which is approximately that of a speech browser.  I 
saw

   IETF Logo Datatracker Dev Mode

   • Groups
       □ By area/parent
       □ Apps & Realtime
       □ General
       □ Internet
       □ Ops & Management
       □ Routing
       □ Security
       □ Transport
       □ IAB
       □ IRTF
       □ IETF LLC
       □ Other
           ☆ Active AGs  etc, etc, etc,...

and some 50 odd lines before I got to the subject.  On behalf of "low vision" 
readers, could you put a link at the very top of the page to the subject matter.
It would save a lot of time, and doesn't get in the way of users of "high 
vision" browsers.

The page https://www.w3.org/WAI/people-use-web/tools-techniques/
gives an example of how to do this.

Thanks, Roger

---

From: Bob Hinden <[email-masked]>
Date: Thu, 10 Mar 2022 10:00:03 -0800

I am fine with the new colors, thought it is very bright :-)  Nice work to Lars!

Since it is changing, one thing I would like to see is that the default page for a draft show the “htmilized” version instead of the text version.  For me that would be a lot more useful.

Bob

> On Mar 9, 2022, at 4:25 PM, Robert Sparks <[email-masked]> wrote:
> 
> All -
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 10 Mar 2022 13:26:23 -0500

Actually, I would suggest the real html version rather than the "htmlized"
version as the default.

Cheers,
Andy

On Thu, Mar 10, 2022 at 1:00 PM Bob Hinden <[email-masked]> wrote:

> Since it is changing, one thing I would like to see is that the default
> page for a draft show the “htmilized” version instead of the text version.
> For me that would be a lot more useful.
>
> Bob
>
>
> datatracker from bootstrap3 to bootstrap5, avoiding customization as much
> as possible, and simplifying many dependencies along the way.
> >
> > List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Jay Daley <[email-masked]>
Date: Fri, 11 Mar 2022 07:33:16 +1300

> On 11/03/2022, at 3:36 AM, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> 

This was done the other way around - the main website has a design that was professionally produced some years ago.  This was recently upgrade to Bootstrap 5 (which took some work) and the web development company that did that work was commissioned to extract all the elements into a Bootstrap theme that can be used on other sites:

	https://github.com/ietf-tools/common-bootstrap-theme

I’m not sure if this is ready to be used yet.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 10 Mar 2022 18:37:42 +0000

>   This was done the other way around - the main website has a design that was professionally produced some years ago.  This was recently upgrade to Bootstrap 5 (which took some work) and the web de…

Thanks for the info!

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 10 Mar 2022 19:57:16 +0100

On 10. Mar 2022, at 19:26, Andrew G. Malis <[email-masked]> wrote:
> 
> Actually, I would suggest the real html version rather than the "htmlized" version as the default.

… and the metadata.js function could be used to mimic the header used bu htmlized, or at least the most useful parts (say, datatracker link, diff2, newer versions/revision track).

Grüße, Carsten

---

From: Bob Hinden <[email-masked]>
Date: Thu, 10 Mar 2022 13:30:32 -0800

I find the links to diffs, errata, IPR, history, etc. useful in the “htmlized" version.   I don’t think they are available in the “html” one.

Bob

> On Mar 10, 2022, at 10:26 AM, Andrew G. Malis <[email-masked]> wrote:
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 10 Mar 2022 16:46:49 -0500

Bob,

See Carsten's comment about that.

Cheers,
Andy

On Thu, Mar 10, 2022 at 4:30 PM Bob Hinden <[email-masked]> wrote:

> I find the links to diffs, errata, IPR, history, etc. useful in the
> “htmlized" version.   I don’t think they are available in the “html” one.
>
> Bob
>
>
> > > Lars began, and has done the majority of the work so far, on moving
> the datatracker from bootstrap3 to bootstrap5, avoiding customization as
> > > The conversion is not complete, but the general idea is far enough
> along to start collecting feedback - I've put a test instance up at
> > > Please look around - if you see something truly broken open an issue
> at https://github.com/ietf-tools/datatracker/issues/new?labels=new,bs5
> > >

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Sun, 20 Mar 2022 08:09:20 +0000

This discussion makes me wonder whether the same bs5 color schemes should be used in 'companions' web properties such as yangcatalog.org

-éric

-----Original Message-----
From: Tools-discuss <[email-masked]> on behalf of Robert Sparks <[email-masked]>
Date: Thursday, 10 March 2022 at 02:00
To: tools-discuss <[email-masked]>
Subject: [Tools-discuss] Upcoming change to the look of the datatracker

    All -

    RjS

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 21 Mar 2022 09:13:05 +0000

>    This discussion makes me wonder whether the same bs5 color schemes should be used in 'companions' web properties such as yangcatalog.org

Yes.  Content is more important, but having a consistent look and feel (and color scheme) for all IETF properties will be good to do as well.