Subject: [Tools-discuss] Novice burned by minutes upload/publishing procedure

From: "David R. Oran" <[email-masked]>
Date: Mon, 28 Mar 2022 11:26:20 -0400

This is most likely a simple RTFM (which I couldn’t find) or a “bad user on device” error from a novice, but I thought I’d report it anyway in case it matches an open ticket or some other known problem.

I’m ICNRG co-chair and our note taker used HedgeDoc on notes.ietf.org for the minutes (a first for us I believe). I went to publish the minutes and experienced the following:

- I go to meeting materials for ICNRG@IETF113, which has a single button to “Upload Minutes”
- I hit “publish” in Hedgedoc, and that just opens a web page with the rendered text. Not what I want.
- So, I go to “Menu” and say “download markdown”. Seems reasonable. I now have the .md file on my machine.
- Now I go back to meeting materials and say “upload minutes” and point to the .md file I downloaded.
- Yay, minutes get uploaded, but…
- They render wrong, with line breaks mostly gone.
- However, wonder of wonders, now that I’ve done the upload, the meeting materials now shows me an option to “Import from  notes.ietf.org” which I’m pretty sure was not there before.
- So, I say great, and try that.
- Refuses to import claiming an identical version was already uploaded.
- So, maybe I can delete the uploaded minutes and maybe try again?
- Nope, no way to delete uploaded minutes.

So, we’ve got minutes uploaded, but not really readable.

DaveO

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 28 Mar 2022 17:55:19 +0200

> So, we’ve got minutes uploaded, but not really readable.

Hi Dave,

I have no idea why the “Import…” button wasn’t there, but you can fix your markdown using the “de-gfm” tool that is part of kramdown-rfc.
Just run the markdown you downloaded from hedgedoc through de-gfm and upload that.

(Datatracker can do that, but IIRC only does this if you use the import button.)

Grüße, Carsten

---

From: "David R. Oran" <[email-masked]>
Date: Mon, 28 Mar 2022 14:12:01 -0400

> Just run the markdown you downloaded from hedgedoc through de-gfm and upload that.
Thanks - I did that.
I don’t really use markdown (I edit most of my stuff directly in XML2RFC syntax) but it’s nice to have kramdown-rfc handy in any case.

DaveO

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 29 Mar 2022 10:49:54 -0400

Carsten,

Where is the import button? If I go to the meetings materials page for my
WG, I see an "Upload Minutes" button, but not an import button.

Thanks,
Andy

On Mon, Mar 28, 2022 at 11:55 AM Carsten Bormann <[email-masked]> wrote:

> I have no idea why the “Import…” button wasn’t there, but you can fix your
> markdown using the “de-gfm” tool that is part of kramdown-rfc.
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: "David R. Oran" <[email-masked]>
Date: Tue, 29 Mar 2022 11:00:11 -0400

> WG, I see an "Upload Minutes" button, but not an import button.
Ah, so maybe we have a trouble ticket here…
I had the same problem - no button until you have already done an upload, and then if you try to import, it complains of a duplicate, and then you can’t delete the previously uploaded version.

DaveO

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Mar 2022 10:21:21 -0500

> I had the same problem - no button until you have already done an upload, and then if you try to import, it complains of a duplicate, and then you can’t delete the previously uploaded version.
Yes, this was identified late last week - I _thought_ an issue had been 
created for it, but I'm not finding it right now (digging through the 
post-meeting maelstrom). I'll dig a bit more, and will report the issue 
number soon.
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Mar 2022 11:10:11 -0500

On 3/29/22 10:21 AM, Robert Sparks wrote:
>> I had the same problem - no button until you have already done an 
>> upload, and then if you try to import, it complains of a duplicate, 
>> and then you can’t delete the previously uploaded version.
> Yes, this was identified late last week - I _thought_ an issue had 
> been created for it, but I'm not finding it right now (digging through 
> the post-meeting maelstrom). I'll dig a bit more, and will report the 
> issue number soon.
https://github.com/ietf-tools/datatracker/issues/3762
>>>> (Datatracker can do that, but IIRC only does this if you use the 
>>>> import
>>>> button.)
>>>>
>>>> Grüße, Carsten
>>>>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 29 Mar 2022 18:23:54 +0200

Thanks, Robert

Is there a simple workaround, such as crafting the appropriate URL for
the import button for a particular WG ? Or is it one of those URL-free
buttons from Javascript ? 

Cheers
    Toerless

On Tue, Mar 29, 2022 at 11:10:11AM -0500, Robert Sparks wrote:
> > > > > (Datatracker can do that, but IIRC only does this if you use
> > > > > the import
> > > > > button.)
> > > > > 
> > > > > Grüße, Carsten
> > > > > 

-- 
---
[email-masked]

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Mar 2022 11:35:07 -0500

> buttons from Javascript ?

You can craft the URL, but until the fixes go in for this, the safer 
thing to do is upload a simple -00 minutes in text or markdown format 
that simply says "preparing to import minutes from notes", and then 
import using the button.

Note, however, that at the moment, the notes service is 500ing, and the 
secretariat is working on a fix. Be sure you can _see_ the notes you 
want to import before trying to do so.

RjS

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 31 Mar 2022 18:48:03 +0200

Thanks Robert,

Workaround procedure first creating notes-00.txt to then have the button worked great.
Cc'ong wgchairs in case other WG chairs are not aware of this option (as it's
kinda trying to hide itself due to the bug ;-)

Cheers
    Toerless

On Tue, Mar 29, 2022 at 11:35:07AM -0500, Robert Sparks wrote:
> You can craft the URL, but until the fixes go in for this, the safer thing
> to do is upload a simple -00 minutes in text or markdown format that simply
> says "preparing to import minutes from notes", and then import using the
> button.
> 
> secretariat is working on a fix. Be sure you can _see_ the notes you want to
> import before trying to do so.
> 
> RjS
> 
> > 
> > Cheers
> >      Toerless
> > 

-- 
---
[email-masked]