Subject: [Tools-discuss] Link to Jabber logs in WG pages no longer accurate

From: Tim Wicinski <[email-masked]>
Date: Thu, 24 Mar 2022 11:20:03 -0400

In https://datatracker.ietf.org/group/dnsop/about/ the link to the jabber
logs points to   https://jabber.ietf.org/logs/dnsop/ - this page now is a
IETF page on group chat, and one much work to find the new location of the
jabber logs.
https://jabber.ietf.org/jabber/logs/dnsop/

Also, can we reverse the order of the Index?  With the more recent log at
the top rather than the bottom?  (I know I know, I am high maintenance)

tim

---

From: Robert Sparks <[email-masked]>
Date: Thu, 24 Mar 2022 10:38:46 -0500

On 3/24/22 10:20 AM, Tim Wicinski wrote:
>
> In https://datatracker.ietf.org/group/dnsop/about/ the link to the 
> jabber logs points to https://jabber.ietf.org/logs/dnsop/ - this page 
> now is a IETF page on group chat, and one much work to find the new 
> location of the jabber logs.
Yes, this will be addressed.
>
> Also, can we reverse the order of the Index?  With the more recent log 
> at the top rather than the bottom?  (I know I know, I am high maintenance)
I'll ask.
>
> tim
>
>
> ___________________________________________________________
> Tools-discuss mailing list [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to:[email-masked]
> * Report tools.ietf.org bugs to:[email-masked]
> * Report all other bugs or issues to:[email-masked]
> List info (including how to Unsubscribe):https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Michael Richardson <[email-masked]>
Date: Thu, 24 Mar 2022 18:50:52 +0100

> Yes, this will be addressed.

Thank you, I also had this challenge on Wednesday.

    > I'll ask.

What would be ideal would be if the jabber log for a particular day on which
there was a meeting could get linked into the meeting agenda page.
(I'd send a PR for this if I had more spare cycles)

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 24 Mar 2022 14:19:01 -0400

> (I'd send a PR for this if I had more spare cycles)
Michael, I've taken to copy/pasting the logs and appending them to the
minutes (after removing the "joins/leaves" msgs).  Because I've realized
they are just as part of the minutes as the mic line.

tim

> Tools-discuss mailing list - [email-masked]
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Michael Richardson <[email-masked]>
Date: Thu, 24 Mar 2022 22:15:26 +0100

Tim Wicinski <[email-masked]> wrote:
    > Michael, I've taken to copy/pasting the (JABBER) logs and appending them to the
    > minutes (after removing the "joins/leaves" msgs).  Because I've
    > realized they are just as part of the minutes as the mic line.

That's a really good idea, and it should become SOP.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 24 Mar 2022 18:00:25 -0400

Well, advice please.

I pasted the Jabber log into teh minutes.  I edited out the join leave.
I then copyied the whole markdown minutes into notepad on my PC, saved 
it as a .md file on my PC.
And then went to the upload minutes page and uploaded it.

ost of the minutes came out fine.
The chat log is unreadable (look at savnet meeting materials to see what 
a mess it made.)

I would guess if I manually added a line end after eveyr chat log entry 
it would be better.  But that seems the wrong answer.

Help?
Thanks,
Joel

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 24 Mar 2022 18:15:20 -0400

I would put a line of three backticks

```

before and after which tells it to treat it as code

---

From: Michael Richardson <[email-masked]>
Date: Fri, 25 Mar 2022 00:15:28 +0100

> it would be better.  But that seems the wrong answer.

yeah, this goes to the incompatible markdown between HedgeDoc and DT.

Your solution of doubline line endings would work, but you could do that with
sed to the jabber log before merging.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 24 Mar 2022 19:24:11 -0400

That results in <pre> before and </pre> after, but still all run together.

Yours,
Joel

On 3/24/2022 6:15 PM, Tim Wicinski wrote:
> On Thu, Mar 24, 2022 at 6:00 PM Joel M. Halpern <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Well, advice please.
> 
>      > Tim Wicinski <[email-masked] <mailto:[email-masked]>> wrote:
>      >      > Michael, I've taken to copy/pasting the (JABBER) logs and
>     appending them to the
>      >      > minutes (after removing the "joins/leaves" msgs).  Because
>     I've
>      >      > realized they are just as part of the minutes as the mic line.
>      >
>      > Michael Richardson <[email-masked]
>     <mailto:[email-masked]>>, Sandelman Software Works
>     <mailto:[email-masked]>
>     * Report datatracker and mailarchive bugs to:
>     [email-masked] <mailto:[email-masked]>
>     * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tools-discuss>
>

---

From: Robert Sparks <[email-masked]>
Date: Thu, 24 Mar 2022 19:04:34 -0500

Leave it sit for awhile please. What you put in now is reasonable, and a 
code change coming soon will address that the rendering escaped the 
<pre> rather than letting that through to the html.

RjS

On 3/24/22 6:24 PM, Joel M. Halpern wrote:
>>      >
>>      > Tim Wicinski <[email-masked] <mailto:[email-masked]>> 
>> wrote:
>>      >      > Michael, I've taken to copy/pasting the (JABBER) logs and
>>     appending them to the
>>      >      > minutes (after removing the "joins/leaves" msgs).  Because
>>     I've
>>      >      > realized they are just as part of the minutes as the 
>> mic line.
>>      >
>>      > That's a really good idea, and it should become SOP.
>>      >
>>      > --
>>      > Michael Richardson <[email-masked]
>>      >   -= IPv6 IoT consulting =-
>>      >
>>      >
>>      >
>>
> [email-masked]

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 24 Mar 2022 17:06:20 -0700

Can we make it happen mechanically and automatically

-Ekr

---

From: Robert Sparks <[email-masked]>
Date: Fri, 25 Mar 2022 02:56:37 -0500

> Can we make it happen mechanically and automatically
https://github.com/ietf-tools/datatracker/discussions/3747
>
> -Ekr
>
>
> On Thu, Mar 24, 2022 at 2:15 PM Michael Richardson 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>
>         > minutes (after removing the "joins/leaves" msgs). Because I've
>     [email-masked]