Subject: [Tools-discuss] agenda links open in new window?

From: "Salz, Rich" <[email-masked]>
Date: Mon, 21 Mar 2022 11:01:40 +0000

Should all links on the agenda page (e.g., https://datatracker.ietf.org/meeting/113/agenda) open in a new window?
I find that all the time I look at something, then hit back and wait for the agenda to reload.

---

From: Robert Sparks <[email-masked]>
Date: Mon, 21 Mar 2022 06:58:19 -0500

Forcing new windows is not a nice thing to do to users.

The real issue you point to here is paying for the reload time when 
you've _just_ loaded the agenda.

We could address that with better browser caching I think? Hopefully 
something we can work on generally throughout the datatracker soon. The 
agenda page, in particular, needs to be rethought to make use of 
fetching a lot of the current "hidden until you hover or click" content 
when it's needed rather than stuffing it all in the initial page load.

RjS

On 3/21/22 6:01 AM, Salz, Rich wrote:
>
> Should all links on the agenda page (e.g., 
> https://datatracker.ietf.org/meeting/113/agenda) open in a new window?
>
> ___________________________________________________________
> Tools-discuss mailing list [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to:[email-masked]
> * Report tools.ietf.org bugs to:[email-masked]
> * Report all other bugs or issues to:[email-masked]
> List info (including how to Unsubscribe):https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 21 Mar 2022 12:23:29 +0000

*   Forcing new windows is not a nice thing to do to users.

Okay but it’s not consistent.  The little “show meeting materials” icon is a pop-up.

  *   The real issue you point to here is paying for the reload time when you've _just_ loaded the agenda.

That removes the pain point, yeah.