Subject: [Tools-discuss] Fwd: [Int-dir] Auto-acceptance/non-notification of assigned reviews...

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Tue, 29 Mar 2022 14:49:25 +0200

Dear tools team,

I'm forwarding a discussion taking place in intdir. I believe that changing
the subject line of the e-mails is actually a good idea. Is that change
something you would agree to implement?

Thanks!

Carlos (as intdir co-chair/secretariat, not sure what the right term is ;) )

---------- Forwarded message ---------
From: Pascal Thubert (pthubert) <pthubert=[email-masked]>
Date: Tue, Mar 29, 2022 at 2:01 PM
Subject: Re: [Int-dir] Auto-acceptance/non-notification of assigned
reviews...
To: Ted Lemon <[email-masked]>
Cc: Tim Chown <[email-masked]>, [email-masked] <[email-masked]>

+1

I tried to say the same very recently. The messages are not easily
extracted from the noise and are not acknowledged.

If the subject started with INT DIR REVIEW ASSIGNMENT maybe we could do
better ?

Regards,

Pascal

Le 29 mars 2022 à 13:13, Ted Lemon <[email-masked]> a écrit :

In my case it turns out that I just auto-deleted the message because the
subject line had the name of a draft in it that I wasn’t following. My
suggested fix for this is to not put the draft name in the subject line of
review assignment email messages, since it’s not relevant. What the
assignment message needs to communicate is that a review has been assigned,
and putting the draft name there risks people doing what I automatically
do: deleting it without reading.

On Tue, Mar 29, 2022 at 04:53 Tim Chown <[email-masked]> wrote:

> This has happened to me 2 or 3 times for Ops Dir assignments.  We never
> got to the cause with Gunter.  It may be the same system, or may not.
>
> Tim
>
> > On 28 Mar 2022, at 21:42, Ted Lemon <[email-masked]> wrote:
> >
> > I just got email from Carlos Bernardos that listed review assignments.
> Useful email, but what surprised me is that a review is assigned to me. I
> don't remember ever accepting this assignment nor being notified of it, so
> this is a bit problematic. Is anyone else having this happen to them?
> >
> > I think this is not the first time it's happened, and it's not fun,
> because typically the first I actually hear of it is when the int-dir chair
> sends me an aggrieved message asking why my assigned review is late. :(
> > _______________________________________________
> > Int-dir mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/int-dir
>
> _______________________________________________
Int-dir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-dir

_______________________________________________
Int-dir mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/int-dir

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 29 Mar 2022 15:33:48 +0200

On 2022-03-29, at 14:49, CARLOS JESUS BERNARDOS CANO <[email-masked]> wrote:
> 
>> My suggested fix for this is to not put the draft name in the subject line of review assignment email messages, since it’s not relevant. What the assignment message needs to communicate is that a review has been assigned, and putting the draft name there risks people doing what I automatically do: deleting it without reading.

If the draft name is not in the subject, I will never find that message again when working on the draft name; you might as well not send it.

I don’t think we can assume everybody has the same process for dealing with the daily mail tsunamis.

Grüße, Carsten

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Tue, 29 Mar 2022 15:40:14 +0200

Hi Carsten,

I agree, but I think we should discuss to find the best compromise that
work best for everybody. Something like: "INT DIR review assignment of
<draft-foo> by <deadline>" I think would cover all expressed concerns. What
do you think?

Thanks,

Carlos

On Tue, Mar 29, 2022 at 3:33 PM Carsten Bormann <[email-masked]> wrote:

> >> My suggested fix for this is to not put the draft name in the subject
> line of review assignment email messages, since it’s not relevant. What the
> If the draft name is not in the subject, I will never find that message
> again when working on the draft name; you might as well not send it.
>

---

From: Bob Hinden <[email-masked]>
Date: Tue, 29 Mar 2022 07:59:12 -0700

> On Mar 29, 2022, at 6:40 AM, CARLOS JESUS BERNARDOS CANO <[email-masked]> wrote:
> 
> Hi Carsten,
> 
> I agree, but I think we should discuss to find the best compromise that work best for everybody. Something like: "INT DIR review assignment of <draft-foo> by <deadline>" I think would cover all expressed concerns. What do you think?

Sounds good to me.

Bob

> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Bernie Volz <[email-masked]>
Date: Tue, 29 Mar 2022 10:07:19 -0400

Seems like good subject line to me. It should also be documented so folks can set up appropriate filters to avoid deleting it or placing it into junk folder.

- Bernie

> On Mar 29, 2022, at 9:40 AM, CARLOS JESUS BERNARDOS CANO <[email-masked]> wrote:
> 
> 
> Hi Carsten,
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Mar 2022 10:24:54 -0500

I'll use https://github.com/ietf-tools/datatracker/discussions/3760 to 
run this by all the review teams.

RjS

---

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Mar 2022 11:41:25 -0400

I’d like to see the subject linereally emphasize that it’s a review. It’s
fine if the draft title is there as long as it didn’ doesn’t stand out.
Putting “REVIEW ASSIGNMENT” in all caps would work.  Don’t try to make it
pretty—try to make it stand out. I don’t have an automatic tool that’s
deleting these—they just look so much like regular email about the draft
that if it’s one I habitually don’t read about, I’m going to delete the
assignment without it ever registering that it’s not a working group email
message.

On Tue, Mar 29, 2022 at 11:25 Robert Sparks <[email-masked]> wrote:

> >> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
> >
> > List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Mar 2022 10:52:50 -0500

Some alternatives to think about:

Do you use the datatracker (while logged in) often enough that a message 
popping up at the top of the page (only once) when you get an assignment 
would be useful.

Also, do you use https://datatracker.ietf.org/accounts/review/ (linked 
from the menu under your login name)?

RjS

On 3/29/22 10:41 AM, Ted Lemon wrote:
> I’d like to see the subject linereally emphasize that it’s a review. 
> It’s fine if the draft title is there as long as it didn’ doesn’t 
> stand out. Putting “REVIEW ASSIGNMENT” in all caps would work.  Don’t 
> try to make it pretty—try to make it stand out. I don’t have an 
> automatic tool that’s deleting these—they just look so much like 
> regular email about the draft that if it’s one I habitually don’t read 
> about, I’m going to delete the assignment without it ever registering 
> that it’s not a working group email message.
>
>     I'll use
>     https://github.com/ietf-tools/datatracker/discussions/3760 to
>     >> I agree, but I think we should discuss to find the best
>     compromise that work best for everybody. Something like: "INT DIR
>     review assignment of <draft-foo> by <deadline>" I think would
>     cover all expressed concerns. What do you think?
>     > Sounds good to me.
>     >
>     > Bob
>     >
>     >
>     >> Thanks,
>     >>
>     >> Carlos
>     >>
>     >>>> My suggested fix for this is to not put the draft name in the
>     subject line of review assignment email messages, since it’s not
>     relevant. What the assignment message needs to communicate is that
>     a review has been assigned, and putting the draft name there risks
>     people doing what I automatically do: deleting it without reading.
>     >> If the draft name is not in the subject, I will never find that
>     message again when working on the draft name; you might as well
>     not send it.
>     >>
>     >> * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked]
>     > * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked]
>     * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked]
> Tools-discuss mailing list [email-masked]
> * Report datatracker and mailarchive bugs to:[email-masked]
> * Report tools.ietf.org bugs to:[email-masked]
> * Report all other bugs or issues to:[email-masked]
> List info (including how to Unsubscribe):https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Mar 2022 11:56:09 -0400

I don’t use the data tracker often enough that this would work for me. I
did use the reviews link to figure out if I really had a review after
seeing Carlos’ summary message. Honestly, the thing that would work best
for me would be to have a calendar to subscribe to that just marked a
suggested day to do the review along with a drop-dead date to make sure
that if I space out, I get a last chance to do it before the deadline. I
look at my calendar a lot.

On Tue, Mar 29, 2022 at 11:53 Robert Sparks <[email-masked]> wrote:

>> >> I agree, but I think we should discuss to find the best compromise
>> that work best for everybody. Something like: "INT DIR review assignment of
>> subject line of review assignment email messages, since it’s not relevant.
>> What the assignment message needs to communicate is that a review has been
>> assigned, and putting the draft name there risks people doing what I
>> automatically do: deleting it without reading.
>> message again when working on the draft name; you might as well not send it.
>> >>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 29 Mar 2022 11:00:02 -0500

On 3/29/22 10:56 AM, Ted Lemon wrote:
> I don’t use the data tracker often enough that this would work for me. 
> I did use the reviews link to figure out if I really had a review 
> after seeing Carlos’ summary message. Honestly, the thing that would 
> work best for me would be to have a calendar to subscribe to that just 
> marked a suggested day to do the review along with a drop-dead date to 
> make sure that if I space out, I get a last chance to do it before the 
> deadline. I look at my calendar a lot.
I captured that idea at 
https://github.com/ietf-tools/datatracker/discussions/3760
>     Do you use the datatracker (while logged in) often enough that a
>     message popping up at the top of the page (only once) when you get
>     an assignment would be useful.
>
>     Also, do you use https://datatracker.ietf.org/accounts/review/
>     (linked from the menu under your login name)?
>
>     RjS
>
>>     I’d like to see the subject linereally emphasize that it’s a
>>     review. It’s fine if the draft title is there as long as it didn’
>>     doesn’t stand out. Putting “REVIEW ASSIGNMENT” in all caps would
>>     work. Don’t try to make it pretty—try to make it stand out. I
>>     don’t have an automatic tool that’s deleting these—they just look
>>     so much like regular email about the draft that if it’s one I
>>     habitually don’t read about, I’m going to delete the assignment
>>     without it ever registering that it’s not a working group email
>>     message.
>>
>>         compromise that work best for everybody. Something like: "INT
>>         DIR review assignment of <draft-foo> by <deadline>" I think
>>         would cover all expressed concerns. What do you think?
>>         > Sounds good to me.
>>         >
>>         > Bob
>>         >
>>         >
>>         >> Thanks,
>>         >>
>>         >> Carlos
>>         >>
>>         >>>> My suggested fix for this is to not put the draft name
>>         in the subject line of review assignment email messages,
>>         since it’s not relevant. What the assignment message needs to
>>         communicate is that a review has been assigned, and putting
>>         the draft name there risks people doing what I automatically
>>         >> If the draft name is not in the subject, I will never find
>>         that message again when working on the draft name; you might
>>         as well not send it.
>>         >>
>>         >> I don’t think we can assume everybody has the same process
>>         for dealing with the daily mail tsunamis.
>>         >>
>>         >> Grüße, Carsten
>>         >>
>>     * Reporttools.ietf.org  <http://tools.ietf.org>  bugs to:[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Mar 2022 12:17:25 -0400

Thanks!  I realize that’s probably an unreasonably big ask, but it would be
cool. :)

---

From: tjw ietf <[email-masked]>
Date: Tue, 29 Mar 2022 12:56:33 -0400

As someone who is also a slave to their calendar it’s an awesome idea. But I understand it’s a big ask also. 

Sent from my iPhone

> On Mar 29, 2022, at 12:17, Ted Lemon <[email-masked]> wrote:
> 
> 
> Thanks!  I realize that’s probably an unreasonably big ask, but it would be cool. :)
> 
>>> I don’t use the data tracker often enough that this would work for me. I did use the reviews link to figure out if I really had a review after seeing Carlos’ summary message. Honestly, the thing that would work best for me would be to have a calendar to subscribe to that just marked a suggested day to do the review along with a drop-dead date to make sure that if I space out, I get a last chance to do it before the deadline. I look at my calendar a lot. 
>> I captured that idea at https://github.com/ietf-tools/datatracker/discussions/3760
>> 
>>> 
>>>> Do you use the datatracker (while logged in) often enough that a message popping up at the top of the page (only once) when you get an assignment would be useful.
>>>> 
>>>> Also, do you use https://datatracker.ietf.org/accounts/review/ (linked from the menu under your login name)?
>>>> 
>>>> RjS
>>>> 
>>>>> I’d like to see the subject linereally emphasize that it’s a review. It’s fine if the draft title is there as long as it didn’ doesn’t stand out. Putting “REVIEW ASSIGNMENT” in all caps would work.  Don’t try to make it pretty—try to make it stand out. I don’t have an automatic tool that’s deleting these—they just look so much like regular email about the draft that if it’s one I habitually don’t read about, I’m going to delete the assignment without it ever registering that it’s not a working group email message. 
>>>>>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 29 Mar 2022 13:02:41 -0400

Ted Lemon <[email-masked]> wrote:
    > doesn’t stand out.  Putting “REVIEW ASSIGNMENT” in all caps would work.
    > Don’t try to make it pretty—try to make it stand out. I don’t have an
    
I have the same problem.
I have solved it slightly because WG stuff has a List-Id, which I now include
my folder scan, like:

  84D%03/29 ["iTech Conferen]                  Learn more about our Keynotes!<<--------------0505050
  85D%03/29 [Bernie Volz    ]     tools-discus Re: [Tools-discuss] [Int-dir] Auto-acceptance/non-not
  91D%03/29   <Robert Sparks  >     tools-discus Re: [Tools-discuss] [Int-dir] Auto-acceptance/non-n

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [