Subject: RE: IOTP Implementations - Who's on First?

From: "Smith, Chris " <[email-masked]>
Date: Fri, 21 Jan 2000 17:10:27 -0500

Perhaps I wasn't clear enough.

I've had a request to bundle up the responses I received and forward them
to the list. I won't do that. I won't presume to know that what someone
sends me individually can be repeated on the open list.

The intent is that individuals will respond *on the list*.

These is one point I will draw from viewing several items. IOTP uses
the concept of Roles to define 'who does what' during a transaction.
However, nothing limits these roles to being occupied only for a 
B2C transaction. B2B uses the same roles, so - IOTP could certainly
be used as part of B2B commerce solution. Don't think that just because
you are *not* doing B2C that we aren't interested in what you might
have to say.

In addition - if you wish to add your voice to that of the
interested audience, that too is welcome.

------------------------------------------------------------ 
 Chris Smith                                +1.416.348.6090 
 Royal Bank                       [email-masked] 

> -----Original Message-----
> From: Smith, Chris 
> Sent: January 18, 2000 02:28 PM
> To: IOTP Group
> Subject: IOTP Implementations - Who's on First?
> 
> At some point, those of working on IOTP will need to
> consider testing interoperability. Right now, I know of only
> 2 (or maybe 3) groups actively working on IOTP components.
> 
> For those who are doing so in anything remotely resembling
> a corporate environment, it helps immensely if we can say,
> with some evidence, how many different groups are involved.
> 
> I realize that some people will want to be circumspect about
> their plans. However, we can all help each other if we can
> speak up to indicate that some implementation work is
> planned or underway.
> 
> Longer term, if IOTP is to move towards an IETF standard,
> we would have to demonstrate interoperability of the
> independent implementations. We might as well get started
> on thinking about this, too.
> 
> To get this started - from my point of view:
> 
> Royal Bank (of Canada) has a production IOTP implementation
> of Withdrawal and Deposit of Mondex value. We built both an
> IOTP server and a Windows client. It is in use, in
> production, by customers of the bank.
> 
> ------------------------------------------------------------ 
>  Chris Smith                                +1.416.348.6090 
>  Royal Bank                       [email-masked]

---

From: Andras Varga <[email-masked]>
Date: Mon, 24 Jan 2000 10:51:59 +0100

RE: IOTP Implementations - Who's on First?At Brokat Infosystems (more exactly, at MeTechnology - a
Brokat company,
we have implemented an IOTP system as part of a research project.

The Merchant and the Payment Handler are based on Twister, Brokat's
e-services platform (http://www.brokat.com/us/twister/index.html).

The wallet is a Java applet, with a highly customizable Swing-based user interface.
It can be started by the shop either by MIME-type or embedded in a HTML page.
The wallet does address and payment instrument management; transactions are stored
in a transaction log and can be examined or resumed any time later. The wallet
is multi-user,  user profiles and transactions are stored encrypted on the hard disk.

For a start, we implemented Virtual Customer Card payments (a prepaid scheme).

The system uses IOTP 1.0 messages, but we also defined Server-to-Server messages
so that the Payment Handler can notify the Merchant about the progress of the payment.
These messages can be used as an alternative to the explicit (Consumer-initiated) delivery
requests.

If you are interested in further details, please write.

-----------------------------------------------------------------------------------
Andras Varga          MeTechnology - A Brokat Company
[email-masked]