Subject: RE: What's the right forum for developing XML Messaging

From: David Burdett <[email-masked]>
Date: Tue, 22 Feb 2000 13:49:58 -0800

Chris
 
I think there is a great overlap between eCommerce's needs for messaging and
the general need for "messaging" particularly in the area of reliable
messaging and use of security (see
http://www.xml.org/archives/ebxml-transport/msg00145.html
<http://www.xml.org/archives/ebxml-transport/msg00145.html> ) which contains
the Overview and Requirements document for the group and you will find that
the scope is not focused just on eCommerce.
 
Remember that IOTP was developed to solve a particular eCommerce problem
namely how to do purchases and payments reliably and securely on the
Internet.
 
If it were not for the overlap in the requiremennt then I would be strongly
advocating separate activities to focus on the needs of each as you suggest.
However as I see it the objectives of the original IETF XML Messaging and
ebXML Transport, Routing and Packaging groups (as compared with ebXML as a
whole) are just about identical.
 
In my view I anticipate that the results of the work currently under way
will be generally applicable to other situations - not just eCommerce. If
additional needs are required then they I think it should be possible to
meet the need as extensions rather than a re-write.
 
David

-----Original Message-----
From: Smith, Chris [mailto:[email-masked]]
Sent: Monday, February 21, 2000 7:06 AM
To: IETF Trade (E-mail)
Subject: RE: What's the right forum for developing XML Messaging

As one of the "people who developed IOTP" (and also one who 
'developed *using* IOTP') we did what almost all DTD users do. 

We wrote a core schema as a DTD, and extended and refined it 
to its finished form (that is 'usable form') using English. 
I've noticed that a great many RFCs use this strategy as 
well. It seems to have worked reasonably well. 

As for xmlmessaging - I'm curious if others think that 
'xmlmessaging' will be used solely for e-commerce. Myself - 
I think that's a rhetorical question! It will be used for 
all kinds of things. 

This was my original thought when David mentioned the 
whole question of either/or - I figured that the IETF 
side was appropriate to work on the core xmlmessaging, 
while the ebXML would work on using it for e-business. 

Of course, in later notes, I find that these two groups 
are essentially the same people. This then raises a different 
concern; the initial notes on xmlmessaging do not (and should 
not!) say that it is only for e-business purposes. However, 
it that is the only reason it gets developed at all, then I 
would have a minor concern that we might not get the best 
possible xmlmessaging spec available due to a focus on 
e-business. 

I beginning to think that ebXML should go solve the problems 
they need to solve - just don't pretend that you are solving 
the generic xmlmessaging problem for everyone. If they *do* 
solve it in a robust and reusable manner, great - then it is 
available. Since most of the individuals (and their sponsoring 
companies) are part of ebXML for e-business reasons, this makes 
a lot of sense to me. This group wasn't formed to solve generic 
problems, they were formed to solve e-business problems. 

If an ebXML result ends up missing essential non-e-business features, 
then xmlmessaging will still have to be done separately. 

However - if ebXML wants to use a generic xmlmessaging capability as 
a foundation, then it seems quite appropriate that a separate group 
work on that portion of it, and that they include all appropriate 
requirements, not just the e-business ones. 

------------------------------------------------------------ 
 Chris Smith                                +1.416.348.6090 
 Royal Bank                       [email-masked] 

> -----Original Message----- 
> From: Michie, Alan [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: February 17, 2000 03:59 PM 
> To: 'David Burdett' 
> Cc: ebXML Transport (E-mail); IETF Trade (E-mail) 
> Subject: RE: What's the right forum for developing XML Messaging 
> 
> 
> David, 
> 
> The group of people who developed IOTP have probably 
> already decided what to do about the choice between 
> using plain DTD's or some form of schema which allows 
> element values to be described more precisely. 
> 
> Can you tell me what has been decided and why or refer 
> me to some information on the web or in the email 
> archive --- OR -- is the matter still 
> under consideration for the xmlmessage spec?

---

From: Ofer Avineri <[email-masked]>
Date: Wed, 23 Feb 2000 13:32:34 +0200

<David Burdett>
> Internet</David Burdett>

<Ofer Avineri>
This is exactly why we think a new Working Group within IETF should be
formed, to deal with the entire XML Transport/Messaging scope. This is the
WG that will work with +any+ 3rd party community trying to facilitate its
solution on XML. </Ofer Avineri>

<Chris Smith>
> all kinds of things. </Chris Smith>

<Ofer Avineri>
Let's take the VoxML initiative for example, they're trying to standardize a
way to +Transport HTML/XML content to Cellular Voice Information, I see no
e-business nor e-commerce requirements from them.
If ebXML (and we're working there) wants to develop its own XML Transport
protocol, why do they need the IETF? Perhaps they should move IP, HTTP and
SNMP to ebXML as well? We can always address the issue with the IESG or
IAB.</Ofer Avineri>

Ofer Avineri
E-MANAGE Product Manager,
Digital Intelligence Systems, Inc.