Subject: Can't validate DTD (RFC 2801)

From: Harald Barrera Dubois <[email-masked]>
Date: Tue, 06 Feb 2001 11:27:50 +0100

Hello.

Trying to validate the DTD of the IOTP (section 13 from RFC 2801) with XML SPY (version 3.5 registered),
an error has been reported by the parser. The error message is: "Element ANY is undefined" and it references
to line 44, page 275 of the RFC (section 13). The element is "Attribute" and this is the definition:

<!ELEMENT Attribute ( ANY ) >
<!ATTLIST Attribute
    type                   NMTOKEN             #REQUIRED
    critical                ( true | false )         #REQUIRED

The problem is in "( ANY )". I have found in http://www.w3.org/ the standard "Extensible Markup Language (XML) 1.0 (Second Edition)" 
and at section 3.2 "Element Type Declarations" (p. 21, 22 and 23) I have found the gramatical definition of an element declaration as
shown below.

elementdecl ::= '<!ELEMENT' S Name S contentspec S ? '>'

contentspec ::= 'EMPTY' | 'ANY' | Mixed | children 

Mixed ::= '(' S ? '#PCDATA' (S ? '|' S ? Name )* S ? ')*' | '(' S ? '#PCDATA' S ? ')'

children ::= (choice | seq ) ('?' | '*' | '+')?

cp ::= (Name | choice | seq) ('?' | '*' | '+')?

choice ::= '(' S ? cp ( S ? '|' S ? cp )+ S ? ')'

seq ::= '(' S ? cp ( S ? ',' S ? cp )* S ? ')'

where S is the space character (' ') and Name is a string of characters.  

As you can see the definition of "Attribute" does not match the gramatical definition of an element declaration, if "ANY" is 
not a Name.

So, these are my questions to the list members:

Is ANY a Name? If it is, where is the definition of the Name "ANY"?
Is this a mistake?
May be the parentheses of  "( ANY )" are wrong?
Is April-2000 the latest version of the RFC 2801?

Thank you.

---
Harald Barrera Dubois
CRIPTOLAB Research Group. (http://tirnanog.ls.fi.upm.es )
Computer Science High School (http://www.fi.upm.es )
Politechnical University of Madrid (http://www.upm.es )
SPAIN

---

From: Yoshiaki KAWATSURA <[email-masked]>
Date: Tue, 06 Feb 2001 21:47:33 +0900 (JST)

Herald,
ANY in Attribute attribute is in contentSpec, not entity.
So this DTD in RFC2801 has a mistake.

----
Yoshiaki Kawatsura : E-mail [email-masked]
 Business Solution Systems Division, Hitachi,Ltd.
Voice: +81-44-549-1713(direct) Fax: +81-44-549-1721