Subject: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-04.txt

From: [email-masked]
Date: Wed, 24 Sep 2014 19:22:21 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the TURN Revised and Modernized Working Group of the IETF.

        Title           : Session Traversal Utilities for NAT (STUN) Extension for Third Party Authorization
        Authors         : Tirumaleswar Reddy
                          Prashanth Patil
                          Ram Mohan Ravindranath
                          Justin Uberti
	Filename        : draft-ietf-tram-turn-third-party-authz-04.txt
	Pages           : 20
	Date            : 2014-09-24

Abstract:
   This document proposes the use of OAuth to obtain and validate
   ephemeral tokens that can be used for Session Traversal Utilities for
   NAT (STUN) authentication.  The usage of ephemeral tokens ensure that
   access to a STUN server can be controlled even if the tokens are
   compromised.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tram-turn-third-party-authz/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tram-turn-third-party-authz-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turn-third-party-authz-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 25 Sep 2014 02:28:05 +0000

We submitted http://tools.ietf.org/html/draft-ietf-tram-turn-third-party-authz-04 which addresses the WGLC comments received.
side-by-side diffs: http://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turn-third-party-authz-04

-Tiru

> -----Original Message-----
> From: tram [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Thursday, September 25, 2014 7:52 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-04.txt
> 
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram

---

From: Simon Perreault <[email-masked]>
Date: Thu, 25 Sep 2014 08:47:55 -0400

The changes look good to me! Thanks a lot for your quick reaction time!

Oleg, Marc, could you please confirm that your concerns have been addressed?

Thanks,
Simon

On Wed, Sep 24, 2014 at 10:28 PM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

> We submitted
> which addresses the WGLC comments received.
> side-by-side diffs:
> >         Title           : Session Traversal Utilities for NAT (STUN)
> Extension for Third
> > Party Authorization

---

From: Oleg Moskalenko <[email-masked]>
Date: Thu, 25 Sep 2014 08:01:28 -0700

Yes, my concerns were addressed.

Thanks,
Oleg

On Thu, Sep 25, 2014 at 5:47 AM, Simon Perreault <[email-masked]>
wrote:

>> > Subject: [tram] I-D Action:
>> draft-ietf-tram-turn-third-party-authz-04.txt
>> >
>> >

---

From: Oleg Moskalenko <[email-masked]>
Date: Sat, 27 Sep 2014 17:09:07 -0700

Tiru, I'd like to get a clarification regarding the section 9:

      The lifetime provided by the TURN server in the Allocate and
      Refresh responses MUST be less than or equal to the lifetime of
      the token.

That's not exactly clear. Let's assume the following input:

TS of the token is 1000
Lifetime of the token is 500
Current timestamp is 1200

What will be the session max lifetime: 500 or 300 ? If the token is 200
seconds old, than the age of the token has to be subtracted from the max
lifetime value - right ? The current document wording is not saying that.

Thanks
Oleg