Subject: Re: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-04.txt

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 29 Sep 2014 07:23:28 +0000

Hi Oleg,

Please see inline [TR]

From: Oleg Moskalenko [mailto:[email-masked]]
Sent: Sunday, September 28, 2014 5:39 AM
To: Tirumaleswar Reddy (tireddy)
Cc: [email-masked]
Subject: Re: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-04.txt

Tiru, I'd like to get a clarification regarding the section 9:

      The lifetime provided by the TURN server in the Allocate and
      Refresh responses MUST be less than or equal to the lifetime of
      the token.
That's not exactly clear. Let's assume the following input:
TS of the token is 1000
Lifetime of the token is 500
Current timestamp is 1200
What will be the session max lifetime: 500 or 300 ?
[TR] The session max lifetime is 300 seconds.
If the token is 200 seconds old, than the age of the token has to be subtracted from the max lifetime value - right ?
[TR] Yes
The current document wording is not saying that.
[TR] Sure, will fix that.
NEW: It is RECOMMENDED that the TURN server calculates the maximum allowed lifetime value using the formula: lifetime + Delta – abs(RDnew –TS).
-Tiru
Thanks
Oleg

On Wed, Sep 24, 2014 at 7:28 PM, Tirumaleswar Reddy (tireddy) <[email-masked]<mailto:[email-masked]>> wrote:
We submitted http://tools.ietf.org/html/draft-ietf-tram-turn-third-party-authz-04 which addresses the WGLC comments received.
side-by-side diffs: http://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turn-third-party-authz-04

-Tiru

> -----Original Message-----
> From: tram [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of internet-
> [email-masked]<mailto:[email-masked]>
> Sent: Thursday, September 25, 2014 7:52 AM
> To: [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
> Subject: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-04.txt
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>  This draft is a work item of the TURN Revised and Modernized Working
> Group of the IETF.
>
>         Title           : Session Traversal Utilities for NAT (STUN) Extension for Third
> Party Authorization
>         Authors         : Tirumaleswar Reddy
>                           Prashanth Patil
>                           Ram Mohan Ravindranath
>                           Justin Uberti
>       Filename        : draft-ietf-tram-turn-third-party-authz-04.txt
>       Pages           : 20
>       Date            : 2014-09-24
>
> Abstract:
>    This document proposes the use of OAuth to obtain and validate
>    ephemeral tokens that can be used for Session Traversal Utilities for
>    NAT (STUN) authentication.  The usage of ephemeral tokens ensure that
>    access to a STUN server can be controlled even if the tokens are
>    compromised.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tram-turn-third-party-authz/
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-tram-turn-third-party-authz-04
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turn-third-party-authz-04
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> tram mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tram

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tram

---

From: Oleg Moskalenko <[email-masked]>
Date: Mon, 29 Sep 2014 00:30:17 -0700

Tiru, thank you for the clarification.

Regards,
Oleg

On Mon, Sep 29, 2014 at 12:23 AM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

>  Hi Oleg,
>
>
>
> Please see inline [TR]
>
>
>
> *From:* Oleg Moskalenko [mailto:[email-masked]]
> *Sent:* Sunday, September 28, 2014 5:39 AM
> *To:* Tirumaleswar Reddy (tireddy)
> *Cc:* [email-masked]
> *Subject:* Re: [tram] I-D Action:
> draft-ietf-tram-turn-third-party-authz-04.txt
>
>
>
> If the token is 200 seconds old, than the age of the token has to be
> subtracted from the max lifetime value - right ?
>
> [TR] Yes
>
> NEW: It is RECOMMENDED that the TURN server calculates the maximum
> allowed lifetime value using the formula: lifetime + Delta – abs(RDnew –TS).
>
> -Tiru
>
> Thanks
> Oleg
>
>
>
>
>
>
>
>
>
> On Wed, Sep 24, 2014 at 7:28 PM, Tirumaleswar Reddy (tireddy) <
> [email-masked]> wrote:
>
> We submitted
> which addresses the WGLC comments received.
> side-by-side diffs:
> > From: tram [mailto:[email-masked]] On Behalf Of internet-
> > [email-masked]
> > To: [email-masked]
> > Cc: [email-masked]
> > until the htmlized version and diff are available at tools.ietf.org.
> >
> > [email-masked]
> [email-masked]