Subject: [tram] FW: New Version Notification for draft-patil-tram-turn-serv-selection-00.txt

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 27 Oct 2014 12:01:54 +0000

We've published a draft that describes TURN selection criteria, as guidelines, that can be used by a client to perform an informed TURN server selection decision when a client discovers multiple TURN servers.  Comments and suggestions are welcome.

Cheers,
-Tiru

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 27, 2014 5:30 PM
To: Prashanth Patil (praspati); Tirumaleswar Reddy (tireddy); Gonzalo Salgueiro (gsalguei); Prashanth Patil (praspati); Gonzalo Salgueiro (gsalguei); Tirumaleswar Reddy (tireddy)
Subject: New Version Notification for draft-patil-tram-turn-serv-selection-00.txt

A new version of I-D, draft-patil-tram-turn-serv-selection-00.txt
has been successfully submitted by Tirumaleswar Reddy and posted to the IETF repository.

Name:		draft-patil-tram-turn-serv-selection
Revision:	00
Title:		Traversal Using Relays around NAT (TURN) Server Selection
Document date:	2014-10-26
Group:		Individual Submission
Pages:		7
URL:            http://www.ietf.org/internet-drafts/draft-patil-tram-turn-serv-selection-00.txt
Status:         https://datatracker.ietf.org/doc/draft-patil-tram-turn-serv-selection/
Htmlized:       http://tools.ietf.org/html/draft-patil-tram-turn-serv-selection-00

Abstract:
   A TURN client may discover multiple TURN servers.  In such a case,
   there are no guidelines that a client can follow to choose or prefer
   a particular TURN server among those discovered.  This document
   details selection criteria, as guidelines, that can be used by a
   client to perform an informed TURN server selection decision.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Simon Perreault <[email-masked]>
Date: Mon, 27 Oct 2014 09:58:53 -0400

Interesting!

Quick procedural question: The intended status says Informational, but the
text uses RFC2119 keywords. Is this an oversight?

Simon

On Mon, Oct 27, 2014 at 8:01 AM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

> We've published a draft that describes TURN selection criteria, as
> guidelines, that can be used by a client to perform an informed TURN server
> selection decision when a client discovers multiple TURN servers.  Comments
> and suggestions are welcome.
>
> Cheers,
> -Tiru
>
> To: Prashanth Patil (praspati); Tirumaleswar Reddy (tireddy); Gonzalo
> Salgueiro (gsalguei); Prashanth Patil (praspati); Gonzalo Salgueiro
> (gsalguei); Tirumaleswar Reddy (tireddy)
> Subject: New Version Notification for
> draft-patil-tram-turn-serv-selection-00.txt
>
>
> URL:
> http://www.ietf.org/internet-drafts/draft-patil-tram-turn-serv-selection-00.txt
> Status:
> https://datatracker.ietf.org/doc/draft-patil-tram-turn-serv-selection/
> Htmlized:
> http://tools.ietf.org/html/draft-patil-tram-turn-serv-selection-00
>
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram
>

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Tue, 28 Oct 2014 14:40:14 +0000

From: Simon Perreault [mailto:[email-masked]]
Sent: Monday, October 27, 2014 7:29 PM
To: Tirumaleswar Reddy (tireddy)
Cc: [email-masked]
Subject: Re: [tram] FW: New Version Notification for draft-patil-tram-turn-serv-selection-00.txt

Interesting!

Quick procedural question: The intended status says Informational, but the text uses RFC2119 keywords. Is this an oversight?

[TR] Yes, will fix in next update.

Thanks and Regards,
-Tiru

Simon

On Mon, Oct 27, 2014 at 8:01 AM, Tirumaleswar Reddy (tireddy) <[email-masked]<mailto:[email-masked]>> wrote:
We've published a draft that describes TURN selection criteria, as guidelines, that can be used by a client to perform an informed TURN server selection decision when a client discovers multiple TURN servers.  Comments and suggestions are welcome.

Cheers,
-Tiru

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, October 27, 2014 5:30 PM
To: Prashanth Patil (praspati); Tirumaleswar Reddy (tireddy); Gonzalo Salgueiro (gsalguei); Prashanth Patil (praspati); Gonzalo Salgueiro (gsalguei); Tirumaleswar Reddy (tireddy)
Subject: New Version Notification for draft-patil-tram-turn-serv-selection-00.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tram

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Wed, 29 Oct 2014 06:37:03 +0000

> On Oct 27, 2014, at 9:58 AM, Simon Perreault <[email-masked]> wrote:
> 
> Interesting!
> 

There are many Informational documents that use 2119 language, so they aren't be mutually exclusive.   That said, it is meant to be purely as a BCP-style Informational document.  Whether or not usage of 2119 language is utilized can be determined if we move forward with the document.

Cheers,

Gonzalo

> Simon
> 
> On Mon, Oct 27, 2014 at 8:01 AM, Tirumaleswar Reddy (tireddy) <[email-masked]> wrote:

---

From: Simon Perreault <[email-masked]>
Date: Wed, 29 Oct 2014 09:35:01 -0400

On Wed, Oct 29, 2014 at 2:37 AM, Gonzalo Salgueiro (gsalguei) <
[email-masked]> wrote:

> > Quick procedural question: The intended status says Informational, but
> the text uses RFC2119 keywords. Is this an oversight?
>
> There are many Informational documents that use 2119 language, so they
> aren't be mutually exclusive.

Correct.

>  That said, it is meant to be purely as a BCP-style Informational
> document.  Whether or not usage of 2119 language is utilized can be
> determined if we move forward with the document.

Understood. Although with its current content, which is fairly
prescriptive, I think that draft would warrant a Proposed Standard intended
status.

Simon

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Wed, 29 Oct 2014 14:11:09 +0000

> On Oct 29, 2014, at 9:35 AM, Simon Perreault <[email-masked]> wrote:
> 
> 
> On Wed, Oct 29, 2014 at 2:37 AM, Gonzalo Salgueiro (gsalguei) <[email-masked]> wrote:
> There are many Informational documents that use 2119 language, so they aren't be mutually exclusive. 
> 
> Correct.
>  
>  That said, it is meant to be purely as a BCP-style Informational document.  Whether or not usage of 2119 language is utilized can be determined if we move forward with the document.
> 
> Understood. Although with its current content, which is fairly prescriptive, I think that draft would warrant a Proposed Standard intended status.

I'd be fine with that.  At this point I'd be happy to simply hear comments on the draft ;-)

Cheers,

-G