Subject: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-05.txt

From: [email-masked]
Date: Thu, 02 Oct 2014 00:08:39 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the TURN Revised and Modernized Working Group of the IETF.

        Title           : Session Traversal Utilities for NAT (STUN) Extension for Third Party Authorization
        Authors         : Tirumaleswar Reddy
                          Prashanth Patil
                          Ram Mohan Ravindranath
                          Justin Uberti
	Filename        : draft-ietf-tram-turn-third-party-authz-05.txt
	Pages           : 20
	Date            : 2014-10-02

Abstract:
   This document proposes the use of OAuth to obtain and validate
   ephemeral tokens that can be used for Session Traversal Utilities for
   NAT (STUN) authentication.  The usage of ephemeral tokens ensure that
   access to a STUN server can be controlled even if the tokens are
   compromised.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tram-turn-third-party-authz/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tram-turn-third-party-authz-05

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turn-third-party-authz-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Oleg Moskalenko <[email-masked]>
Date: Thu, 2 Oct 2014 00:18:00 -0700

I agree with the changes.

Thanks
Oleg

---

From: Oleg Moskalenko <[email-masked]>
Date: Mon, 13 Oct 2014 02:41:55 -0700

The third-party authorization option has been implemented in Coturn:

https://code.google.com/p/coturn/

Oleg

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 13 Oct 2014 10:13:58 +0000

Awesome.

-Tiru

From: tram [mailto:[email-masked]] On Behalf Of Oleg Moskalenko
Sent: Monday, October 13, 2014 3:12 PM
To: [email-masked]
Subject: Re: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-05.txt

On Thu, Oct 2, 2014 at 12:18 AM, Oleg Moskalenko <[email-masked]<mailto:[email-masked]>> wrote:
I agree with the changes.
Thanks
Oleg

---

From: Oleg Moskalenko <[email-masked]>
Date: Mon, 13 Oct 2014 10:25:23 -0700

As IANA has not assigned the attribute numbers, yet, we are using the
unassigned values 0x8031 and 0x0031.

On Mon, Oct 13, 2014 at 3:13 AM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

>  Awesome.
>
>
>
> -Tiru
>
>
>
> *From:* tram [mailto:[email-masked]] *On Behalf Of *Oleg Moskalenko
> *Sent:* Monday, October 13, 2014 3:12 PM
> *To:* [email-masked]
> *Subject:* Re: [tram] I-D Action:
> draft-ietf-tram-turn-third-party-authz-05.txt
>
>
>

---

From: Simon Perreault <[email-masked]>
Date: Tue, 14 Oct 2014 10:19:30 -0400

+1!

Simon

On Mon, Oct 13, 2014 at 6:13 AM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram
>
>

---

From: "Olle E. Johansson" <[email-masked]>
Date: Tue, 14 Oct 2014 16:22:06 +0200

Great work Oleg! +pi !

/O
> Simon
> 
> On Mon, Oct 13, 2014 at 6:13 AM, Tirumaleswar Reddy (tireddy) <[email-masked]> wrote:
> Awesome.
> 
>  
> 
> -Tiru
> 
>  
> 
> On Thu, Oct 2, 2014 at 12:18 AM, Oleg Moskalenko <[email-masked]> wrote:
>