Subject: Re: [tram] Last Call: <draft-ietf-tram-alpn-06.txt> (Application Layer Protocol Negotiation (ALPN) labels for Session Traversal Utilities for NAT (STUN) Usages) to Proposed Standard

From: "Prashanth Patil (praspati)" <[email-masked]>
Date: Wed, 15 Oct 2014 07:01:57 +0000

Hi Adam,
The concerning use cases described in the draft were to indicate that the new ALPN identifiers could also be considered for WebRTC firewall traversal (as pointed out in http://tools.ietf.org/html/draft-hutton-rtcweb-nat-firewall-considerations-03#section-4.2).
End to end identifier negotiation is still the goal of this draft i.e. to negotiate the use of stun and its usages.

We'll remove these use cases and stick to end to end negotiation.

-Prashanth

> On Thu, Oct 9, 2014 at 15:41, Adam Langley <[email-masked]> wrote:

>> Is your concern specific to TRAM's proposed use of ALPN, or does it apply to
>> ALPN in general?

> In general I think the IETF should be promoting the end-to-end
> principle. My concern is specifically about TRAM implicitly endorsing
> the idea that the network should be applying policy like that.

> (There's also a fair amount of irony in that fact that the second
> example suggests ALPN be used to get around the fact that networks
> often discriminate based on TCP port numbers, and the first example is
> suggesting that networks do exactly the same thing to ALPN
> identifiers.)

> Cheers

> AGL

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Sun, 26 Oct 2014 23:44:41 -0500

> We'll remove these use cases and stick to end to end negotiation.
Just so I'm clear, should I be expecting a -07?

Thanks,

Spencer

> -Prashanth
>
> > On Thu, Oct 9, 2014 at 15:41, Adam Langley <[email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Mon, 27 Oct 2014 04:53:17 +0000

Hi Spencer - 

Do you want that -07 prior to IESG review?  We assumed we should wait to make all changes after IESG review.  We're flexible and can do it either way.  Just let us know.

Cheers,

Gonzalo

> On Oct 27, 2014, at 12:44 AM, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> 
> 
> On Wednesday, October 15, 2014, Prashanth Patil (praspati) <[email-masked]> wrote:
> Hi Adam,
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram

---

From: Spencer Dawkins <[email-masked]>
Date: Mon, 27 Oct 2014 08:47:50 -0500

> Do you want that -07 prior to IESG review?  We assumed we should wait to make all changes after IESG review.  We're flexible and can do it either way.  Just let us know.

Ah - I'm glad we had this conversation!

My preference would be to have the IESG review a clean version of drafts 
that receive Last Call or review comments. That makes it easier for 
everyone to compare what the Last Call and review comments were to what 
the working group thinks the draft says as a result.

So, yes, please respin the draft.

And I'm sorry I didn't ask sooner.

Spencer

---

From: Spencer Dawkins <[email-masked]>
Date: Mon, 27 Oct 2014 09:08:28 -0500

On 10/15/2014 02:01 AM, Prashanth Patil (praspati) wrote:
> Hi Adam,
> The concerning use cases described in the draft were to indicate that 
> the new ALPN identifiers could also be considered for WebRTC firewall 
> traversal (as pointed out in 
> http://tools.ietf.org/html/draft-hutton-rtcweb-nat-firewall-considerations-03#section-4.2).
> End to end identifier negotiation is still the goal of this draft i.e. 
> to negotiate the use of stun and its usages.

Sorry for chiming in late. I saw this exchange when it happened, but I'm 
still thinking about it.

I understood Adam's point to be "the draft says you can use ALPN labels 
to do something we don't think people should do", and Prashanth's 
response to be "we'll make sure the draft doesn't say that".

That might be the right action.

What finally sunk in for me, was that changing the draft so that it 
doesn't include those use cases, doesn't prevent anyone from doing what 
Adam doesn't think should be done, does it?

Would it be better to point out this concern in the draft, and perhaps 
explain why this is discouraged?

That's not a suggestion that you should do that. It's an honest question.

Thanks,

Spencer, as your more alert AD ...

---

From: Simon Perreault <[email-masked]>
Date: Mon, 27 Oct 2014 10:19:36 -0400

> That's not a suggestion that you should do that. It's an honest question.

My take on this is that any ALPN code would have the same consideration. So
if it's something we want to say (I don't have an opinion either way), then
it needs to be said about ALPN in general, not in this STUN/TURN-specific
ALPN usage.

Simon

---

From: "Prashanth Patil (praspati)" <[email-masked]>
Date: Mon, 27 Oct 2014 14:21:57 +0000

Hi Spencer,
Yes, a middle box could still use ALPN identifiers to make policy decisions. But that’s true with any ALPN identifier and not specific to identifiers defined in this draft.

-Prashanth

From: Spencer Dawkins <[email-masked]<mailto:[email-masked]>>
Date: Monday, October 27, 2014 7:38 PM
To: Prashanth Patil <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Simon Perreault <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [tram] Last Call: <draft-ietf-tram-alpn-06.txt> (Application Layer Protocol Negotiation (ALPN) labels for Session Traversal Utilities for NAT (STUN) Usages) to Proposed Standard

Hi Adam,

Sorry for chiming in late. I saw this exchange when it happened, but I'm still thinking about it.

I understood Adam's point to be "the draft says you can use ALPN labels to do something we don't think people should do", and Prashanth's response to be "we'll make sure the draft doesn't say that".

What finally sunk in for me, was that changing the draft so that it doesn't include those use cases, doesn't prevent anyone from doing what Adam doesn't think should be done, does it?

Would it be better to point out this concern in the draft, and perhaps explain why this is discouraged?

Thanks,

-Prashanth
> On Thu, Oct 9, 2014 at 15:41, Adam Langley <[email-masked]><mailto:[email-masked]> wrote:

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/tram