Subject: [tram] TURN over WebSocket

From: Victor Pascual Avila <[email-masked]>
Date: Mon, 1 Dec 2014 10:10:45 +0100

Hi,

last year we put together this I-D:
https://tools.ietf.org/html/draft-chenxin-behave-turn-websocket-01

We have recently received some emails indicating there's interest in
reviving this work.

Use case: only traffic on ports 80 and 443 are allowed and the
need/requirement to run both HTTPS and TURN servers on port 443, on
the same IP address.

Shall we create a new milestone for this?

Cheers,
-Victor

---

From: Simon Perreault <[email-masked]>
Date: Mon, 1 Dec 2014 10:15:02 -0500

> Shall we create a new milestone for this?

All,

Note that this question from Victor is intended for the working group. The
chairs are in listening mode! :)

Simon

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 1 Dec 2014 15:49:19 +0000

https://tools.ietf.org/html/draft-ietf-httpbis-tunnel-protocol-00 already solves the problem with firewall only permitting HTTP(S) flows through a proxy. Please explain the firewall configuration in which the above technique will not work.

-Tiru

From: tram [mailto:[email-masked]] On Behalf Of Simon Perreault
Sent: Monday, December 01, 2014 8:45 PM
To: Victor Pascual Avila
Cc: [email-masked]; [email-masked]
Subject: Re: [tram] TURN over WebSocket

On Mon, Dec 1, 2014 at 4:10 AM, Victor Pascual Avila <[email-masked]<mailto:[email-masked]>> wrote:
Shall we create a new milestone for this?

All,

Note that this question from Victor is intended for the working group. The chairs are in listening mode! :)

Simon

---

From: Sergio Garcia Murillo <[email-masked]>
Date: Mon, 01 Dec 2014 16:57:21 +0100

Transparent proxying for example

Best regards
Sergio

On 01/12/2014 16:49, Tirumaleswar Reddy (tireddy) wrote:
>
> https://tools.ietf.org/html/draft-ietf-httpbis-tunnel-protocol-00 
> already solves the problem with firewall only permitting HTTP(S) flows 
> through a proxy. Please explain the firewall configuration in which 
> the above technique will not work.
>
> -Tiru
>
> *From:*tram [mailto:[email-masked]] *On Behalf Of *Simon Perreault
> *Sent:* Monday, December 01, 2014 8:45 PM
> *To:* Victor Pascual Avila
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [tram] TURN over WebSocket
>
> On Mon, Dec 1, 2014 at 4:10 AM, Victor Pascual Avila 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 1 Dec 2014 20:46:12 +0000

I am in favor of adopting this.

On Dec 1, 2014, at 4:10 AM, Victor Pascual Avila <[email-masked]> wrote:

> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram
>

---

From: Brandon Williams <[email-masked]>
Date: Mon, 01 Dec 2014 17:46:17 -0500

Hi Victor,

Can't ALPN be used to allow both servers to run on port 443? What 
justifies the greater complexity of using WSS?

Thanks,
--Brandon

-- 
Brandon Williams; Senior Principal Software Engineer
Emerging Products Engineering; Akamai Technologies Inc.

---

From: Simon Perreault <[email-masked]>
Date: Thu, 18 Dec 2014 14:12:17 -0500

Ok here's our recap of the discussion, as chairs:

- Nobody disagrees about the technical merit of TURN over WebSockets
(ToWS). That is, nobody said it won't work, it will break stuff, or won't
actually solve the problem.

- There is disagreement about what the problem actually is, and whether we
really do need ToWS in the context of WebRTC.

- Nevertheless, there is an important number of TRAMsters that appear to be
interested in working on ToWS.

So, unless somebody makes a compelling argument against enabling that group
of interested people to work on ToWS within TRAM, we will propose a new
milestone for this work, and adopt draft-chenxin-behave-turn-websocket as
WG document.

Simon & Gonzalo