Subject: [tram] I-D Action: draft-ietf-tram-turnbis-01.txt

From: [email-masked]
Date: Thu, 29 Jan 2015 21:18:24 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the TURN Revised and Modernized Working Group of the IETF.

        Title           : Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)
        Authors         : Tirumaleswar Reddy
                          Alan Johnston
                          Philip Matthews
                          Jonathan Rosenberg
	Filename        : draft-ietf-tram-turnbis-01.txt
	Pages           : 77
	Date            : 2015-01-29

Abstract:
   If a host is located behind a NAT, then in certain situations it can
   be impossible for that host to communicate directly with other hosts
   (peers).  In these situations, it is necessary for the host to use
   the services of an intermediate node that acts as a communication
   relay.  This specification defines a protocol, called TURN (Traversal
   Using Relays around NAT), that allows the host to control the
   operation of the relay and to exchange packets with its peers using
   the relay.  TURN differs from some other relay control protocols in
   that it allows a client to communicate with multiple peers using a
   single relay address.

   The TURN protocol was designed to be used as part of the ICE
   (Interactive Connectivity Establishment) approach to NAT traversal,
   though it also can be used without ICE.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tram-turnbis/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tram-turnbis-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turnbis-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Fri, 30 Jan 2015 05:39:37 +0000

Major changes in this revision are support for SSODA and merged RFC6156. Please review and provide your valuable comments. 
Diff from previous version : http://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=draft-ietf-tram-turnbis-01.txt 

-Tiru

> -----Original Message-----
> From: tram [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Friday, January 30, 2015 10:48 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tram] I-D Action: draft-ietf-tram-turnbis-01.txt
> 
> 
>         Title           : Traversal Using Relays around NAT (TURN): Relay Extensions
> to Session Traversal Utilities for NAT (STUN)
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram

---

From: Oleg Moskalenko <[email-masked]>
Date: Sat, 31 Jan 2015 15:10:01 -0800

Hi Tiru

as the turnbis written, in its current form, it allows EVEN-PORT attribute
in the ALLOCATE request together with the ADDITIONAL-ADDRESS-FAMILY
attribute. If this is really what you want, then the RESERVATION-TOKEN
handling must be changed in the ALLOCATE response - because there will be
two RESERVATION-TOKEN attributes included into the response (when
EVEN-PORT=1).

Or the EVEN-PORT must be prohibited in the same request with
ADDITIONAL-ADDRESS-FAMILY.

As of now, there is inherent inconsistency.

Thanks
Oleg

On Thu, Jan 29, 2015 at 9:39 PM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

> Major changes in this revision are support for SSODA and merged RFC6156.
> Please review and provide your valuable comments.
> Diff from previous version :
> http://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=draft-ietf-tram-turnbis-01.txt
>
> -Tiru
>

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Sun, 1 Feb 2015 02:36:07 +0000

From: Oleg Moskalenko [mailto:[email-masked]]
Sent: Sunday, February 01, 2015 4:40 AM
To: Tirumaleswar Reddy (tireddy)
Cc: [email-masked]
Subject: Re: [tram] I-D Action: draft-ietf-tram-turnbis-01.txt

Hi Tiru
as the turnbis written, in its current form, it allows EVEN-PORT attribute in the ALLOCATE request together with the ADDITIONAL-ADDRESS-FAMILY attribute. If this is really what you want, then the RESERVATION-TOKEN handling must be changed in the ALLOCATE response - because there will be two RESERVATION-TOKEN attributes included into the response (when EVEN-PORT=1).
Or the EVEN-PORT must be prohibited in the same request with ADDITIONAL-ADDRESS-FAMILY.
As of now, there is inherent inconsistency.
[TR] Agreed, will update the draft that AAF must not be used with even port.
-Tiru
Thanks
Oleg

On Thu, Jan 29, 2015 at 9:39 PM, Tirumaleswar Reddy (tireddy) <[email-masked]<mailto:[email-masked]>> wrote:
Major changes in this revision are support for SSODA and merged RFC6156. Please review and provide your valuable comments.
Diff from previous version : http://tools.ietf.org/rfcdiff?difftype=--hwdiff&url2=draft-ietf-tram-turnbis-01.txt

-Tiru

> From: tram [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of internet-
> [email-masked]<mailto:[email-masked]>
> To: [email-masked]<mailto:[email-masked]>
> Cc: [email-masked]<mailto:[email-masked]>
> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.
>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tram

---

From: Oleg Moskalenko <[email-masked]>
Date: Sat, 31 Jan 2015 23:07:14 -0800

Tiru, I do not see any problem with EVEN-PORT when its value is 0. The
problem only arises when EVEN-PORT is equals 0x80 (reserved allocation
required). So I'd suggest for forbid only the situation when the highest
bit of EVEN-PORT is 1.

Thanks
Oleg

On Sat, Jan 31, 2015 at 6:36 PM, Tirumaleswar Reddy (tireddy) <
[email-masked]> wrote:

>    *From:* Oleg Moskalenko [mailto:[email-masked]]
> *Sent:* Sunday, February 01, 2015 4:40 AM
> *To:* Tirumaleswar Reddy (tireddy)
> *Cc:* [email-masked]
> *Subject:* Re: [tram] I-D Action: draft-ietf-tram-turnbis-01.txt
>
>
>
> Hi Tiru
>