Subject: [tram] STUNTrace and PMTUD drafts

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Thu, 26 Mar 2015 22:39:18 +0000

TRAMsters -

Based on the discussion (during and after) the final presentation on STUNTrace it is clear alignment and overlap between STUNTrace and the PMTUD draft (draft-petithuguenin-tram-stun-pmtud<https://tools.ietf.org/html/draft-petithuguenin-tram-stun-pmtud-00>).  The PMTUD draft is solving a broader problem, whereas STUNTrace is practically a specialized use-case of it.  I think the best way to proceed with these is to progress these independently, remove the overlap and cross reference each appropriately.  Do folks agree with this approach?

Cheers,

Gonzalo

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 26 Mar 2015 17:41:20 -0500

On 03/26/2015 05:39 PM, Gonzalo Salgueiro (gsalguei) wrote:
> TRAMsters -
> 
> Based on the discussion (during and after) the final presentation on
> STUNTrace it is clear alignment and overlap between STUNTrace and the
> PMTUD draft
> (draft-petithuguenin-tram-stun-pmtud<https://tools.ietf.org/html/draft-petithuguenin-tram-stun-pmtud-00>).
> The PMTUD draft is solving a broader problem, whereas STUNTrace is
> practically a specialized use-case of it.  I think the best way to
> proceed with these is to progress these independently, remove the
> overlap and cross reference each appropriately.  Do folks agree with
> this approach?
> 

I agree with that plan.

- -- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org
Profile: http://www.linkedin.com/in/petithug

---

From: Justin Uberti <[email-masked]>
Date: Thu, 26 Mar 2015 17:47:44 -0500

+1

On Thu, Mar 26, 2015 at 5:41 PM, Marc Petit-Huguenin <[email-masked]>
wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA256
>
> > (draft-petithuguenin-tram-stun-pmtud<
> https://tools.ietf.org/html/draft-petithuguenin-tram-stun-pmtud-00>).
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1
>
> iQIcBAEBCAAGBQJVFIsQAAoJECnERZXWan7EXvkQAItBGEAtuBPVIgsihWz2zqoa
> MCZTVRvoqrzozL52748HdPPVNYxnm4fn9eerCqlZC45Ht9u9+TM8Exe8wj7TzKvW
> 2Cd5TAMO7krD1+lO1wgJG2VZ6AHHo3GbhrYBrPiIQphpZ7D2CMLu+cHjlsMweq06
> PfFypMYUQj8aU3IdVQTPVsj3VERLOrz2PokMtP3iedBO7TUgegxk/pQvROX6cqDf
> QgC0y4P7i2wE1eqgIw/wytNQiBlnVySwOiXkAoRQf2Knw+Wj0myreXNpxQU6DFQY
> XTVREA5HOH6ljcatA/7zW0KSjm9eQmORL/hUwqxZuw0YY5Ktfvyl38LQ6dvOtHdJ
> DmgwU5iOJ6Up+5zEQ5e1MHN52UTyWAT4Z01Sf+sEaZF6de20JnSQH80XxP6eVxm9
> MPDM1B1631bmW0bmBt8IGhfnLwqC5QEl/A+OfGGVEaZ67T/ntR+DEZsphMc9NYDu
> +nSnQQkzO0NL7MCKemaFW5Li0Xn01a9/97u+Qc47Ttc0K2sSlt9F9+5r1y/dYaA3
> NVjDxKoJA7Tx6XYjVXiNMrAr7wdwqfRhOyesyAXMLwYOR3rfH8K9Js5OZqm5fPLy
> 181r38bsQCXv5Rt6XWklcBHMbC234ie4c8Uli7pAzYuLurWZhwRRtL1Jo9MEcLAa
> ybwHEkyS1WI58QGbUIs/
> =5jV6
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram
>

---

From: Suhas Nandakumar <[email-masked]>
Date: Thu, 26 Mar 2015 19:40:25 -0500

+1

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Fri, 27 Mar 2015 17:53:55 +0000

+/-0

I think it will make it easier for the reader if the two was merged. I _think_ there is a lot of overlapping the generic mechanism; set something in the outgoing packet prepare to receive ICMP). Once that is described the mtu and traecroute functionality can be described in fairly small sections.

I will make an attempt to merge them and see how that looks.

.-.
Pål-Erik

On 26 Mar 2015, at 19:40, Suhas Nandakumar <[email-masked]<mailto:[email-masked]>> wrote:

+1

On Thu, Mar 26, 2015 at 5:47 PM, Justin Uberti <[email-masked]<mailto:[email-masked]>> wrote:
+1

On Thu, Mar 26, 2015 at 5:41 PM, Marc Petit-Huguenin <[email-masked]<mailto:[email-masked]>> wrote:

I agree with that plan.

- --
Marc Petit-Huguenin
Email: [email-masked]<mailto:[email-masked]>
Blog: http://blog.marc.petit-huguenin.org<http://blog.marc.petit-huguenin.org/>
Profile: http://www.linkedin.com/in/petithug

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tram

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tram

_______________________________________________
tram mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/tram