Subject: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-14.txt

From: [email-masked]
Date: Wed, 15 Apr 2015 23:21:19 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the TURN Revised and Modernized Working Group of the IETF.

        Title           : Session Traversal Utilities for NAT (STUN) Extension for Third Party Authorization
        Authors         : Tirumaleswar Reddy
                          Prashanth Patil
                          Ram Mohan Ravindranath
                          Justin Uberti
	Filename        : draft-ietf-tram-turn-third-party-authz-14.txt
	Pages           : 23
	Date            : 2015-04-15

Abstract:
   This document proposes the use of OAuth 2.0 to obtain and validate
   ephemeral tokens that can be used for Session Traversal Utilities for
   NAT (STUN) authentication.  The usage of ephemeral tokens ensures
   that access to a STUN server can be controlled even if the tokens are
   compromised.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tram-turn-third-party-authz/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tram-turn-third-party-authz-14

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turn-third-party-authz-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 16 Apr 2015 06:25:57 +0000

This reversion addresses comments received from Richard, Stephen and Kathleen as part of ISEG review and comments from Oleg.

Cheers,
-Tiru

-----Original Message-----
From: tram [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, April 16, 2015 11:51 AM
To: [email-masked]
Cc: [email-masked]
Subject: [tram] I-D Action: draft-ietf-tram-turn-third-party-authz-14.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
tram mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tram

---

From: Oleg Moskalenko <[email-masked]>
Date: Sun, 19 Apr 2015 02:35:46 -0700

I'd suggest another minor cosmetic change. In the edition 14, the GCM
algorithm names are taken from section 4.1 of
http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-40; but
the non-GCM algorithm names are taken from section 5.1. I'd suggest,
for consistency, use the section 5.1 for all supported algorithm
names:

A256GCMKW change to A256GCM

Thanks
Oleg

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Sun, 19 Apr 2015 10:09:04 +0000

> From: Oleg Moskalenko [mailto:[email-masked]]
> Sent: Sunday, April 19, 2015 3:06 PM
> To: Tirumaleswar Reddy (tireddy)
> Cc: [email-masked]
> Subject: Re: [tram] FW: I-D Action: draft-ietf-tram-turn-third-party-authz-
> 14.txt
> 
> http://tools.ietf.org/html/draft-ietf-jose-json-web-algorithms-40; but the
> non-GCM algorithm names are taken from section 5.1. I'd suggest, for
> consistency, use the section 5.1 for all supported algorithm
> names:
> 

Yes, changed in my local copy. 

-Tiru

> > This reversion addresses comments received from Richard, Stephen and
> Kathleen as part of ISEG review and comments from Oleg.
> >
> > Cheers,
> > -Tiru
> >
> > Subject: [tram] I-D Action:
> > draft-ietf-tram-turn-third-party-authz-14.txt
> >
> >
> > Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> >