Subject: [tram] I-D Action: draft-ietf-tram-stun-path-data-01.txt

From: [email-masked]
Date: Tue, 07 Apr 2015 08:43:19 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the TURN Revised and Modernized Working Group of the IETF.

        Title           : Discovery of path characteristics using STUN
        Authors         : Tirumaleswar Reddy
                          Dan Wing
                          Paal-Erik Martinsen
                          Varun Singh
	Filename        : draft-ietf-tram-stun-path-data-01.txt
	Pages           : 9
	Date            : 2015-04-07

Abstract:
   A host with multiple interfaces needs to choose the best interface
   for communication.  Oftentimes, this decision is based on a static
   configuration and does not consider the path characteristics, which
   may affect the user experience.

   This document describes a mechanism for an endpoint to discover the
   path characteristics using Session Traversal Utilities for NAT (STUN)
   messages.  The measurement information can then be used to influence
   the endpoint's Interactive Connectivity Establishment (ICE) candidate
   pair selection algorithm.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tram-stun-path-data/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-tram-stun-path-data-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-tram-stun-path-data-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Tue, 7 Apr 2015 15:46:47 +0000

http://tools.ietf.org/html/draft-ietf-tram-stun-path-data-01 addresses comments from Martin and Oleg. 

Thanks and Regards,
-Tiru

> -----Original Message-----
> From: tram [mailto:[email-masked]] On Behalf Of internet-
> [email-masked]
> Sent: Tuesday, April 07, 2015 9:13 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [tram] I-D Action: draft-ietf-tram-stun-path-data-01.txt
> 
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram

---

From: Simon Perreault <[email-masked]>
Date: Tue, 07 Apr 2015 11:53:07 -0400

> http://tools.ietf.org/html/draft-ietf-tram-stun-path-data-01 addresses comments from Martin and Oleg. 

Awesome! Thanks for the very fast response time!

Simon

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Wed, 8 Apr 2015 10:58:59 +0000

Hi,

I think the name of the draft is a bit wide. The draft will discover loss and RTT, when I read “path characteristics” I start thinking about all sorts of things like available bandwidth, qDelay, jitter and so on.  

And do we really discover loss and RTT? Wouldn’t that be something we measure?

I would like the draft to change name to:
“Measurement of loss and RTT using STUN (MOLAR)”

The “PATH-CHARACTERISTIC” attribute is also a bit misleading in its name.  I think something like “RETRANSMIT-COUNT” and renaming the fields to NumRequests and NumResponses is more appropriate.

Defining the attribute in one main section would make it easier for developers to scan through the draft. And would avoid having to post the attribute ASCI art twice (Section 3.1 and 3.2). 

.-.
Pål-Erik

> On 07 Apr 2015, at 17:46, Tirumaleswar Reddy (tireddy) <[email-masked]> wrote:
>