Subject: [tram] Fwd: New Version Notification for draft-martinsen-tram-turnbandwidthprobe-00.txt

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Fri, 29 May 2015 11:31:59 +0000

Hi,

We posted a new draft today.

It is s a simple draft describing how a client can utilise a TURN server to measure available bandwidth by sending traffic to itself through the turn server. No TURN server modifications are needed.

The three drafts
- PMTUD using STUN(https://tools.ietf.org/html/draft-petithuguenin-tram-stun-pmtud)
- STUN Traceroute (https://tools.ietf.org/html/draft-martinsen-tram-stuntrace)
- TURN Bandwidth (The draft in this mail) (https://www.ietf.org/internet-drafts/draft-martinsen-tram-turnbandwidthprobe)

form a simple solution to probe the network for useful information without requiring any change to the network infrastructure.

.-.
Pål-Erik

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-martinsen-tram-turnbandwidthprobe-00.txt
Date: 29 May 2015 09:35:27 CEST
To: Gonzalo Salgueiro <[email-masked]<mailto:[email-masked]>>, Trond Andersen <[email-masked]<mailto:[email-masked]>>, Trond Andersen <[email-masked]<mailto:[email-masked]>>, "Paal-Erik Martinsen" <[email-masked]<mailto:[email-masked]>>, Gonzalo Salgueiro <[email-masked]<mailto:[email-masked]>>, "Marc Petit-Huguenin" <[email-masked]<mailto:[email-masked]>>, Marc Petit-Huguenin <[email-masked]<mailto:[email-masked]>>, Paal-Erik Martinsen <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-martinsen-tram-turnbandwidthprobe-00.txt
has been successfully submitted by Paal-Erik Martinsen and posted to the
IETF repository.

Name: draft-martinsen-tram-turnbandwidthprobe
Revision: 00
Title: Traversal Using Relays around NAT (TURN) Bandwidth Probe
Document date: 2015-05-29
Group: Individual Submission
Pages: 11
URL:            https://www.ietf.org/internet-drafts/draft-martinsen-tram-turnbandwidthprobe-00.txt
Status:         https://datatracker.ietf.org/doc/draft-martinsen-tram-turnbandwidthprobe/
Htmlized:       https://tools.ietf.org/html/draft-martinsen-tram-turnbandwidthprobe-00

Abstract:
  Performing pre-call probing to discover a reasonable value for the
  available bandwidth, is useful information that can be utilized by
  bandwidth sensitive or bandwidth intensive network devices (e.g.,
  video encoders).  The method described herein is intended to produce
  an initial bandwidth value.  Applications using this mechanism should
  also employ appropriate rate adaptation techniques.  In addition to
  bandwidth, latency and bufferbloat can also be measured.  No
  modification is needed on the server side.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---

From: Simon Perreault <[email-masked]>
Date: Fri, 29 May 2015 10:57:40 -0400

Le 2015-05-29 07:31, Pal Martinsen (palmarti) a écrit :
> It is s a simple draft describing how a client can utilise a TURN server
> to measure available bandwidth by sending traffic to itself through the
> turn server. No TURN server modifications are needed. 

Cool! I can see this being useful.

I think it would be worth mentioning that the client is in theory free
to use any format for the payload, but in practice using STUN makes it
possible to multiplex with existing traffic. So a client that doesn't
need multiplexing could do away with all the STUN complexity and just
use a home-grown, simple format. This may seem obvious but it still took
me a good 5 minutes of head scratching to figure out.

> The three drafts
> - PMTUD using
> STUN(https://tools.ietf.org/html/draft-petithuguenin-tram-stun-pmtud)
> - STUN Traceroute
> (https://tools.ietf.org/html/draft-martinsen-tram-stuntrace)
> - TURN Bandwidth (The draft in this mail)
> (https://www.ietf.org/internet-drafts/draft-martinsen-tram-turnbandwidthprobe)
> 
> form a simple solution to probe the network for useful information
> without requiring any change to the network infrastructure. 

This is starting to look like... *gasp*... a framework! ;)

Simon

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Fri, 29 May 2015 19:41:11 +0000

> On May 29, 2015, at 10:57 AM, Simon Perreault <[email-masked]> wrote:
> 

Our thoughts exactly ;-)

> me a good 5 minutes of head scratching to figure out.

Good point. We’ll update the draft clarifying this.

> This is starting to look like... *gasp*... a framework! ;)

This is our intent. We’d like the WG to consider their usefulness and entertain the possibility of adopting these as WG documents (obviously with associated milestones created).

Cheers,

Gonzalo

> 
> Simon
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram