Subject: [tram] Review draft-ietf-tram-turn-server-discovery-02

From: Eduardo Gueiros <[email-masked]>
Date: Mon, 18 May 2015 01:45:11 -0600

Authors, I have read draft-ietf-tram-turn-server-discovery-02 and the following small review. 

Overall I am impressed with the quality of the document. It has been easy to read, it has good references and I really like the proposed solutions and how they are individually addressed. Well done addressing security concerns.

It is very well written and I this time I’d like just to point some writing nits and suggestions. 

Thanks, 
Eduardo
eduardo at jive.com

—

Introduction
Paragraph 1
General comment: Paragraph too large. Consider breaking down in two or three paragraphs.

Introduction
Paragraph 2
> based on the network in the which the TURN client finds itself.

- Remove extra “the” to read:
based on the network in which the TURN client finds itself.

- Suggestion: Add text before bullets:
The three discovery mechanisms are:

Section 3, bullet #1
>1.  Local Configuration : Local or manual configuration should be
>       tried first, as it may be an explicit preferred choice of a user.

Suggestion:
1.  Local Configuration : If local or manual configuration exists, they should be
       tried first, as it may be an explicit preferred choice of a user.

Section 3, bullet #2
>Service Resolution : Service Resolution : The TURN client
>       attempts to perform TURN service resolution using the host's DNS
>       domain.

- Remove duplicate "Service Resolution": 
Service Resolution: The TURN client
       attempts to perform TURN service resolution using the host's DNS
       domain.

Section 3, paragraph 4
>A client MAY optionaly
>   choose to perform the discovery procedure only for a desired
>   interface/address combination, if the client does not wish to
>   discover a TURN server for all combinations of interface and address
>   family.

- The comma made this sentence not very clear when I first read it. In my opinion removing the common makes the sentence clearer. 
A client MAY optionaly
   choose to perform the discovery procedure only for a desired
   interface/address combination if the client does not wish to
   discover a TURN server for all combinations of interface and address
   family.

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Mon, 18 May 2015 11:52:32 +0000

Thanks Eduardo for the review. We will address the nits and suggestions in the next revision.

Cheers,
-Tiru
From: Eduardo Gueiros [mailto:[email-masked]]
Sent: Monday, May 18, 2015 1:15 PM
To: [email-masked]
Cc: Prashanth Patil (praspati); Tirumaleswar Reddy (tireddy); Dan Wing (dwing)
Subject: Review draft-ietf-tram-turn-server-discovery-02

Thanks,
Eduardo

eduardo at jive.com

—

Introduction
Paragraph 1

Introduction
Paragraph 2

Section 3, bullet #1

Suggestion:

Section 3, bullet #2

       domain.

Section 3, paragraph 4

A client MAY optionaly

   family.