Subject: [tram] I-D Action: draft-ietf-tram-measurement-rtt-loss-00.txt

From: [email-masked]
Date: Thu, 16 Jun 2016 05:52:27 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the TURN Revised and Modernized of the IETF.

        Title           : Measurement of Round Trip Time and Fractional Loss Using STUN
        Authors         : Paal-Erik Martinsen
                          Tirumaleswar Reddy
                          Dan Wing
                          Varun Singh
	Filename        : draft-ietf-tram-measurement-rtt-loss-00.txt
	Pages           : 9
	Date            : 2016-06-16

Abstract:
   A host with multiple interfaces needs to choose the best interface
   for communication.  Oftentimes, this decision is based on a static
   configuration and does not consider the path characteristics, which
   may affect the user experience.

   This document describes a mechanism for an endpoint to measure the
   path characteristics fractional loss and RTT using Session Traversal
   Utilities for NAT (STUN) messages.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tram-measurement-rtt-loss/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-tram-measurement-rtt-loss-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Pal Martinsen (palmarti)" <[email-masked]>
Date: Thu, 16 Jun 2016 13:06:22 +0000

Hi all,

This version addresses comments and DISCUSSES from the IESG review.
(https://datatracker.ietf.org/doc/draft-ietf-tram-stun-path-data/ballot/)

No technical changes, but name and structure of the draft have changed.

Implementation of the draft can also be found at: https://github.com/NATTools/stunlib

Changes:

- Renamed draft to "Measurement of Round Trip Time and Fractional Loss Using STUN"
This better reflects what the draft actually describes.
Rewrote Abstract to reflect those changes

- Renamed attribute PATH-CHARACTERISTIC to
  TRANSACTION_TRANSMIT_COUNTER
Again to better reflect what the attribute actually does. Also adjusted the field names in the attribute.

- Renamed section "Path characteristics determination mechanism" ->
  “Measuring RTT and Fractional Loss”

- Down played how ICE should use it. Only hints that this is useful information for ICE like functionality.

- Fix re-transmit vs transmits (off by one problem)

- Added wording regarding passive listening in the security section

- Removed from security section
“Unauthenticated STUN message MUST NOT include the TRANSACTION_TRANSMIT_COUNTER attribute in order to prevent on-path attacker from influencing decision-making.”
An on-path attacker could do much worse thing to the (s)RTP packets
once media is flowing. 

- Fixed examples in section 3.3

- Removed use-cases section. Did not provide value and only served to
limit the possible uses of the mechanism. (The section did serve its
purpose in a draft explaining in detail why). This creates a backward
dependecy I do not think is necessary. It is up to ICE, MPRTP etc to
Really decide if this is something they should use.

.-.
Pål-Erik

> On 16 Jun 2016, at 14:52, [email-masked] wrote:
> 
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram