Subject: [tram] I-D Action: draft-ietf-tram-turnbis-10.txt

From: [email-masked]
Date: Thu, 11 May 2017 02:22:45 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the TURN Revised and Modernized of the IETF.

        Title           : Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)
        Authors         : Tirumaleswar Reddy
                          Alan Johnston
                          Philip Matthews
                          Jonathan Rosenberg
	Filename        : draft-ietf-tram-turnbis-10.txt
	Pages           : 81
	Date            : 2017-05-11

Abstract:
   If a host is located behind a NAT, then in certain situations it can
   be impossible for that host to communicate directly with other hosts
   (peers).  In these situations, it is necessary for the host to use
   the services of an intermediate node that acts as a communication
   relay.  This specification defines a protocol, called TURN (Traversal
   Using Relays around NAT), that allows the host to control the
   operation of the relay and to exchange packets with its peers using
   the relay.  TURN differs from some other relay control protocols in
   that it allows a client to communicate with multiple peers using a
   single relay address.

   The TURN protocol was designed to be used as part of the ICE
   (Interactive Connectivity Establishment) approach to NAT traversal,
   though it also can be used without ICE.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-tram-turnbis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-tram-turnbis-10
https://datatracker.ietf.org/doc/html/draft-ietf-tram-turnbis-10

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-tram-turnbis-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Fri, 12 May 2017 09:34:07 +0000

Updated draft discusses Happy Eyeballs for TURN in Section 2.10 (https://tools.ietf.org/html/draft-ietf-tram-turnbis-10#section-2.10).

-Tiru

-----Original Message-----
From: tram [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, May 11, 2017 2:53 PM
To: [email-masked]
Cc: [email-masked]
Subject: [tram] I-D Action: draft-ietf-tram-turnbis-10.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
tram mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tram

---

From: Brandon Williams <[email-masked]>
Date: Sun, 14 May 2017 17:52:50 -0400

Hi Tiru,

Thanks for the update. I think it looks like what we've discussed.

Are there any other outstanding issues you're tracking that still need 
to be addressed? I'm not aware of any; just wanted to check how close we 
are to closure on this one.

--Brandon

---

From: Jonathan Lennox <[email-masked]>
Date: Mon, 15 May 2017 16:41:55 +0000

> On May 12, 2017, at 5:34 AM, Konda, Tirumaleswar Reddy <[email-masked]> wrote:
> 

It might be worth calling out that if a DTLS server sends HelloVerifyRequest (as it normally will on the open Internet), there’s no need to tear down the DTLS association.

Other than that, this section looks good.

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Wed, 17 May 2017 08:41:12 +0000

-----Original Message-----
From: Jonathan Lennox [mailto:[email-masked]] 
Sent: Monday, May 15, 2017 10:12 PM
To: Konda, Tirumaleswar Reddy <[email-masked]>
Cc: [email-masked]
Subject: Re: [tram] I-D Action: draft-ietf-tram-turnbis-10.txt

Agreed. Added the following line:
If TURN over DTLS server has been configured to require a cookie exchange and if HelloVerifyRequest is received from the TURN servers on both
IP addresses families then the client can silently abandon the connection on the IP address family with lower precedence.

Thanks for the review.

-Tiru

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Wed, 17 May 2017 09:45:01 +0000

-----Original Message-----
From: tram [mailto:[email-masked]] On Behalf Of Brandon Williams
Sent: Monday, May 15, 2017 3:23 AM
To: [email-masked]
Subject: Re: [tram] I-D Action: draft-ietf-tram-turnbis-10.txt

Hi Tiru,

Thanks.

Are there any other outstanding issues you're tracking that still need to be addressed? I'm not aware of any; just wanted to check how close we are to closure on this one.

All comments received from the WG have been addressed. I am only tracking couple of minor changes to the draft to align with stunbis (use MESSAGE-INTEGRITY-SHA256, change from "401 Unauthorized" to "401 Unauthenticated").

-Tiru

--Brandon