Subject: Re: [tram] WGLC: draft-ietf-tram-turnbis-11

From: Brandon Williams <[email-masked]>
Date: Sun, 1 Oct 2017 15:19:36 -0400

I have a couple final comments re: the version 11 and the changes 
between version 10 and version 11. Apologies for taking so long for 
this. I though I had done it already but realize now that I was 
remembering my response to the stunbis update.

1) idnits calls out a handful of things to check or resolve.
a) The doc should use documentation range IPv4 addresses throughout.
b) Are there any cases where IPv6 examples should also be provided?
c) There are some obsolete and/or outdated references to fix.

2) On page 19, there are two new uses of the word "can":
   "the TURN client can silently abandon"
   "the client can silently abandon"
These references are about applying address family precedence. Is this 
text meant to be normative? If so, it should use "MAY" instead of "can".

The rest looks as expected I think.

--Brandon

On 09/15/2017 02:47 PM, Gonzalo Camarillo wrote:
> Folks,
> 
> we are starting a Working Group Last Call (WGLC) on the following draft:
> 
> https://datatracker.ietf.org/doc/draft-ietf-tram-turnbis/
> 
> This WGLC will end on October 2nd. Please, send your comments to this
> list. Thanks!
> 
> Cheers,
> 
> Gonzalo
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram
>

---

From: Brandon Williams <[email-masked]>
Date: Sun, 1 Oct 2017 16:07:22 -0400

One more nit that I just noticed ...

3) Section 15.13. ICMP Attribute contains a field called "Type" in the 
attribute value. Since attributes are TLV encoded with Type and Length 
as the first two fields, it might be better to call this field in the 
attribute value "ICMP Type" instead of just "Type".

--Brandon

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 4 Oct 2017 02:46:10 -0700

Hi,

I completely missed the deadline on that.  I'll sent my long overdue review beginning of next week.

Thanks.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 16 Oct 2017 09:19:24 +0000

Thanks Brandon for the review, Please see inline.

> -----Original Message-----
> From: tram [mailto:[email-masked]] On Behalf Of Brandon Williams
> Sent: Monday, October 2, 2017 12:50 AM
> To: Gonzalo Camarillo <[email-masked]>; [email-masked]
> Subject: Re: [tram] WGLC: draft-ietf-tram-turnbis-11
> 
> I have a couple final comments re: the version 11 and the changes between
> version 10 and version 11. Apologies for taking so long for this. I though I had
> done it already but realize now that I was remembering my response to the
> stunbis update.
> 

Fixed. 

> b) Are there any cases where IPv6 examples should also be provided?

No.

> c) There are some obsolete and/or outdated references to fix.

Fixed all errors reported by idnits. 

> These references are about applying address family precedence. Is this text
> meant to be normative? If so, it should use "MAY" instead of "can".

"SHOULD" looks more suitable than "MAY".

> The rest looks as expected I think.

-Tiru

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 16 Oct 2017 09:28:59 +0000

> Sent: Monday, October 2, 2017 1:37 AM
> 3) Section 15.13. ICMP Attribute contains a field called "Type" in the attribute
> value. Since attributes are TLV encoded with Type and Length as the first two
> fields, it might be better to call this field in the attribute value "ICMP Type"
> instead of just "Type".

Replaced "Type" with "ICMP Type" and "Code" with "ICMP Code".

-Tiru