Subject: Re: [tram] Adam Roach's Discuss on draft-ietf-tram-stun-pmtud-10: (with DISCUSS and COMMENT)

From: Gonzalo Camarillo <[email-masked]>
Date: Mon, 14 Jan 2019 14:05:26 +0000

What is the next step here?

Gonzalo

On 13-Dec-18 16:27, Spencer Dawkins at IETF wrote:
> Hi, Simon, 
> 
> On Thu, Dec 13, 2018 at 7:12 AM Simon Perreault
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     - Pull the definition of PADDING into this document. Declare that
>     we've gathered sufficient experience with PADDING that it now
>     warrants being elevated to Standards Track. That is, it's been
>     proven to work.____
> 
>     __ __
> 
>     This is plausible. It solves the first-order problem. ____
> 
>     __ __
> 
>     I note that RFC 5780 defined a number of new attributes. Is pulling
>     PADDING forward the right thing to do, or are there others that
>     would also qualify (so, perhaps a status change for RFC 5780)? ____
> 
>     __ __
> 
>     I don’t think the others have been implemented much, so that’s why I
>     think only pulling PADDING makes sense. If I remember correctly, I
>     only implemented PADDING in Numb (I don’t have access to the source
>     code anymore so can’t be sure).____
> 
>     __ __
> 
>     Anyone else with an opinion?
> 
> 
> That's helpful information. 
> 
> We should wait for anyone else with information to weigh in, but if it's
> correct that the other experimental attributes haven't been implemented
> and deployed in a way that would provide guidance for standards-track
> use, I think defining PADDING in this document makes more sense to me
> than adding a downref to an experimental RFC that we wouldn't consider
> if the reference was using anything except PADDING.  
> 
> Thanks,
> 
> Spencer
> 
>     ____
> 
>     __ __
> 
>     Simon____
>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 14 Jan 2019 08:25:25 -0600

Hi, Gonzalo,

> > if the reference was using anything except PADDING.

No one has objected in the past month (which included holidays, but I would
have asked this question with a week or two timeout, if the holidays had
not been coming up).

I think bringing the definition of PADDING into the current draft is the
right thing to do.

If TRAM people thought that the other experimental attributes in RFC 5780
don't have enough implementation experience to justify moving them past
Experimental status, changing the status of RFC 5780 to Historic might be
appropriate at some point, but that's not related to the conversation we're
having now, and I haven't asked a question about that, so I'll ignore that
for now.

Thanks for your help with this.

Spencer

---

From: "Gonzalo Salgueiro (gsalguei)" <[email-masked]>
Date: Fri, 18 Jan 2019 18:12:39 +0000

Thanks, Spencer.  We will proceed with bringing the definition of PADDING into the current draft.

Cheers,

Gonzalo

On Jan 14, 2019, at 9:25 AM, Spencer Dawkins at IETF <[email-masked]<mailto:[email-masked]>> wrote:

Hi, Gonzalo,

On Mon, Jan 14, 2019 at 8:05 AM Gonzalo Camarillo <[email-masked]<mailto:[email-masked]>> wrote:
What is the next step here?

Gonzalo

On 13-Dec-18 16:27, Spencer Dawkins at IETF wrote:
> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>

No one has objected in the past month (which included holidays, but I would have asked this question with a week or two timeout, if the holidays had not been coming up).

I think bringing the definition of PADDING into the current draft is the right thing to do.

If TRAM people thought that the other experimental attributes in RFC 5780 don't have enough implementation experience to justify moving them past Experimental status, changing the status of RFC 5780 to Historic might be appropriate at some point, but that's not related to the conversation we're having now, and I haven't asked a question about that, so I'll ignore that for now.

Spencer