Subject: [tram] Suresh Krishnan's No Objection on draft-ietf-tram-turnbis-27: (with COMMENT)

From: Suresh Krishnan via Datatracker <[email-masked]>
Date: Wed, 10 Jul 2019 07:03:51 -0700

Suresh Krishnan has entered the following ballot position for
draft-ietf-tram-turnbis-27: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-tram-turnbis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

* Section 3.7

I think an informative reference to [draft-ietf-intarea-frag-fragile] would be
very useful here. It is a BCP that covers this issue in great detail and has
specific recommendations for different audiences.

* Section 13.2 Page 53

"If the packet is being sent to the peer"

The term "the packet" is ambiguous here. This could potentially refer to the
ICMPv6 packet being sent or the original packet that caused the error. Can you
please clarify which one you mean here?

* References

I do have a better citation for the Fragmentation Considered Harmful paper if
you want to use it.

   [Kent]     Kent, C. and J. Mogul, ""Fragmentation Considered
              Harmful", In Proc. SIGCOMM '87 Workshop on Frontiers in
              Computer Communications Technology, DOI
              10.1145/55483.55524", August 1987,
              <http://www.hpl.hp.com/techreports/Compaq-DEC/
              WRL-87-3.pdf>.

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Thu, 11 Jul 2019 06:11:28 +0000

Hi Suresh,

Thanks for the review. Please see inline 

> -----Original Message-----
> From: tram <[email-masked]> On Behalf Of Suresh Krishnan via
> Datatracker
> Sent: Wednesday, July 10, 2019 7:34 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Subject: [tram] Suresh Krishnan's No Objection on draft-ietf-tram-turnbis-27:
> (with COMMENT)
> 
> This email originated from outside of the organization. Do not click links or
> open attachments unless you recognize the sender and know the content is
> safe.
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 

Sure, updated.

> ICMPv6 packet being sent or the original packet that caused the error. Can
> you please clarify which one you mean here?

Fixed text for clarity as follows:
If the ICMPv4 packet (Destination Unreachable (Type 3) with Code 4) is being sent to the peer, the TURN server SHOULD reduce the MTU reported in the ICMP message by 48 bytes to allow room for the overhead of a Data indication. 

>               <http://www.hpl.hp.com/techreports/Compaq-DEC/

Thanks, Updated.

Cheers,
-Tiru

> 
> 
> _______________________________________________
> tram mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tram

---

From: Suresh Krishnan <[email-masked]>
Date: Thu, 11 Jul 2019 13:39:24 +0000

Hi Tiru,
  Thanks for addressing my comments. Your suggested text changes look good to me except one. The open point inline.

On Jul 11, 2019, at 2:11 AM, Konda, Tirumaleswar Reddy <[email-masked]<mailto:[email-masked]>> wrote:

* Section 13.2 Page 53

This text will not work. It is an ICMPv6 packet that will be sent and not an ICMPv4 packet. Can you reword with ICMPv6 Packet Too Big instead.

Regards
Suresh

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Thu, 11 Jul 2019 15:19:09 +0000

Hi Suresh,

I modified both 13.2 and 13.3 sections. The text I proposed is for 13.3 (IPv6-to-IPv4 Translations). For Section 13.2 (IPv6-to-IPv6 Translations) used the following text:
If the ICMPv6 packet ("Packet too big") is being sent to the peer, the TURN server reduces the MTU reported in the ICMP message by 48 bytes to allow room for the overhead of a Data indication.

Cheers,
-Tiru

From: Suresh Krishnan <[email-masked]>
Sent: Thursday, July 11, 2019 7:09 PM
To: Konda, Tirumaleswar Reddy <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [tram] Suresh Krishnan's No Objection on draft-ietf-tram-turnbis-27: (with COMMENT)

CAUTION: External email. Do not click links or open attachments unless you recognize the sender and know the content is safe.

________________________________
Hi Tiru,
  Thanks for addressing my comments. Your suggested text changes look good to me except one. The open point inline.

* Section 13.2 Page 53

Regards
Suresh