Subject: [rbridge] IPVLX Agenda

From: Erik.Nordmark at sun.com (Erik Nordmark)
Date: Fri Jul 30 15:50:15 2004

Sorry for the lateness - I've been on vacation for the last two weeks.
Agenda comments welcome now or during agenda bashing on Monday.

---

Agenda for IP Virtual Link eXtension BOF (IPVLX)
	Monday 1300-1500 in Harbor I

Welcome Administrivia, and	Erik Nordmark		5 minutes
Agenda Bashing

Problem Statement		Erik Nordmark		15 minutes

Exploring possible solutions to understand
the problem and solution space better with 2 presentations:

Automatic Prefix Assignment	Hilarie Orman		15 minutes

L2 Bridges and		 	Radia Perlman		30 minutes
Rbridges 
<draft-perlman-rbridge-01.txt>

How do the 3 above approaches   Erik Nordmark		10 minutes
match the problem statement?

Discussion off problem		All			30 minutes
statement and how to proceed

Reading list:
Problem statement (included below)
draft-perlman-rbridge-01.txt
draft-williams-ipvlx-ipbridging-01.txt

---

Problem Statement:

Organizations with large local networks may wish to administer
them without the complications of internal IP address assignments.
Layer 2 addresses provide the unique names, but the most common 
layer 2 interconnection method (dynamically created spanning tree
formation using bridges) is not as flexible as layer 3 routing.
The BoF will explore hybrid solutions that retain the simplicity of 
administration while taking full advantage of complex topologies.

Bridges with spanning tree algorithms have obvious disadvantages: routing
is confined to a spanning tree (precluding pair-wise shortest paths),
ARP and Neighbor Discovery packets must be carried across all the links,
the header on which the spanning tree forwards has no hop count,
spanning tree forwarding in the presence of temporary loops spawns
exponential copies of packets, nodes can have only a single point of
attachment, the spanning tree, in order to avoid temporary loops,
is slow to start forwarding on new ports, and it is not possible to take
advantage of the rich physical topology for capacity since the packet flows
are restricted to following the spanning tree.

Routers avoid those disadvantages but have their own problems:
IP addresses are link specific so a host that moves must change 
its IP address, the routers must be configured with unique link prefixes
for each of the attached links, and the block of IP address space can not be
fully utilized because it must be partitioned across the different links.

The BoF will explore combining benefits of bridges and routers in a way 
that will co-exist with existing hosts, IP routers and bridges.  The 
design should support both IPv4 and IPv6.

---

---

From: ftemplin at iprg.nokia.com (Fred Templin)
Date: Fri Jul 30 16:56:11 2004

Hello Erik,

I have a new document with some possible relevance for
ipvlx. Any chance to have this one added to the reading list:

  http://www.geocities.com/osprey67/v6v4inet-01a.txt

Thanks - Fred
[email-masked]

Erik Nordmark wrote:

>_______________________________________________
>rbridge mailing list
>[email-masked]
>http://www.postel.org/mailman/listinfo/rbridge
>  
>

Date: Fri, 30 Jul 2004 16:55:27 -0700
From: Fred Templin <[email-masked]>
To: Erik Nordmark <[email-masked]>, "Developing a hybrid router/bridge." <[email-masked]>
Subject: Re: [rbridge] IPVLX Agenda
Cc: 
Reply-To: "Developing a hybrid router/bridge." <[email-masked]>
Status: RO
Content-Length: 3035

Hello Erik,

I have a new document with some possible relevance for
ipvlx. Any chance to have this one added to the reading list:

  http://www.geocities.com/osprey67/v6v4inet-01a.txt

Thanks - Fred
[email-masked]

Erik Nordmark wrote:

>_______________________________________________
>rbridge mailing list
>[email-masked]
>http://www.postel.org/mailman/listinfo/rbridge
>  
>

Date: Fri, 30 Jul 2004 15:49:18 -0700 (PDT)
From: Erik Nordmark <[email-masked]>
To: [email-masked]
Cc: 
Subject: [rbridge] IPVLX Agenda
Reply-To: Erik Nordmark <[email-masked]>, "Developing a hybrid router/bridge." <[email-masked]>
Status: RO
Content-Length: 2572

---

Reading list:

---

Problem Statement:

---

Date: Tue, 20 Jul 2004 17:41:00 -0700
From: Joe Touch <[email-masked]>
To: "Developing a hybrid router/bridge." <[email-masked]>
Subject: [rbridge] new Internet Draft available - draft-perlman-rbridge-01.txt
Reply-To: "Developing a hybrid router/bridge." <[email-masked]>
Status: RO
Content-Length: 872

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig083D8182C321D7B3DB1D5621
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

Hi, all,

An updated version of the Rbridge ID has been submitted:

This will be discussed at the upcoming IPVLX BOF in San Diego.

Joe

--------------enig083D8182C321D7B3DB1D5621
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

--------------enig083D8182C321D7B3DB1D5621--

Date: Fri, 9 Jul 2004 08:30:06 -0700 (PDT)
From: Erik Nordmark <[email-masked]>
To: [email-masked]
Cc: [email-masked]
Subject: [rbridge] Updated problem statement
Reply-To: Erik Nordmark <[email-masked]>, "Developing a hybrid router/bridge." <[email-masked]>
Status: RO
Content-Length: 1845

Based on some editorial comments from Hilarie Orman I've tweaked the
wording in the problem statement. Hopefully it is more succinct as
a result.

  Erik

---

Date: Thu, 08 Jul 2004 14:15:57 -0700
From: Joe Touch <[email-masked]>
To: "Developing a hybrid router/bridge." <[email-masked]>
Subject: [rbridge] IETF Update - ipvlx BOF scheduled
Reply-To: "Developing a hybrid router/bridge." <[email-masked]>
Status: RO
Content-Length: 192

Hi, all,

FYI, I just noticed that ipvlx (IP Virtual Link eXtension) BOF has been 
scheduled for Monday, Aug 2, 13:00-15:00.

See the Rbridge web pages (www.postel.org/rbridge) for info.

Joe