Subject: [rbridge] IPVLX Agenda

From: anoop.ghanwani at hp.com (Ghanwani, Anoop)
Date: Wed Aug 4 10:14:38 2004

Hi Erik,

Were minutes taken at the BoF?  Are they publicly accessible?

Thanks,
Anoop
--
Anoop Ghanwani | Procurve Networking | 916.785.1760 | [email-masked]

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Erik Nordmark
> Sent: Friday, July 30, 2004 3:49 PM
> To: [email-masked]
> Subject: [rbridge] IPVLX Agenda
> 
> 
> 
> Sorry for the lateness - I've been on vacation for the last two weeks.
> Agenda comments welcome now or during agenda bashing on Monday.
> 
> ---
> 
> Agenda for IP Virtual Link eXtension BOF (IPVLX)
> 	Monday 1300-1500 in Harbor I
> 
> Welcome Administrivia, and	Erik Nordmark		5 minutes
> Agenda Bashing
> 
> Problem Statement		Erik Nordmark		15 minutes
> 
> Exploring possible solutions to understand
> the problem and solution space better with 2 presentations:
> 
> Automatic Prefix Assignment	Hilarie Orman		15 minutes
> 
> L2 Bridges and		 	Radia Perlman		
> 30 minutes
> Rbridges 
> <draft-perlman-rbridge-01.txt>
> 
> How do the 3 above approaches   Erik Nordmark		10 minutes
> match the problem statement?
> 
> Discussion off problem		All			
> 30 minutes
> statement and how to proceed
> 
> 
> Reading list:
> Problem statement (included below)
> draft-perlman-rbridge-01.txt
> draft-williams-ipvlx-ipbridging-01.txt
> 
> ---
> 
> Problem Statement:
> 
> Organizations with large local networks may wish to administer
> them without the complications of internal IP address assignments.
> Layer 2 addresses provide the unique names, but the most common 
> layer 2 interconnection method (dynamically created spanning tree
> formation using bridges) is not as flexible as layer 3 routing.
> The BoF will explore hybrid solutions that retain the simplicity of 
> administration while taking full advantage of complex topologies.
> 
> Bridges with spanning tree algorithms have obvious 
> disadvantages: routing
> is confined to a spanning tree (precluding pair-wise shortest paths),
> ARP and Neighbor Discovery packets must be carried across all 
> the links,
> the header on which the spanning tree forwards has no hop count,
> spanning tree forwarding in the presence of temporary loops spawns
> exponential copies of packets, nodes can have only a single point of
> attachment, the spanning tree, in order to avoid temporary loops,
> is slow to start forwarding on new ports, and it is not 
> possible to take
> advantage of the rich physical topology for capacity since 
> the packet flows
> are restricted to following the spanning tree.
> 
> Routers avoid those disadvantages but have their own problems:
> IP addresses are link specific so a host that moves must change 
> its IP address, the routers must be configured with unique 
> link prefixes
> for each of the attached links, and the block of IP address 
> space can not be
> fully utilized because it must be partitioned across the 
> different links.
> 
> The BoF will explore combining benefits of bridges and 
> routers in a way 
> that will co-exist with existing hosts, IP routers and bridges.  The 
> design should support both IPv4 and IPv6.
> 
> ---
> 
> 
> 
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://www.postel.org/mailman/listinfo/rbridge
>

---

From: Erik.Nordmark at sun.com (Erik Nordmark)
Date: Wed Aug 4 10:18:34 2004

> Were minutes taken at the BoF?  Are they publicly accessible?

I need to merge to sets of minutes together and then I'll send them out to
the list and ask for corrections.

   Erik