Subject: [rbridge] Convergence time

From: rute.sofia at siemens.com (Sofia, Rute)
Date: Tue, 13 Sep 2005 00:21:11 +0200

Guillermo,

Can you please refer to *any* performance study on RSTP that shows convergence times in the order of 10/100 ms?

Best Regards,
Rute Sofia

> -----Original Message-----
> From: rbridge-bounces at postel.org 
> [mailto:rbridge-bounces at postel.org] On Behalf Of Guillermo Ib??ez
> Sent: Monday, September 12, 2005 11:43 PM
> To: Developing a hybrid router/bridge.
> Subject: Re: [rbridge] Convergence time
> 
> I recommend a reading of RSTP (IEEE 802.1D) protocol for 
> mechanisms of 
> fast reconfiguration and spanning tree reconstruction. Although 
> convergence is alleged to extend to several seconds in case of root 
> bridge failure (Myers 2004), tipical times are tenths, hundreds of 
> milliseconds, not easy to achieve with routing protocols.
> I am not familiar with fast rerouting but applying it to 
> build spanning 
> trees may be require a different solution than repairing routes with 
> backup routes.
> Guillermo Ib??ez
> 
> Alia Atlas wrote:
> 
> > I imagine that one could do fast-reroute techniques, 
> depending on the
> > convergence time requirements.  Given SPTs and a link-state 
> protocol 
> > are being used,
> > I believe that the work in rtgwg could apply.
> >
> > Alia
> >
> > On 8/29/05, *Wojtek Paprowicz* <quasarus at gazeta.pl 
> > <mailto:quasarus at gazeta.pl>> wrote:
> >
> >     Hi everybody,
> >
> >     I was wondering if convergence is a case in RBRIDGE idea. Taking
> >     into concideration, that currently RBRIDGEs run ISIS, I think it
> >     should be. How do you think should be the timers set in order to
> >     achieve results similar to SDH? The default timers will 
> not do the
> >     trick. On the other hand, we cannot lower e.g. helloInterval too
> >     much. The timers are also crucial for node/link 
> failures and failure
> >     recovery times. Be grateful for your opinions.
> >
> >     Regards,
> >     Wojtek Paprowicz
> >
> >
> >
> >     _______________________________________________
> >     rbridge mailing list
> >     rbridge at postel.org <mailto:rbridge at postel.org>
> >     http://www.postel.org/mailman/listinfo/rbridge
> >
> >
> >-------------------------------------------------------------
> -----------
> >
> >_______________________________________________
> >rbridge mailing list
> >rbridge at postel.org
> >http://www.postel.org/mailman/listinfo/rbridge
> >  
> >
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge
>

---

From: gibanez at it.uc3m.es (Guillermo Ibáñez)
Date: Tue, 13 Sep 2005 12:54:21 +0200

Rute ,
       10 msec is cited in the standard as a reachable minimum to detect 
link failure (for instance of the bridge root port link).  As the 
alternate port for root port  is preselected, no BPDU interchange across 
the link is needed in this particular case for reconfiguration of the link.
Global Open Ethernet goes beyond this, reaching 2 msec for switchover to 
an alternate link with GOE switches. See:  Global Open Ethernet (GOE) 
System and its Performance Evaluation/ A. Iwata, Y. Hidaka, M. 
Umayabashi, N. Enomoto, and A. Arutaki  (IEEE Journal on Selected Areas 
in Communications) Oct. 2004 ./In this article performance for 
reconfiguration with RSTP switches is reported as 60 msec, but growing 
with increasing network sizes.
Lucent offers RSTP based improved implementations with reconvergence 
under 200 msec. in :  
www.lucent.ru/i/docs/TripplePlay/Spanning-Trees-Whitepaper.doc
Although the upper limit for RSTP seems to be on the several seconds 
range, it seems there is still room for improvement as the vendors 
manifest (Lucent) and implementations show. So, improving RSTP to lower 
upper convergence limit  might be one way to advance, as the capability 
for fast transitions is proven.
Regards
Guillermo
PD. Root bridge failure seems to be the worst case for reconvergence in 
RSTP compared with link failure or new root bridge election.