Subject: [rbridge] Configuration of VLANs vs selfconfiguration

From: Vishwas at sinett.com (Vishwas Manral)
Date: Thu, 22 Sep 2005 20:59:15 -0700

Hi Joe,

May be the question could be, do we intend the use of GVRP for distributing VLAN information even in Rbridge mode? 

I think the GVRP should be allowed else the Rbridge protocol should be extended for a similar purpose.

Thanks,
Vishwas
-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On Behalf Of Joe Touch
Sent: Friday, September 23, 2005 5:40 AM
To: Developing a hybrid router/bridge.
Subject: Re: [rbridge] Configuration of VLANs vs selfconfiguration

Rbridges are supposed to work like bridges:

	- zero configuration for a single LAN
	- as easy (or hard) to configure for VLANs

They are not intended to be zero-config VLAN systems any more than
bridges are.

Joe

Guillermo Ib??ez wrote:
> 
> G. Ib??ez wrote:
> 
> I have a doubt since some time on VLAN configuration. One of the main 
> aspects driving the routing bridges proposal is to be configuration 
> free, like the transparent bridges, opposite to using  routers where IP 
> addresses must be  asigned, administered and may change when the host 
> moves in the network. However, VLAN configuration of bridges is an 
> important aspect and effort, that prevents selfconfiguration of rbridges 
> to be achieved. In the Rbridges draft (see extract below), this problem 
> is skipped assuming the Rbridges are already configured with the 
> information on which VLANs should be supported on which port.
> Although the problem of VLAN configuration is complex to handle, by 
> ignoring it we risk not to fulfill  one of the main requirements of 
> Rbridges: zero configuration.
> Regards
> Guillermo
> 
> Extracted from draft:
> 
> "Support of VLANs does traditionally require configuration 
>    of the bridges (or in this case RBridges) to know which links belong 
>    to which VLANs. In theory some other mechanism might allow an RBridge 
>    to know which VLANs should be supported on which port. The RBridge 
>    design does not care how RBridges discover which VLANs are supported 
>    by each of their ports, but for simplicity we assume here that 
>    RBridges (like bridges) are configured with this information." 
> 
> 
>

---

From: touch at ISI.EDU (Joe Touch)
Date: Fri, 23 Sep 2005 07:23:37 -0700

If there is a way the routing protocol can be leveraged for distributing
VLAN info, or to run multiple VLANs over a single protocol, or to assist
with zero-config VLANs, that should be considered after the basic
rbridge system is defined, IMO.

I.e., these are extensions, not key aspects of the basic architecture,
IMO. The point of the rbridge, IMO, is increased cross-section bandwidth
- not, as many have focused on - issues of scale (either in number of
VLANs or number of nodes) beyond that of existing bridge systems per se.

Joe

Vishwas Manral wrote:
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
Url : http://www.postel.org/pipermail/rbridge/attachments/20050923/bbc9c741/signature.bin