Subject: [rbridge] Configuration of VLANs vs selfconfiguration

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Fri, 23 Sep 2005 11:45:28 -0300

Joe,

	Last I heard, there was nothing preventing the same MAC 
address living in more than one VLAN.  In fact, for routers and
VLAN bridges, wouldn't this be the dominant case?

	If that has not changed, then the suggested approach will
not even work - independent of whether or not its in scope for
what we're trying to do.

--
Eric

====================================================================
While Harald's suggestion is interesting, IMO it would be part of an
rbridge only after it has been developed for bridges first.

This is not an rbridge issue.

Joe

Harald Tveit Alvestrand wrote:
> 
> --On fredag, september 23, 2005 09:38:53 +0200 Guillermo Ib??ez 
> <gibanez at it.uc3m.es> wrote:
> 
> 
>>   IMHO, with this restrictive interpretation of zero configuration we
>>solve only half of the configuration problem.
>>   Anyway, if this is the prevalent opinion, I suggest to add  this
>>clarification  to the draft (zero configuration for single LAN, equal
>>configuration for VLANs as standard bridges).
>>Guillermo
> 
> 
> I think you could in theory get close to zeroconf for VLAN membership.
> It would go something like:
> 
> - Device attaches
> - Bridge broadcasts "who knows this guy" on a reserved "management" VLAN
> - Some management function replies "I do - he's in vlan G"
> - Bridge configures the port to that VLAN
>   (or if no reply - to a "default" VLAN)
> 
> (For extra credits, work in where to add 802.1x authentication)
> 
> The only config on the bridge would be what answers to believe (security 
> makes complete zeroconf impossible, but we all know that by now....)
> 
> But this mechanism would be completely orthogonal to what TRILL is about, 
> of course. So this is not the right list to discuss it.
> 
>                        Harald
> 
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge

--> -----Original Message-----
--> From: rbridge-bounces at postel.org 
--> [mailto:rbridge-bounces at postel.org]On
--> Behalf Of Joe Touch
--> Sent: Friday, September 23, 2005 10:21 AM
--> To: Developing a hybrid router/bridge.
--> Subject: Re: [rbridge] Configuration of VLANs vs selfconfiguration
--> 
--> 
--> _______________________________________________
--> rbridge mailing list
--> rbridge at postel.org
--> http://www.postel.org/mailman/listinfo/rbridge
-->

---

From: touch at ISI.EDU (Joe Touch)
Date: Fri, 23 Sep 2005 08:08:53 -0700

I'm not sure whether being in more than one VLAN breaks this or is
permitted (it seems like it wouldn't be, but I'm not sure).

>>- Some management function replies "I do - he's in vlan G"

That's not zero-config to me; it, like DHCP, just moves the
configuration to a central location.

Joe

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
Url : http://www.postel.org/pipermail/rbridge/attachments/20050923/79acd5ef/signature.bin