Subject: [rbridge] rbridge for ipv6 ?

From: gsankara at cisco.com (Ganesh CS)
Date: Tue, 13 Sep 2005 21:06:02 +0530

Hi all,
Is rbridge for ipv6 under consideration ?

Ganesh

---

From: touch at ISI.EDU (Joe Touch)
Date: Tue, 13 Sep 2005 09:00:57 -0700

Rbridge is an L2 device; at the ingress, it should be capable of peeking
into various packets for optimization like other L2 systems, e.g., for
multicast. This includes IPv4 and IPv6, but these are just optimizations
- if not implemented, it should not affect correct operation.

Joe

Ganesh CS wrote:
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://www.postel.org/mailman/listinfo/rbridge
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 254 bytes
Desc: OpenPGP digital signature
Url : http://www.postel.org/pipermail/rbridge/attachments/20050913/aff8d77c/signature.bin

---

From: healthinghearts at huawei.com (Yang Yang)
Date: Wed, 14 Sep 2005 00:35:45 +0800

Hi,
   Rbridge forwards frames based on L2 address in data plane. But it uses
routing protocols which may operate at L3 in control plane. If L3 address is
used, is Rbridge a L2 device? And I think IPv4 and IPv6 should both be
supported.
   Still now, I am not sure whether the routing protocol can use MAC address
via adding a new TLV in IS-IS.

   Best Regards!
    Yang Yang

-----Original Message-----
From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Joe Touch
Sent: Wednesday, September 14, 2005 12:01 AM
To: Developing a hybrid router/bridge.
Subject: Re: [rbridge] rbridge for ipv6 ?

Joe

---

From: pekkas at netcore.fi (Pekka Savola)
Date: Tue, 13 Sep 2005 19:49:45 +0300 (EEST)

> - if not implemented, it should not affect correct operation.

(This should be obvious, but I'll state it explicitly in any case), it 
should still work if some parts of the site implement v4/v6 optimizing 
rbridges, some can only optimize for v4, others only for v6, and yet 
another set not at all.

Maybe that requires each rbridge adversiting its optimizing 
capabilities in IS-IS or something, which may or may not be trivial.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: touch at ISI.EDU (Joe Touch)
Date: Tue, 13 Sep 2005 09:53:51 -0700

Yang Yang wrote:
> routing protocols which may operate at L3 in control plane.

That's exclusively interior to the rbridge; they don't depend on
examining L3 coming in.

> If L3 address is
> used, is Rbridge a L2 device? 

See above - the L3 portion is only internal to the rbridge campus. I.e.,
imagine bridges that communicate a custom tree configuration using a
private protoco.

> And I think IPv4 and IPv6 should both be
> supported.

I'll let others address that...

Joe

---

From: touch at ISI.EDU (Joe Touch)
Date: Tue, 13 Sep 2005 10:18:59 -0700

> rbridges, some can only optimize for v4, others only for v6, and yet 

Agreed. Also, how much the optimization helps may depend on how
widespread support for the optimization is.

> capabilities in IS-IS or something, which may or may not be trivial.

We can have everyone participate in supporting multiple routing 'trees'
(they're not trees anymore, but you get the idea), where only egresses
that support v4 or v4 peek will be able to utilize. I don't think this
requires advertizing the capabilities per se, but it will probably
require the use of separate forwarding tables. those that support such
will use them; others will support only a single merged table as well.

Joe

---

From: dengyiou at huawei.com (Yiou Deng)
Date: Wed, 14 Sep 2005 13:22:57 +0800

����Hello!!
����Rbridge network is just like a L2VPN network formed by IP or MPLS,
the only use of routing protocols in Rbridge is to ensure the
connectivity of Rbridge network internally. 
����
����Maybe we can talk face to face at Kuike building if any doubts still
there :-)
����
����Yiou
����-----�ʼ�ԭ��-----
������: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org]
���� Yang Yang
����ʱ��: 2005��9��14�� 0:36
�ռ���: 'Developing a hybrid router/bridge.'
����: Re: [rbridge] rbridge for ipv6 ?
����
����Hi,
����   Rbridge forwards frames based on L2 address in data plane. But it
uses
����routing protocols which may operate at L3 in control plane. If L3
address is
����used, is Rbridge a L2 device? And I think IPv4 and IPv6 should both
be
����supported.
����   Still now, I am not sure whether the routing protocol can use MAC
address
����via adding a new TLV in IS-IS.
����
����   Best Regards!
����    Yang Yang
����
����-----Original Message-----
����From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org]
On
����Behalf Of Joe Touch
����Sent: Wednesday, September 14, 2005 12:01 AM
����To: Developing a hybrid router/bridge.
����Subject: Re: [rbridge] rbridge for ipv6 ?
����
����Rbridge is an L2 device; at the ingress, it should be capable of
peeking
����into various packets for optimization like other L2 systems, e.g.,
for
����multicast. This includes IPv4 and IPv6, but these are just
optimizations
����- if not implemented, it should not affect correct operation.
����
����Joe
����
����Ganesh CS wrote:
����> Hi all,
����> Is rbridge for ipv6 under consideration ?
����> 
����> Ganesh
����> _______________________________________________
����> rbridge mailing list
����> rbridge at postel.org
����> http://www.postel.org/mailman/listinfo/rbridge
����
����
����_______________________________________________
����rbridge mailing list
����rbridge at postel.org
����http://www.postel.org/mailman/listinfo/rbridge

---

From: gsankara at cisco.com (Ganesh CS)
Date: Wed, 14 Sep 2005 20:14:42 +0530

Hi Yiou,
Do you mean that still routing protocols other than IS-IS routing are
required just for rbrige reachability ?

regs
Ganesh

Yiou Deng wrote:

>------------------------------------------------------------------------
>

---

From: dengyiou at huawei.com (Yiou Deng)
Date: Mon, 19 Sep 2005 12:03:26 +0800

����Hi Ganesh,
����I mean that ANY of the routing protocols can be used for rbridge
reachability. I'm new for this mailing list and know little about why
ISIS is preferred for rbridge. Will anyone be kind enough to explain
this for me? Thanks in advance.
����
����Regards,
����Yiou
����-----�ʼ�ԭ��-----
������: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org]
���� Ganesh CS
����ʱ��: 2005��9��14�� 22:45
�ռ���: Developing a hybrid router/bridge.
����: Re: [rbridge] ????: rbridge for ipv6 ?
����
����Hi Yiou,
����Do you mean that still routing protocols other than IS-IS routing
are
����required just for rbrige reachability ?
����
����regs
����Ganesh
����
����Yiou Deng wrote:
����
����>����Hello!!
����>����Rbridge network is just like a L2VPN network formed by IP or
MPLS,
����>the only use of routing protocols in Rbridge is to ensure the
����>connectivity of Rbridge network internally. 
����>����
����>����Maybe we can talk face to face at Kuike building if any doubts
still
����>there :-)
����>����
����>����Yiou
����>����-----�ʼ�ԭ��-----
����>������: rbridge-bounces at postel.org
[mailto:rbridge-bounces at postel.org]
����>���� Yang Yang
����>����ʱ��: 2005��9��14�� 0:36
����>�ռ���: 'Developing a hybrid router/bridge.'
����>����: Re: [rbridge] rbridge for ipv6 ?
����>����
����>����Hi,
����>����   Rbridge forwards frames based on L2 address in data plane.
But it
����>uses
����>����routing protocols which may operate at L3 in control plane. If
L3
����>address is
����>����used, is Rbridge a L2 device? And I think IPv4 and IPv6 should
both
����>be
����>����supported.
����>����   Still now, I am not sure whether the routing protocol can
use MAC
����>address
����>����via adding a new TLV in IS-IS.
����>����
����>����   Best Regards!
����>����    Yang Yang
����>����
����>����-----Original Message-----
����>����From: rbridge-bounces at postel.org
[mailto:rbridge-bounces at postel.org]
����>On
����>����Behalf Of Joe Touch
����>����Sent: Wednesday, September 14, 2005 12:01 AM
����>����To: Developing a hybrid router/bridge.
����>����Subject: Re: [rbridge] rbridge for ipv6 ?
����>����
����>����Rbridge is an L2 device; at the ingress, it should be capable
of
����>peeking
����>����into various packets for optimization like other L2 systems, e.
g.,
����>for
����>����multicast. This includes IPv4 and IPv6, but these are just
����>optimizations
����>����- if not implemented, it should not affect correct operation.
����>����
����>����Joe
����>����
����>����Ganesh CS wrote:
����>����> Hi all,
����>����> Is rbridge for ipv6 under consideration ?
����>����> 
����>����> Ganesh
����>����> _______________________________________________
����>����> rbridge mailing list
����>����> rbridge at postel.org
����>����> http://www.postel.org/mailman/listinfo/rbridge
����>����
����>����
����>����_______________________________________________
����>����rbridge mailing list
����>����rbridge at postel.org
����>����http://www.postel.org/mailman/listinfo/rbridge
����>
����>  
����>
����
����>
����>_______________________________________________
����>rbridge mailing list
����>rbridge at postel.org
����>http://www.postel.org/mailman/listinfo/rbridge
����>  
����>

---

From: gsankara at cisco.com (Ganesh CS)
Date: Mon, 19 Sep 2005 20:27:35 +0530

Hi Yiou,
Per my understanding, within rbridge domain we should not be requiring a
separate routing protocol other than rbridge's own routing protocol for
rbridge reachability. However to advertise internal routes to outside of
the rbridge domain we may require a routing protocol.

Anyone on the list can correct me if I am wrong.

regs
Ganesh

Yiou Deng wrote:

>>-----------------------------------------------------------------------
>>    
>>
>-
>����>

---

From: touch at ISI.EDU (Joe Touch)
Date: Mon, 19 Sep 2005 10:36:56 -0700

> the rbridge domain we may require a routing protocol.

We would, if we ever intended to advertise internal routes outside. This
is the opposite of the goal of an rbridge, which is to completely
encapsulate this state internally.

When considering what an rbridge campus (which is what we call it) does,
consider the acid test: what would a single bridge do?

Bridges might export, e.g., some info about which interfaces reach
others in the way it participates in a spanning tree (directly or
indirectly; I'm not a spanning tree protocol guru). But which path is
taken internally is not exported there, nor would it be for an rbridge
campus.

Joe