Subject: [rbridge] TTL only - was RE: New fields in shim header?

From: sgai at nuovasystems.com (Silvano Gai)
Date: Mon, 16 Oct 2006 14:20:49 -0700

Joe,

.....

> 
> The enclosed source MAC indicates the source rbridge at the time it
was
> encapsulated; 

Not true if the source MAC was spoofed by a host connected to another
RBridge. Do you agree?

> the appropriate source rbridge for that packet may change
> by the time the packet arrives elsewhere in the rbridge campus.

If you put the source RBridge address in the frame, why should it
change?

-- Silvano

> That's
> another reason it's not useful to know the source - it is ephemeral
> anyway.
> 
> Joe

---

From: touch at ISI.EDU (Joe Touch)
Date: Mon, 16 Oct 2006 16:49:00 -0700

> Not true if the source MAC was spoofed by a host connected to another

True for all spoofing of MACs. That's not addressed by rbridges at all.

> If you put the source RBridge address in the frame, why should it

What might change is what the subsequent hops thinks the source _should_
be. The address in the packet wouldn't change, but would be useless in
that case.

Joe

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 250 bytes
Desc: OpenPGP digital signature
Url : http://mailman.postel.org/pipermail/rbridge/attachments/20061016/c6d30fdb/signature.bin