Subject: [rbridge] TTL only - was RE: New fields in shim header?

From: sgai at nuovasystems.com (Silvano Gai)
Date: Mon, 16 Oct 2006 21:35:17 -0700

Joe,

> -----Original Message-----
> From: Joe Touch [mailto:touch at ISI.EDU]
> Sent: Monday, October 16, 2006 4:49 PM
> To: Silvano Gai
> Cc: Caitlin Bestler; Gray, Eric; rbridge at postel.org; Radia Perlman
> Subject: Re: [rbridge] TTL only - was RE: New fields in shim header?
> 
> 
> 
> Silvano Gai wrote:
> > Joe,
> >
> > .....
> >
> >> The enclosed source MAC indicates the source rbridge at the time it
> > was
> >> encapsulated;
> >
> > Not true if the source MAC was spoofed by a host connected to
another
> > RBridge. Do you agree?
> 
> True for all spoofing of MACs. That's not addressed by rbridges at
all.
> 
> >> the appropriate source rbridge for that packet may change
> >> by the time the packet arrives elsewhere in the rbridge campus.
> >
> > If you put the source RBridge address in the frame, why should it
> > change?
> 
> What might change is what the subsequent hops thinks the source
_should_
> be. The address in the packet wouldn't change, but would be useless in
> that case.
> 

It will tell me with certainty where the frame entered the RBridge
network (which RBridge did the encapsulation), which for me is
important, not useless.

-- Silvano

---

From: touch at ISI.EDU (Joe Touch)
Date: Tue, 17 Oct 2006 07:28:35 -0700

> network (which RBridge did the encapsulation), which for me is

While any sort of record-path info would be useful for debugging, what
does this tell you for rbridge?

Again, we're inside the LAN already. You don't know which bridge packets
come through either. Why do you need to know the rbridge ingress?

Joe

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 250 bytes
Desc: OpenPGP digital signature
Url : http://mailman.postel.org/pipermail/rbridge/attachments/20061017/d744a26d/signature-0001.bin