Subject: [rbridge] TTL only - was RE: New fields in shim header?

From: sgai at nuovasystems.com (Silvano Gai)
Date: Thu, 12 Oct 2006 13:16:44 -0700

Caitlin,

See below

...

> 
> And as we all know the probability of MsgSize having been
> crafted so the MsgSize % n is zero is all too high. So the
> more we add to the header, the more IP datagrams will be
> required to send the same traffic. 

I had the impression that TRILL was increasing the frame size on the
encapsulated size, not MTU reduction at the IP level. The fact that we
add few bytes more or less impacts performance, but not number of IP
datagram.

-- Silvano

That's not only more
> bandwidth, but a reduced probability of the entire message
> arriving on first try, deeper queues in all the forwarding
> elements, etc.
> 
> Using the larger header needs a solid justification, not
> just a presumption that bandwidth is cheap.
> 
> I am assuming there is no desire to replicate IPSEC funcationality
> at L2 then *all* of the L2 headers may be forged. I don't see how
> you can claim that any specific one is more trustworthy than
> the others.
> 
>

---

From: touch at ISI.EDU (Joe Touch)
Date: Thu, 12 Oct 2006 13:23:34 -0700

Silvano Gai wrote:
> encapsulated size, 

That'd be nice, but it's not possible; we need to run over existing
802.1D equipment as transit inside the rbridge. See sec 3.2 of
draft-ietf-trill-prob-00.txt

Joe

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 250 bytes
Desc: OpenPGP digital signature
Url : http://mailman.postel.org/pipermail/rbridge/attachments/20061012/84fb3631/signature.bin