Subject: [rbridge] Ingress Rbridge address and BCN

From: sgai at nuovasystems.com (Silvano Gai)
Date: Fri, 27 Oct 2006 08:00:28 -0700

If the congestion is detected in the core of the TRILL network, how do
you signal back to the source host if you don't know which is the
ingresss RBridge? 

You cannot look-up the inner MAC address, because in the core of the
network you don't keep the inner MAC addresses in the table. Correct?

This is a clear reason while you need the ingress RBridge address.

-- Silvano

> -----Original Message-----
> From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org]
On
> Behalf Of Radia.Perlman at sun.com
> Sent: Thursday, October 26, 2006 5:02 PM
> To: Wadekar, Manoj K
> Cc: rbridge at postel.org
> Subject: Re: [rbridge] Ingress Rbridge address and BCN
> 
> Hi Manoj,
> 
> I'm confused about BCN. Wouldn't congestion notification need to go to
the
> original endnode source,
> and not the ingress RBridge?
> 
> Radia
>

---

From: caitlinb at broadcom.com (Caitlin Bestler)
Date: Fri, 27 Oct 2006 08:44:30 -0700

rbridge-bounces at postel.org wrote:
> If the congestion is detected in the core of the TRILL
> network, how do you signal back to the source host if you
> don't know which is the ingresss RBridge?
> 
> You cannot look-up the inner MAC address, because in the core
> of the network you don't keep the inner MAC addresses in the table.
> Correct? 
> 

What harm would there be in sending the BCN RBridge encapsulated
with the source-rbridge being the congesting detecting bridge?

Obviously it generates more traffic, but I'm not convinced that
congestion detection by a "core rbridge" that does not already
know of the source will be a common occurrence. The benefits of
adding rbridge functionality are far stronger for the ingress
and egress rbridges.