Subject: [rbridge] Use of 802.1ah Encaps

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Tue, 12 Dec 2006 16:29:19 -0500

Silvano,

	IFF we were going to use 802.1ah, it could allow us to  
use the "back-bone" DA/SA for next-hop/previous-hop and the
"customer" DA/SA for egress/ingress RBridges.  But that would 
be using it in a way that is not consistent with the intended
use of 802.1ah - simply because that usage would make use of 
the fields in a way that matches the way that your proposed 
"short-hand" SHIM header would use them.

	If you did that, there would be room for using the B-tag
and I-tag as analogues of your I-VLAN and O-VLAN tags.

	I think this is a VERY BAD idea.

--
Eric

> -----Original Message-----
> From: Silvano Gai [mailto:sgai at nuovasystems.com] 
> Sent: Friday, December 08, 2006 10:07 AM
> To: Ali Sajassi (sajassi); Don Fedyk; Gray, Eric
> Cc: Developing a hybrid router/bridge.; Joe Touch
> Subject: RE: [rbridge] Use of 802.1ah Encaps
> 
> Ali,
> 
> Inline:
> 
> > -----Original Message-----
> > From: Ali Sajassi (sajassi) [mailto:sajassi at cisco.com]
> > Sent: Thursday, December 07, 2006 9:23 PM
> > To: Silvano Gai; Don Fedyk; Gray, Eric
> > Cc: Developing a hybrid router/bridge.; Joe Touch
> > Subject: RE: [rbridge] Use of 802.1ah Encaps
> > 
> > 
> > Silvano,
> > 
> > > -----Original Message-----
> > > From: Silvano Gai [mailto:sgai at nuovasystems.com]
> > > Sent: Thursday, December 07, 2006 5:36 PM
> > > To: Don Fedyk; Gray, Eric; Ali Sajassi (sajassi)
> > > Cc: Developing a hybrid router/bridge.; Joe Touch
> > > Subject: RE: [rbridge] Use of 802.1ah Encaps
> > >
> > >
> > > IMO it is technically possible for TRILL to adopt IEEE 802.1ah.
> > > There are advantages and disadvantages.
> > >
> > > The disadvantages are:
> > > 1) Lack of Next-Hop addresses. We discussed this at length
> > > during the last meeting and we didn't reach consensus on a
> > > way to eliminate them.
> > 
> > Can you refresh my memory for why we need a next-hop 
> address when the
> > header carries both source and destination PE addresses and 
> when these
> > addresses are learned in control plane ?
> > 
> 
> Radia did in her reply
> 
> > > 2) Lack of a TTL field (it may be added, but it is not 
> there today).
> > 
> > Can probably be accommodated.
> > 
> > > 3) Many unneeded fields and therefore larger frame overhead.
> > >
> > 
> > Such as ?
> 
> The I-tag is not useful in TRILL and in contrast two addresses and the
> TTL are missing.
> 
> > 
> > > The advantages are:
> > > 1) Larger addressable market for TRILL
> > >
> > > IMO if we stick with the WG charter the disadvantages clearly
> > > outweigh the advantages.
> > >
> > > The WG can be re-chartered, but if we consider the Enterprise
> > > and Data Center market, IEEE 802.1ah is an overkill.
> > >
> > 
> > If by overkill you mean a bit bigger header, then I agree 
> but look at
> > all the other advantages that you get from using standard 
> IEEE header
> > and shim including:
> > 	- security Mgmt:  MACSec/KeySec
> > 	- Congestion Mgmt
> > 	- Connectivity Fault Mgmt
> > 
> > Has it been considered how these are going to work with TRILL shim
> > header or are these outside of WG charter :-)
> > 
> > -Ali
> > 
> > 
> > > -- Silvano
> > >
> > >
> > > > -----Original Message-----
> > > > From: rbridge-bounces at postel.org
> [mailto:rbridge-bounces at postel.org]
> > > On
> > > > Behalf Of Don Fedyk
> > > > Sent: Thursday, December 07, 2006 9:21 AM
> > > > To: Gray, Eric; Ali Sajassi (sajassi)
> > > > Cc: Developing a hybrid router/bridge.; Joe Touch
> > > > Subject: Re: [rbridge] Use of 802.1ah Encaps
> > > >
> > > > Hi Eric
> > > >
> > > > > -----Original Message-----
> > > > > From: Gray, Eric [mailto:Eric.Gray at marconi.com]
> > > > >
> > > > > Don,
> > > > >
> > > > > 	And yet, someone (Ali Sajassi) asserted (in his message
> > > dated Wed
> > > > > 12/6/2006 at 2:16 PM EST) that there were no issues or
> additional
> > > > > complications with using 802.1ah in enterprises for
> plug-and-play
> > > > > applicability.
> > > > >
> > > > > 	Perhaps Ali can answer my question then.
> > > > >
> > > > > 	But, to more directly address your earlier comments:
> > > > >
> > > > > 	The TRILL WG has NOT come up with an encapsulation that
> "looks
> > > > > like" 802.1ah - unless someone squints really hard 
> and tries to
> > > > > pretend that two separate Ethernet encapsulations -
> > > separated by a
> > > > > SHIM header - are one single encapsulation.
> > > >
> > > > To be fair Point to Point header that was discussed without
> > > one of the
> > > > shims was very close "functionally" (colloquial looks like) to
> > > 802.1ah.
> > > > My opinion is still we don't need several variations of
> > > headers doing
> > > > similar things.
> > > >
> > > > This was the slide that looked a lot like what I posted.
> > > >
> > > > http://www3.ietf.org/proceedings/06nov/slides/trill-1/sld13.htm
> > > >
> > > > Regards,
> > > > Don
> > > > >
> > > > > 	That is not to say that the WG has done anything that
> > > could be said
> > > > > to disallow the use of 802.1ah encapsulation.
> > > > > It is just not obviously consistent with all of the WG
> > > goals to use
> > > > > _only_ 802.1ah encapsulation.
> > > > >
> > > > > --
> > > > > Eric
> > > > >
> > > >
> > > > _______________________________________________
> > > > rbridge mailing list
> > > > rbridge at postel.org
> > > > http://mailman.postel.org/mailman/listinfo/rbridge
> > >
>

---

From: dwfedyk at nortel.com (Don Fedyk)
Date: Wed, 13 Dec 2006 12:18:08 -0500

Hi Eric

This argument says if you use ANY standard header then it would be a bad
idea.

So you are creating a new forwarding paradigm and the down side of that
as Ali pointed out is now you have to create most of the other things
that go along with new forwarding paradigm.  

Don  

> Sent: Tuesday, December 12, 2006 4:29 PM
> 
> Silvano,
> 
<snip>