Subject: [rbridge] Use of 802.1ah Encaps

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Wed, 13 Dec 2006 12:29:10 -0500

Don,

	I don't follow your reasoning.

	I certainly am not saying that using "ANY standard header"
is a bad idea.

	As for "creating a new forwarding paradigm" - yes, we're
doing a little bit of that.  Ideally, we'll be doing as little
of that as we can get away with.  The "little bit" we have to
do is to use some additional header information to:

	1) forward frames on the shortest path between RBridges,
	   and
	2) reduce or eliminate potential looping of frames during
	   a perturbation of the shortest path.

This may be somewhat of a simplification, but that's fair in 
light of the general trend for casual observers to do the
opposite.

	Currently, we define a SHIM to carry this information and 
we expect to use one or more "standard headers" to encapsulate
frames being forwarded between RBridges.

	Does this make things clearer?

--
Eric

> -----Original Message-----
> From: Don Fedyk [mailto:dwfedyk at nortel.com] 
> Sent: Wednesday, December 13, 2006 12:18 PM
> To: Gray, Eric; Silvano Gai
> Cc: Developing a hybrid router/bridge.; Joe Touch; Ali 
> Sajassi (sajassi)
> Subject: RE: [rbridge] Use of 802.1ah Encaps
> 
> Hi Eric
> 
> This argument says if you use ANY standard header then it would be a bad
> idea.
> 
> So you are creating a new forwarding paradigm and the down side of that
> as Ali pointed out is now you have to create most of the other things
> that go along with new forwarding paradigm.  
> 
> Don  
> 
> > -----Original Message-----
> > From: Gray, Eric [mailto:Eric.Gray at marconi.com] 
> > Sent: Tuesday, December 12, 2006 4:29 PM
> > 
> > Silvano,
> > 
> > 	IFF we were going to use 802.1ah, it could allow us to  
> > use the "back-bone" DA/SA for next-hop/previous-hop and the
> > "customer" DA/SA for egress/ingress RBridges.  But that would 
> > be using it in a way that is not consistent with the intended
> > use of 802.1ah - simply because that usage would make use of 
> > the fields in a way that matches the way that your proposed 
> > "short-hand" SHIM header would use them.
> > 
> > 	If you did that, there would be room for using the B-tag
> > and I-tag as analogues of your I-VLAN and O-VLAN tags.
> > 
> > 	I think this is a VERY BAD idea.
> > 
> > --
> > Eric
> <snip>
>

---

From: dwfedyk at nortel.com (Don Fedyk)
Date: Wed, 13 Dec 2006 13:19:23 -0500

Hi Eric 

> 	I don't follow your reasoning.
That's OK I cant follow you sometimes either ;-)

> 	I certainly am not saying that using "ANY standard header"
Then why not start from ah?  The bit that Silvano said was we could use
ah and you said it is a bad idea.  

Please describe "BAD idea" then. 

> 	   a perturbation of the shortest path.

You have so far chosen to do this in a mode that optimizes for mixed
bridges at the cost of ignoring the effciencies you could get between
directly connected Rbridges. 802.1ah opimizes forwarding for connected
Provider Backbone Bridges and interworks with legacy at a common
denominator.  

> 	Does this make things clearer?

Eric I understand what is proposed but I still question if a greater
synergy cannot be achieved between encapsulating headers.  A shim is a
not a typical solution but encapsulations are.

Regards,
Don