Subject: [rbridge] Use of 802.1ah Encaps

From: Eric.Gray at marconi.com (Gray, Eric)
Date: Thu, 7 Dec 2006 11:00:36 -0500

Don,

	And yet, someone (Ali Sajassi) asserted (in his message
dated Wed 12/6/2006 at 2:16 PM EST) that there were no issues  
or additional complications with using 802.1ah in enterprises
for plug-and-play applicability.

	Perhaps Ali can answer my question then.

	But, to more directly address your earlier comments:

	The TRILL WG has NOT come up with an encapsulation that 
"looks like" 802.1ah - unless someone squints really hard and 
tries to pretend that two separate Ethernet encapsulations - 
separated by a SHIM header - are one single encapsulation.

	That is not to say that the WG has done anything that 
could be said to disallow the use of 802.1ah encapsulation.
It is just not obviously consistent with all of the WG goals
to use _only_ 802.1ah encapsulation.

--
Eric

> -----Original Message-----
> From: Don Fedyk [mailto:dwfedyk at nortel.com] 
> Sent: Thursday, December 07, 2006 9:33 AM
> To: Gray, Eric; Joe Touch; Ali Sajassi (sajassi)
> Cc: Developing a hybrid router/bridge.
> Subject: RE: [rbridge] Use of 802.1ah Encaps
> 
> Hi Eric
> 
> > -----Original Message-----
> > From: Gray, Eric [mailto:Eric.Gray at marconi.com] 
> > Sent: Thursday, December 07, 2006 8:38 AM
> > Don,
> > 
> > 	Thanks for doing this.  As you can probably attest, 
> > this is a non-trivial "digging" task to come up with this 
> > level of detail.  I am not sure why Joe asked for it, but now 
> > that you have provided it, perhaps you can explain how values 
> > would be derived for the B-TAG TCI/VID and I-TAG TCI/SID 
> > fields if we'd like to deploy this technology in 
> "plug-and-play" mode?
> 
> I have not given much thought to plug-and-play. My advice 
> would be learn
> the current semantics of the fields and see what they offer.  I don't
> see why these fields, which offer encapsulation, backwards
> compatibility, Connectivity Fault Management (CFM) frames etc are any
> worse than similar alternatives.
> 
> Don
> 
> > 
> > --
> > Eric
> > 
> ><snipped hopelessly garbled> 
>

---

From: dwfedyk at nortel.com (Don Fedyk)
Date: Thu, 7 Dec 2006 12:20:52 -0500

Hi Eric 

> separated by a SHIM header - are one single encapsulation.

To be fair Point to Point header that was discussed without one of the
shims was very close "functionally" (colloquial looks like) to 802.1ah.
My opinion is still we don't need several variations of headers doing
similar things. 

This was the slide that looked a lot like what I posted.  

http://www3.ietf.org/proceedings/06nov/slides/trill-1/sld13.htm

Regards,
Don