Subject: [rbridge] RSTP BRIDGE not receiving BPDUs

From: Amit.Gupta at calix.com (Amit Gupta)
Date: Thu, 23 Aug 2007 17:05:42 -0700

What would be the state of a port if you stop receiving the RSTP BPDU's
on that bridge port.

If 2 bridges are interconnected and of the 2 ports only 1 port on each
bridge is receiving BPDU's , will that cause any issues ?

Thanks,

-A

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.postel.org/pipermail/rbridge/attachments/20070823/d8675dd4/attachment.html

---

From: Amit.Gupta at calix.com (Amit Gupta)
Date: Thu, 23 Aug 2007 17:21:16 -0700

It is a very basic question. What would be the state and role of a port
if you stop receiving the RSTP BPDU's on that bridge port.

Thanks,

-A

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.postel.org/pipermail/rbridge/attachments/20070823/39c757f9/attachment.html

---

From: Donald.Eastlake at motorola.com (Eastlake III Donald-LDE008)
Date: Thu, 23 Aug 2007 21:28:16 -0400

Well, I'm sure there are people on this list who could help you but this
is really not the 802.1 mailing list, which would seem more appropriate.
 
It is a generally characteristic of STP protocols that the loss of
frames leads to ports becoming enabled. So, while I am not an RSTP
expert, I would guess that in the normal case the port not receiving
BPDUs would end up in Forwarding state and would believe itself to be
root unless their is a better root visible out some other port...
 
But I could be wrong and maybe I am misunderstanding you.... I am
assuming you mean "2 bridges are interconnected and of the 2 ports only
1 port on *one* bridge is receiving BPDU's" but in your statement in the
message below, you say "each" rather than "one" which seems
inconsistent.
 
On wonders what is blocking the BPDUs and why the one hop physical link
between the bridges is letting BPDUs through in only on direction and
not the other...
 
Donald

________________________________

From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On
Behalf Of Amit Gupta
Sent: Thursday, August 23, 2007 8:21 PM
To: rbridge at postel.org
Subject: Re: [rbridge] RSTP BRIDGE not receiving BPDUs

Thanks,

-A

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.postel.org/pipermail/rbridge/attachments/20070823/947e5f4e/attachment.html

---

From: Amit.Gupta at calix.com (Amit Gupta)
Date: Thu, 23 Aug 2007 20:28:16 -0700

The scenario here is that the2 bridges are connected in a ring topology with eaps providing the ring protection while RSTP is providing the uplink/downlink protection. The reason the other port is not receiving the BPDU is because the EAPS is blocking one of the links to avoid loops in the ring.Thus even though the each bridge has 2 paths 2 reach the other but at any given time will only be able to receive BPDU from the path that is not blocked by EAPS. so thats why I was wondering what state/role would be the port that is not receiving the BPDU. 
Will it keep sending the Hello BPDU even though it is not receiving any ?

From: Eastlake III Donald-LDE008 [mailto:Donald.Eastlake at motorola.com]
Sent: Thu 8/23/2007 6:28 PM
To: Amit Gupta
Cc: rbridge at postel.org
Subject: RE: [rbridge] RSTP BRIDGE not receiving BPDUs

Well, I'm sure there are people on this list who could help you but this is really not the 802.1 mailing list, which would seem more appropriate.
 
It is a generally characteristic of STP protocols that the loss of frames leads to ports becoming enabled. So, while I am not an RSTP expert, I would guess that in the normal case the port not receiving BPDUs would end up in Forwarding state and would believe itself to be root unless their is a better root visible out some other port...
 
But I could be wrong and maybe I am misunderstanding you.... I am assuming you mean "2 bridges are interconnected and of the 2 ports only 1 port on *one* bridge is receiving BPDU's" but in your statement in the message below, you say "each" rather than "one" which seems inconsistent.
 
On wonders what is blocking the BPDUs and why the one hop physical link between the bridges is letting BPDUs through in only on direction and not the other...
 
Donald

From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org] On Behalf Of Amit Gupta
Sent: Thursday, August 23, 2007 8:21 PM
To: rbridge at postel.org
Subject: Re: [rbridge] RSTP BRIDGE not receiving BPDUs

It is a very basic question. What would be the state and role of a port if you stop receiving the RSTP BPDU's on that bridge port.

If 2 bridges are interconnected and of the 2 ports only 1 port on each bridge is receiving BPDU's , will that cause any issues ?

Thanks,

-A

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mailman.postel.org/pipermail/rbridge/attachments/20070823/4c015dde/attachment.html