Subject: [rbridge] Consensus Check: Announcing Root

From: Radia.Perlman at sun.com ([email-masked])
Date: Sun, 07 Oct 2007 20:38:14 -0700

Good point. There might be no bridges. So there has to be a way of encoding that. Anything such as:
a) leaving out the TLV in which one announces the root bridge
b) using a flag to say "no root"
c) using a special address, say 0
or I'm sure there are lots of possibilities.

Radia

----- Original Message -----
From: Eastlake III Donald-LDE008 <Donald.Eastlake at motorola.com>
Date: Saturday, October 6, 2007 12:46 pm
Subject: [rbridge] Consensus Check: Announcing Root

> This is a check via the mailing list on a slight modification of an
> apparent consensus from the minutes of the Chicago meeting for a 
> changefrom protocol draft -05. The tentative consensus at the 
> Chicago meeting
> was:
> 
>   It is mandatory for an RBridge to announce the bridge root that
>   it sees out each physical port.
> 
> Based on mailing list discussion, I would like to tweak this as 
> follows:
>   An Rbridge MUST parse BPDUs it receives on a port and announce
>   in the core IS-IS instance the bridge root that it sees out
>   each port. For MSTP (Multiple Spanning Tree Protocol), this is
>   the CIST (Common and Internal Spanning Tree) root.
> 
> I have a question in connection with this. What is announced for the
> port if no BPDU has been received recently or ever? Should there be a
> "root MAC address valid" flag per port or should there some 
> conventionalvalue, like zero, which is announced?
> 
> Thanks,
> Donald
> 
> _______________________________________________
> rbridge mailing list
> rbridge at postel.org
> http://mailman.postel.org/mailman/listinfo/rbridge
>

---

From: anoop at brocade.com (Anoop Ghanwani)
Date: Mon, 8 Oct 2007 07:55:36 -0700

I would prefer (a) or (b) since 0 is technically
a valid address.  (b) seems best since it's explicit.

Anoop 

> -----Original Message-----
> From: rbridge-bounces at postel.org 
> [mailto:rbridge-bounces at postel.org] On Behalf Of Radia.Perlman at sun.com
> Sent: Sunday, October 07, 2007 8:38 PM
> To: Eastlake III Donald-LDE008
> Cc: Rbridge at postel.org
> Subject: Re: [rbridge] Consensus Check: Announcing Root
> 
> > changefrom protocol draft -05. The tentative consensus at 
> the Chicago 
> > meeting
> > was:
> >

---

From: Donald.Eastlake at motorola.com (Eastlake III Donald-LDE008)
Date: Fri, 12 Oct 2007 15:20:38 -0400

I'm fine with option (b) but it seems implausible that all 0's could
ever be a normal MAC address. Among other things, the 00-00-00 OUI is
reserved for expressing arbitrary EtherTypes in the SNAP SAP format...

Donald

-----Original Message-----
From: Anoop Ghanwani [mailto:anoop at brocade.com] 
Sent: Monday, October 08, 2007 10:56 AM
To: Radia.Perlman at sun.com; Eastlake III Donald-LDE008
Cc: Rbridge at postel.org
Subject: RE: [rbridge] Consensus Check: Announcing Root

Anoop

---

From: sgai at nuovasystems.com (Silvano Gai)
Date: Fri, 12 Oct 2007 13:27:16 -0700

I think the reserved value apply only to the OUI inside the SNAP, not
the one in the MAC address.

-- Silvano

> From: rbridge-bounces at postel.org [mailto:rbridge-bounces at postel.org]
On
> Behalf Of Eastlake III Donald-LDE008
> Sent: Friday, October 12, 2007 12:21 PM
> To: Anoop Ghanwani

---

From: Donald.Eastlake at motorola.com (Eastlake III Donald-LDE008)
Date: Sun, 28 Oct 2007 15:54:37 -0400

Actually, because an Rbridge may be the DRB from multiple links in the
same VLAN on different ports and each of those ports could be connected
to a different bridged LAN, you have to report a set of spanning tree
root bridge IDs. Since this is a variable amount of information, if
there aren't any spanning tree devices around so you haven't received
any BPDUs, it seems simplest just to report that the size of the set is
zero.

Donald

On