Subject: [rbridge] How many "priorities" are there?

From: Radia Perlman <[email-masked]>
Date: Fri, 25 Apr 2008 09:52:57 -0700

Is there just a single priority for an RBridge, that is used for all the 
priorities, or are there separate ones for:
a) priority for becoming DRB on a layer 2 cloud
b) priority for becoming the "CSNP-generator" for announcing VLAN x 
endnodes? And if so, is there a separate priority
per VLAN, so you can have low priority for one, and high for another?
c) priority for becoming a tree root?
d) priority for owning a chosen (as opposed to configured) nickname?

There might even be more cases where we use the term "priority".

I'd guess that a) and c) might be things that customers would want to 
configure. I think that b) is something that
should be just a flag "I implement endnode advertisements (learning from 
and advertising)", though perhaps
the flag should be per VLAN. I don't think d) matters, and
we could just use the same priority as for DRB.

Radia
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: "Ayan Banerjee (ayabaner)" <[email-masked]>
Date: Fri, 25 Apr 2008 13:23:40 -0700

Radia, 

I believe that a (IIH-Priority in base IS-IS), c (Root priority TLV in
draft-ward-l2isis), and d (Section 3.7.3 of
draft-ietf-trill-rbridge-protocol, Device ID TLV of draft-ward-l2isis)
are already defined. I would think that the customer may want to
configure all of them separately. 

Thanks,
Ayan 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Radia Perlman
Sent: Friday, April 25, 2008 9:53 AM
To: Developing a hybrid router/bridge.
Subject: [rbridge] How many "priorities" are there?

Is there just a single priority for an RBridge, that is used for all the
priorities, or are there separate ones for:
a) priority for becoming DRB on a layer 2 cloud
b) priority for becoming the "CSNP-generator" for announcing VLAN x
endnodes? And if so, is there a separate priority per VLAN, so you can
have low priority for one, and high for another?
c) priority for becoming a tree root?
d) priority for owning a chosen (as opposed to configured) nickname?

I'd guess that a) and c) might be things that customers would want to
configure. I think that b) is something that should be just a flag "I
implement endnode advertisements (learning from and advertising)",
though perhaps the flag should be per VLAN. I don't think d) matters,
and we could just use the same priority as for DRB.

Radia

---

From: "Anoop Ghanwani" <[email-masked]>
Date: Mon, 28 Apr 2008 16:37:39 -0700

I think it's reasonable to have all of them
be separate.

Anoop 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Ayan 
> Banerjee (ayabaner)
> Sent: Friday, April 25, 2008 1:24 PM
> To: Radia Perlman; Developing a hybrid router/bridge.
> Subject: Re: [rbridge] How many "priorities" are there?
> 
> Radia, 
> 
> I believe that a (IIH-Priority in base IS-IS), c (Root 
> priority TLV in draft-ward-l2isis), and d (Section 3.7.3 of 
> draft-ietf-trill-rbridge-protocol, Device ID TLV of 
> draft-ward-l2isis) are already defined. I would think that 
> the customer may want to configure all of them separately. 
> 
> Thanks,
> Ayan 
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Radia Perlman
> Is there just a single priority for an RBridge, that is used 
> for all the priorities, or are there separate ones for:
> b) priority for becoming the "CSNP-generator" for announcing 
> VLAN x endnodes? And if so, is there a separate priority per 
> VLAN, so you can have low priority for one, and high for another?
> I'd guess that a) and c) might be things that customers would 
> want to configure. I think that b) is something that should 
> be just a flag "I implement endnode advertisements (learning 
> from and advertising)", though perhaps the flag should be per 
> VLAN. I don't think d) matters, and we could just use the 
> same priority as for DRB.
> 
> Radia