Subject: Re: [rbridge] mib

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Sun, 1 Nov 2009 11:37:49 +0100

See in-line. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Caitlin Bestler
> Sent: Friday, October 30, 2009 6:56 AM
> To: Kate Zebrose
> Cc: [email-masked]; Thomas Nadeau; Jeff Pickering; Donald 
> Eastlake 3
> Subject: Re: [rbridge] mib
> 
> Two thoughts on the read-only issue:
> 
> 1) MIBs are a nuisance, 

I like this :-)

> but any limitation to read-only 
> should really be for reasons that are RBridge specific.
>       If the equivalent MIBs for a router, or a Bridge, are 
> writable then the RBridge MIB should be writable as well.
>       A general shift to read-only MIBs should be an IETF 
> discussion, or perhaps tsvwg, not RBridge.

Why TSVWG? 

The other standard MIB modules you are looking at were worked in the
Routing Area and in OPS (Bridge MIB - now transferred to IEEE 802.1)

I would also like to point the attention of the WG to the relatively new
work in NETCONF and NETMOD which was not in place by the time most other
MIB modules were developped but which now starts to be available as an
alternative for standards-based configuration. 

> 
> 2) That said, information in the MIB that is derived from 
> Bridge controls, ISIS or RBridge discovery where nothing
>       in the protocol mandates that this field be 
> configurable then an argument can be made that the MIB should
>       not create the requirement that this information be 
> editable just because it is in a MIB.
> 
> --
> Caitlin Bestler
> [email-masked]
> http://www.asomi.com/CaitlinBestlerResume.html
> 
> 
> 
> _______________________________________________
> rbridge mailing list
> [email-masked]
> http://mailman.postel.org/mailman/listinfo/rbridge
> 

_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 4 Nov 2009 23:21:28 -0500

My main thought is that if we have volunteers willing to produce a read-only
MIB and continue to have no one volunteering for the extra work it takes to
make it writable, then maybe we should settle for a read-only MIB.

Thanks,
Donald
=============================
Donald E. Eastlake 3rd   +1-508-634-2066 (home)
155 Beaver Street
Milford, MA 01757 USA
[email-masked]

On Thu, Oct 29, 2009 at 11:55 PM, Caitlin Bestler <[email-masked]> wrote:

> 1) MIBs are a nuisance, but any limitation to read-only should really
> be for reasons that are RBridge specific.
>      If the equivalent MIBs for a router, or a Bridge, are writable
> then the RBridge MIB should be writable as well.
>      A general shift to read-only MIBs should be an IETF discussion,
> or perhaps tsvwg, not RBridge.
>
> 2) That said, information in the MIB that is derived from Bridge
> controls, ISIS or RBridge discovery where nothing
>      in the protocol mandates that this field be configurable then an
> argument can be made that the MIB should
>      not create the requirement that this information be editable
> just because it is in a MIB.
>
> --
> Caitlin Bestler
> [email-masked]

---

From: jeff pickering <[email-masked]>
Date: Fri, 06 Nov 2009 02:46:48 -0800

I understand that row creation is painful, but is scalar writability 
that big a deal?
What rows do we need to create?

On a related issue, I posted that just referencing 4444 was problematic 
as you then
could not have co-resident trill and L3 isis. This is something we would 
have to live with
forever and therefore a problem for me. I suggested making a "renamed" 
and "trill-adjusted"
version of 4444 for trill and offered to do this work if indeed the 
approach was one
that the group desires.

Comments appreciated.

Jeff

Donald Eastlake wrote:
> My main thought is that if we have volunteers willing to produce a 
> read-only MIB and continue to have no one volunteering for the extra 
> work it takes to make it writable, then maybe we should settle for a 
> read-only MIB.
>
> Thanks,
> Donald
> [email-masked] <mailto:[email-masked]>
>
>
> On Thu, Oct 29, 2009 at 11:55 PM, Caitlin Bestler <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     then the RBridge MIB should be witable as well.
>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>