Subject: [rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt as WG document

From: Erik Nordmark <[email-masked]>
Date: Tue, 15 Nov 2011 17:13:35 -0800

At the TRILL WG meeting Tuesday there were several comments that the
fine-grained label work is important and needs to be prioritized by
the WG. There was also a rough consensus in the room in favor of
adopting the document, as there was in Quebec City, but there were
only about half as many people in the room that indicated they had
read the document as at the last meeting. This is to confirm that it
should be a WG document and ask people to read and comment.

   Erik and Donald
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: David Allan I <[email-masked]>
Date: Tue, 15 Nov 2011 21:49:03 -0500

I think I was the only person in the room to indicate disapproval for WG adoption....so I figure it is appropriate to offer my rationale...

It is a slightly expanded version of my comments minuted at IETF 81...

1) This is solving a TRILL design problem in the Ethernet layer.

2) It is non standard from an Ethernet point of view, and although implementations exist that may stack more than one tag, processing them as a concatenation of tags IMO is still likely new and inconsistent, so this is dependent on a proprietary and non-standard feature. Similarly inferring a tag stack from a single received tag is a new behavior as well as the re-mapping of the dual tag to single tag or untagged frame at the egress.

3) It actually has limited utility as it does not offer any improved broadcast containment beyond egress filtering as it is nested inside the rbridge header (assuming implementations can filter on a concatentated tag stack). So it adds no value in additional scoping for MDTs for flooding and ARP.

So I personally would suggest if you are going to require/mandate silicon modifications, they would be better off applied to the TRILL header itself vs. blurring the distinction between TRILL and 802.1 and introducing a discontinuity in standard compliant implementations. IEEE 802 has already provided a multi-sdo liaison a couple of years ago on how simultaneous multiple tag operations at a single hop is considered to be an architectural violation when proposals akin to this kind of abuse emerged during the GELS discussions.

So I have no issue with TRILL finding a way to support a larger VLAN space, I just do not agree with the proposed approach...it IS interfering with someone elses standard and how companies would implement that standard, and these days that is a really bad precedent.

I hope this helps
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Erik Nordmark
Sent: Wednesday, November 16, 2011 9:14 AM
To: [email-masked]
Subject: [rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt as WG document

At the TRILL WG meeting Tuesday there were several comments that the fine-grained label work is important and needs to be prioritized by the WG. There was also a rough consensus in the room in favor of adopting the document, as there was in Quebec City, but there were only about half as many people in the room that indicated they had read the document as at the last meeting. This is to confirm that it should be a WG document and ask people to read and comment.

   Erik and Donald

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 15 Nov 2011 21:10:58 -0800

On 11/15/11 6:49 PM, David Allan I wrote:
> I think I was the only person in the room to indicate disapproval for
> WG adoption....so I figure it is appropriate to offer my
> rationale...

David,

Thanks for clarifying. I didn't understand one point:

> 3) It actually has limited utility as it does not offer any improved
> broadcast containment beyond egress filtering as it is nested inside
> the rbridge header (assuming implementations can filter on a
> concatentated tag stack). So it adds no value in additional scoping
> for MDTs for flooding and ARP.

If a network has a need to support say 6000 separate tenant networks
across a common core of RBridges, with RFC 6325 that isn't possible
since the inner header can only represent 4k VLANs.
With this proposal we can support that.

Are you concerned about some form of containment across the core? TRILL
will send multi-destination frames on a tree that can optionally be
pruned by transit rbridges based on the C-tag and EX-tag and the inner 
DA. Thus optionally the transit bridges already look inside the inner 
frame to do more efficient pruning.

> So I personally would suggest if you are going to require/mandate
> silicon modifications, they would be better off applied to the TRILL
> header itself vs. blurring the distinction between TRILL and 802.1
> and introducing a discontinuity in standard compliant
> implementations.

My understanding is that the proposed approach is based on what existing
TRILL-capable hardware can support without hardware modifications.
It also has the benefit that existing RBridges can be used for transit.

Regards,
     Erik

---

From: Radia Perlman <[email-masked]>
Date: Tue, 15 Nov 2011 22:14:42 -0800

I have read the document and support making it a WG document. There
are a few typos here and there, but I don't see any technical errors,
and the TRILL implementers say this is the encoding that is most
convenient for their implementations, so I will take their word for
that.  (I was distracted when you asked during the meeting, so I
didn't raise my hand then.)

Radia

---

From: David Allan I <[email-masked]>
Date: Wed, 16 Nov 2011 01:03:27 -0500

> If a network has a need to support say 6000 separate tenant networks across a common core of RBridges, with RFC 6325 that isn't possible since the inner  > header can only represent 4k VLANs.

> Are you concerned about some form of containment across the core? TRILL will send multi-destination frames on a tree that can optionally be pruned by 
> transit rbridges based on the C-tag and EX-tag and the inner DA. Thus optionally the transit bridges already look inside the inner frame to do more 
> efficient pruning.

I was concerned containment that and have discussed pruning with folks without fully appreciating ESADI myself, which I've now looked over. On that concern I stand corrected. My other concerns still stand

Thanks for pointing this out
Dave

---

From: Jon Hudson <[email-masked]>
Date: Wed, 16 Nov 2011 14:37:05 +0800

I have read the document and fully support making it a WG document. 

Many of my customers eagerly await this functionality.  

Jon

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Tue, 15 Nov 2011 22:40:41 -0800

I second Radia on the support for the finegrain draft moving to WG state.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Radia Perlman
Sent: Tuesday, November 15, 2011 10:15 PM
To: Erik Nordmark
Cc: [email-masked]
Subject: Re: [rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt as WG document

Radia

---

From: "Tissa Senevirathne (tsenevir)" <[email-masked]>
Date: Tue, 15 Nov 2011 22:06:53 -0800

Hi David

TRILL allow VLAN based pruning. 6326bis draft already have added
fine-grain labeling capability. This allow devices to prune based on
fine label. Which in turn will limit the broadcast and ARP issue you
brought up in point #3. 

On point #2. Having two 12 bit tags is a common scenario. Since we are
limiting the interpretation of these two tags within the TRILL cloud and
only within the cloud it is fine. Why ? Because TRILL link header is
what 802.3 layer sees. Inner payload is for all practical purpose just
like IP payload on a Ethernet encapped IP packet. Hence how the inner
payload is treated should treated as a TRILL specific forwarding
behavior not any shape violating 802.3.

Thanks
Tissa

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of David Allan I
Sent: Tuesday, November 15, 2011 6:49 PM
To: Erik Nordmark; [email-masked]
Subject: Re: [rbridge] Adopt
draft-eastlake-trill-rbridge-fine-labeling-02.txt as WG document

I think I was the only person in the room to indicate disapproval for WG
adoption....so I figure it is appropriate to offer my rationale...

2) It is non standard from an Ethernet point of view, and although
implementations exist that may stack more than one tag, processing them
as a concatenation of tags IMO is still likely new and inconsistent, so
this is dependent on a proprietary and non-standard feature. Similarly
inferring a tag stack from a single received tag is a new behavior as
well as the re-mapping of the dual tag to single tag or untagged frame
at the egress.

3) It actually has limited utility as it does not offer any improved
broadcast containment beyond egress filtering as it is nested inside the
rbridge header (assuming implementations can filter on a concatentated
tag stack). So it adds no value in additional scoping for MDTs for
flooding and ARP.

So I personally would suggest if you are going to require/mandate
silicon modifications, they would be better off applied to the TRILL
header itself vs. blurring the distinction between TRILL and 802.1 and
introducing a discontinuity in standard compliant implementations. IEEE
802 has already provided a multi-sdo liaison a couple of years ago on
how simultaneous multiple tag operations at a single hop is considered
to be an architectural violation when proposals akin to this kind of
abuse emerged during the GELS discussions.

So I have no issue with TRILL finding a way to support a larger VLAN
space, I just do not agree with the proposed approach...it IS
interfering with someone elses standard and how companies would
implement that standard, and these days that is a really bad precedent.

I hope this helps
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Erik Nordmark
Sent: Wednesday, November 16, 2011 9:14 AM
To: [email-masked]
Subject: [rbridge] Adopt
draft-eastlake-trill-rbridge-fine-labeling-02.txt as WG document

At the TRILL WG meeting Tuesday there were several comments that the
fine-grained label work is important and needs to be prioritized by the
WG. There was also a rough consensus in the room in favor of adopting
the document, as there was in Quebec City, but there were only about
half as many people in the room that indicated they had read the
document as at the last meeting. This is to confirm that it should be a
WG document and ask people to read and comment.

   Erik and Donald

---

From: [email-masked]
Date: Wed, 16 Nov 2011 14:28:47 +0800

I have read the document and support adopting it as WG draft.

Erik Nordmark <[email-masked]> 
发件人:  [email-masked]
2011-11-16 09:13

收件人
[email-masked]
抄送

主题
[rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt       as 
WG document

   Erik and Donald

---

From: David Allan I <[email-masked]>
Date: Wed, 16 Nov 2011 01:22:12 -0500

HI Tissa:

Having two 12 bit tags IS a common scenario and defined in what was 802.1ad now rolled up into 802.1Q(2011). However they are not considered simultaneously, nor imposed simultaneously. My concern is that by requiring a double tag be inferred from a single tag and vice versa you are forcing a change to components in silicon that would be common for both Ethernet and TRILL. Same issue applies to applying filtering/pruning to the VLAN tree. 

My 2 cents
Dave

-----Original Message-----
From: Tissa Senevirathne (tsenevir) [mailto:[email-masked]] 
Sent: Wednesday, November 16, 2011 2:07 PM
To: David Allan I; Erik Nordmark; [email-masked]
Subject: RE: [rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt as WG document

Hi David

TRILL allow VLAN based pruning. 6326bis draft already have added fine-grain labeling capability. This allow devices to prune based on fine label. Which in turn will limit the broadcast and ARP issue you brought up in point #3. 

On point #2. Having two 12 bit tags is a common scenario. Since we are limiting the interpretation of these two tags within the TRILL cloud and only within the cloud it is fine. Why ? Because TRILL link header is what 802.3 layer sees. Inner payload is for all practical purpose just like IP payload on a Ethernet encapped IP packet. Hence how the inner payload is treated should treated as a TRILL specific forwarding behavior not any shape violating 802.3.

Thanks
Tissa

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Tuesday, November 15, 2011 6:49 PM
To: Erik Nordmark; [email-masked]
Subject: Re: [rbridge] Adopt

So I personally would suggest if you are going to require/mandate silicon modifications, they would be better off applied to the TRILL header itself vs. blurring the distinction between TRILL and 802.1 and introducing a discontinuity in standard compliant implementations. IEEE
802 has already provided a multi-sdo liaison a couple of years ago on how simultaneous multiple tag operations at a single hop is considered to be an architectural violation when proposals akin to this kind of abuse emerged during the GELS discussions.

I hope this helps
Dave

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Erik Nordmark
Sent: Wednesday, November 16, 2011 9:14 AM
To: [email-masked]
Subject: [rbridge] Adopt

   Erik and Donald

---

From: Liyizhou <[email-masked]>
Date: Wed, 16 Nov 2011 13:38:34 +0000

I have read the latest version and would like to support it to be a WG document.

________________________________________
发件人: [email-masked] [[email-masked]] 代表 Erik Nordmark [[email-masked]]
发送时间: 2011年11月16日 9:13
到: [email-masked]
主题: [rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt   as WG document

   Erik and Donald

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 16 Nov 2011 12:16:36 -0800

I support making it a WG document.

---

From: Vishwas Manral <[email-masked]>
Date: Wed, 16 Nov 2011 15:39:45 -0800

Hi Erik,

This is critical work and should be taken up by the IETF.

Thanks,
Vishwas

---

From: [email-masked]
Date: Thu, 17 Nov 2011 08:27:24 +0800

I have read this draft. It is important for TRILL. I support it to be a WG 
document.

Thanks,
Zhai Hongjun
""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
 Protocol Development Dept.VI, Central R&D Institute, ZTE Corporation
 No. 68, Zijinghua Road, Yuhuatai District, Nanjing, P.R.China, 210012
 
 Zhai Hongjun
 
 Tel: +86-25-52877345
 Email: [email-masked]
"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

Vishwas Manral <[email-masked]> 
发件人:  [email-masked]
2011-11-17 07:39

收件人
Erik Nordmark <[email-masked]>
抄送
[email-masked]
主题
Re: [rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt as 
WG document

Hi Erik,

Thanks,
Vishwas

  Erik and Donald_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: ayabaner <[email-masked]>
Date: Wed, 16 Nov 2011 17:13:27 -0800

I support it to be a WG document.

Thanks,
Ayan

On 11/16/11 4:27 PM, "[email-masked]" <[email-masked]>
wrote:

> 发件人:  [email-masked] 2011-11-17 07:39
> 收件人 
> Re: [rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt as WG
> document 
> 
> 
> 
> 
> Hi Erik, 
>  
> On Tue, Nov 15, 2011 at 5:13 PM, Erik Nordmark <[email-masked]
> <mailto:[email-masked]> > wrote:
> ZTE Information Security Notice: The information contained in this mail is
> solely property of the sender's organization. This mail communication is
> confidential. Recipients named above are obligated to maintain secrecy and are
> not permitted to disclose the contents of this communication to others.
> This email and any files transmitted with it are confidential and intended
> solely for the use of the individual or entity to whom they are addressed. If
> you have received this email in error please notify the originator of the
> message. Any views expressed in this message are those of the individual
> sender.

---

From: Linda Dunbar <[email-masked]>
Date: Thu, 17 Nov 2011 09:58:31 +0000

Support!

Linda Dunbar

2011-11-16 09:13

收件人

[email-masked]

抄送

主题

[rbridge] Adopt draft-eastlake-trill-rbridge-fine-labeling-02.txt        as WG document

  Erik and Donald

---

From: Vishwas Manral <[email-masked]>
Date: Thu, 17 Nov 2011 03:22:40 -0800

I meant taken up by the WG.

-Vishwas