Subject: Re: [rbridge] TRILL MIB rbridgeUniFibTable

From: Mahesh Akula <[email-masked]>
Date: Tue, 8 Nov 2011 12:16:27 -0800

Only reason I suggested nexthop nickname is to shorten the length of the
key for the table, but it should be fine eitherways.

Regards,
Mahesh

On Tue, Nov 8, 2011 at 12:10 PM, Anil Rijhsinghani <[email-masked]> wrote:

> Thanks for the "Hop count" suggestion Mahesh - Donald, any thoughts? Is
> this
> something an Rbridge can readily find for a FIB table entry?
>
> As for nexthop,  any particular reason why you want nick?
> I prefer to leave it at Mac since the value inserted by the Rbridge
> into the forwarded packet is Mac and not nick. In addition, Mac will
> typically be in a forwarding table; you don't need to know nick of
> the next hop at forwarding time.
>
> Regards,
> Anil
>
>
> On Tue, Nov 8, 2011 at 2:51 PM, Mahesh Akula wrote:
>
>  How about adding "Hop count" which may vary for each ECMP path from
> ingress rbridge to egress rbridge?
>
> Also for the indices how about adding nexthop rbridge nickname, instead of
> nexthop Mac?
>
> Regards,
> Mahesh
>
>
> On Tue, Nov 8, 2011 at 11:36 AM, Anil Rijhsinghani < [email-masked]*>
> wrote:
> Either there will need to be an accessible "dummy" object per row
> (can you think of anything useful instead?) or, one of those index objects
> could be made read-only but I'll need to check if that's allowed.
>
> Regards,
> Anil
>
> -----
> On Tue, Nov 8, 2011 at 1:35 PM, Mahesh Akula wrote:
>
>   Hi Anil,
>
> I'm curious, if all the three objects in the table has MAX-ACCESS set to
> not-accessible, (as it will be the case if all 3 objects are part of the
> index),  how can any operations be performed on the table?
>
> Regards,
> Mahesh
>
>
> On Tue, Nov 8, 2011 at 10:18 AM, Anil Rijhsinghani < [email-masked]*>
> wrote:
> Mahesh,
>
> I did not consider ECMP being used this way, however in discussing
> further with Donald Eastlake – his comment is attached below – he
> indicates it could happen, whether intentionally or not.
>
> To accommodate this, I'll add rbridgeFibMacAddress to the index to make
> it unique. (I considered taking out rbridgeFibPort from the index, but
> that could make it non-unique if the same next-hop were attached to an
> RBridge via more than one port.)
>
> Regards,
> Anil
>
> -----
> On Nov 7, 2011, at 7:50 PM, Donald Eastlake wrote:
>
> It seems to me that this is possible.
>
> It will not usually happen as there will be a pseudo-node and there
> will be only one path out the port to the pseudo-node... However, the
> DRB can suppress the pseudo-node. The standard says that it SHOULD do
> this if there is only one adjacency, which is obviously no problem.
> But if there are 2 or more adjacencies out the port and the DRB
> suppresses the pseudo-node, then it seems to me that there can indeed
> be more than one ECMP path out a port to a particular destination.
> This will work fine as the frames will be unicast to the intended next
> hop...
>
> If the link is an Ethernet bridged LAN, this could cause more traffic
> on the port than on some other port which also has an ECMP path to the
> destination, but only one such path, perhaps causing some congestion.
> On the other hand, if the link is something exotic like a switching
> fabric link, there might be little interference between the unicast
> traffic out the port to different ECMP adjacencies on the link...
>
> Thanks,
> Donald
>
> -----
> On Nov 7, 2011, at 5:00 PM, Mahesh Akula wrote:
>
> Dear Authors,
>
> As per the draft-ietf-trill-rbridge-mib-04, indices for the
> rbridgeUniFibTable has been defined as combination of rbridgeFibNickname
> and rbridgeFibPort.
>
> In an ECMP scenario, on a Shared LAN link, there can be reachability to
> the Egress Rbridge over two different nexthop Rbridges connected to the
> same rbridge port right?  In this case, there will be more than one entry
> with the same rbridgeFibNickname and rbridgeFibPort but with different
> nexthop Rbridge nickname.
>
> Don't we need to include the nexthop rbridge name also part of the indices
> for this table? Or Am I missing something here?
>
> Regards,
> Mahesh
> _______________________________________________
> rbridge mailing list
> [email-masked]*
> *http://mailman.postel.org/mailman/listinfo/rbridge*<http://mailman.postel.org/mailman/listinfo/rbridge>
>
>
>
>
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Anil Rijhsinghani <[email-masked]>
Date: Tue, 8 Nov 2011 15:10:29 -0500 (EST)

Regards,
Anil

 
Also for the indices how about adding nexthop rbridge nickname, instead 
of nexthop Mac?
 
Regards,
Mahesh

On Tue, Nov 8, 2011 at 11:36 AM, Anil Rijhsinghani < [email-masked] 
<javascript:parent.wgMail.openComposeWindow([email-masked]')> > 
wrote:
Either there will need to be an accessible "dummy" object per row
(can you think of anything useful instead?) or, one of those index 
objects
could be made read-only but I'll need to check if that's allowed.

Regards,
Anil

-----

  Hi Anil,

Regards,
Mahesh

On Tue, Nov 8, 2011 at 10:18 AM, Anil Rijhsinghani < [email-masked]> 
wrote:
Mahesh,

Regards,
Anil

-----

Thanks,
Donald

-----

Dear Authors,

In an ECMP scenario, on a Shared LAN link, there can be reachability to 
the Egress Rbridge over two different nexthop Rbridges connected to the 
same rbridge port right?  In this case, there will be more than one 
entry with the same rbridgeFibNickname and rbridgeFibPort but with 
different nexthop Rbridge nickname.

Don't we need to include the nexthop rbridge name also part of the 
indices for this table? Or Am I missing something here?

Regards,
Mahesh
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge 
<http://mailman.postel.org/mailman/listinfo/rbridge>

---

From: Vishwas Manral <[email-masked]>
Date: Tue, 8 Nov 2011 13:17:16 -0800

Anil,

Is our assumption that the link used will be Ethernet? Would the same table
work for PPP too?

Thanks,
Vishwas

On Tue, Nov 8, 2011 at 12:16 PM, Mahesh Akula <[email-masked]>wrote:

> On Tue, Nov 8, 2011 at 12:10 PM, Anil Rijhsinghani <[email-masked]>wrote:
>

---

From: Anil Rijhsinghani <[email-masked]>
Date: Tue, 8 Nov 2011 21:51:05 -0500

Vishwas,

I have not verified the MIB against PPP. But I guess that's a good argument for using a nickname for next-hop in this table, rather than MAC address.

Regards,
Anil

On Nov 8, 2011, at 4:17 PM, Vishwas Manral <[email-masked]> wrote:

> Anil,
>  
> Is our assumption that the link used will be Ethernet? Would the same table work for PPP too?
>  
> Thanks,
> Vishwas
> 
> On Tue, Nov 8, 2011 at 12:16 PM, Mahesh Akula <[email-masked]> wrote:
> Only reason I suggested nexthop nickname is to shorten the length of the key for the table, but it should be fine eitherways.
>  
> Regards,
> Mahesh
> 
> Thanks for the "Hop count" suggestion Mahesh - Donald, any thoughts? Is this
>  How about adding "Hop count" which may vary for each ECMP path from ingress rbridge to egress rbridge?
>  
> Also for the indices how about adding nexthop rbridge nickname, instead of nexthop Mac?
>  
> Regards,
> Mahesh
> 
> 
> On Tue, Nov 8, 2011 at 11:36 AM, Anil Rijhsinghani < [email-masked]> wrote:
> I'm curious, if all the three objects in the table has MAX-ACCESS set to not-accessible, (as it will be the case if all 3 objects are part of the index),  how can any operations be performed on the table?
>  
> Regards,
> Mahesh
> 
> 
> On Tue, Nov 8, 2011 at 10:18 AM, Anil Rijhsinghani < [email-masked]> wrote:
> Mahesh,
> 
> As per the draft-ietf-trill-rbridge-mib-04, indices for the rbridgeUniFibTable has been defined as combination of rbridgeFibNickname and rbridgeFibPort.
> 
> In an ECMP scenario, on a Shared LAN link, there can be reachability to the Egress Rbridge over two different nexthop Rbridges connected to the same rbridge port right?  In this case, there will be more than one entry with the same rbridgeFibNickname and rbridgeFibPort but with different nexthop Rbridge nickname.
> 
> Don't we need to include the nexthop rbridge name also part of the indices for this table? Or Am I missing something here?
> 
> Regards,
> Mahesh

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 10 Nov 2011 12:52:27 -0500

Hi,

> something an Rbridge can readily find for a FIB table entry?

While it should be easy to calculate, I don't think there is a current
requirement to calculate it...

> the next hop at forwarding time.

The case of other link technologies seems like a reasonably good
reason to go with nickname...

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

> rbridgeUniFibTable has been defined as combination of rbridgeFibNickname and
> rbridgeFibPort.
> In an ECMP scenario, on a Shared LAN link, there can be reachability to the
> Egress Rbridge over two different nexthop Rbridges connected to the same
> rbridge port right?  In this case, there will be more than one entry with
> the same rbridgeFibNickname and rbridgeFibPort but with different nexthop
> Rbridge nickname.