Subject: [rbridge] OAM direction

From: Vishwas Manral <[email-masked]>
Date: Sat, 31 Mar 2012 11:48:31 -0700

Hi Jon,

Here are a few points we need to take care for good OAM design:

1. The OAM packets should be defined as far as possible to be independent
of the lower layer.

2. As we know we already run OAM over all layers like TCP/ ICMP/ UDP/ IP or
any thing else, so as to be able to replicate real world traffic.In a TRILL
network, we can already run traffic/ OAM end to end. So if we sent IP/ ICMP
ping over the TRILL network end-to-end, it would work similar to similar
data traffic already. What is most required is how the OAM traffic is able
to monitor traffic directly over Ethernet.

3. We do not need to define every possible combination of OAM packets in
the same draft. We first need a simple set of ping and unicast traceroute.

Do let me know if this sounds reasonable?

Thanks,
Vishwas

On Sat, Mar 31, 2012 at 3:05 AM, Jon Hudson <[email-masked]> wrote:

>
> The number one concern I hear from Users about anything UDP is that it can
> be dropped and is stateless. (big issue with VXLAN) As this is the same for
> ICMP I see no practical difference to the User which one is used.
>
>
> On Fri, Mar 2, 2012 at 10:47 AM, Sam Aldrin <[email-masked]> wrote:
>
>> Do not have much preference of reusing the same port or not. With a
>> programmer hat on, who developed rfc4379 and it's implementation, it will
>> be klugy, and have issues when process is/was implemented in h.w. For ex:
>> had issue with vccv when used by lsp ping and bfd, due to incompatible
>> hardware in the network.
>> Having said that, idea is to use similar message or tlv formats, will
>> help immensely in adopting the standard.
>>
>> Cheers
>> Sam
>>
>> Sent from my iPad
>>
>> On Mar 2, 2012, at 10:11 AM, Vishwas Manral <[email-masked]>
>> wrote:
>>
>> Hi Tissa,
>>
>> I am not sure we would want to use the same port for de-multiplexing MPLS
>> OAM and UDP based TRILL OAM packets.
>>
>> On another note, I do know that folks use different channels for testing
>> real application behavior in current networks. So yes UDP based channels
>> should be good too.
>>
>> My biggest concern is that we should not have different message formats
>> when the application works over different layers. It is for that reason
>> that BFD has been so successful (the same message format/ state machine)
>> irrespective of the lower layer protocol.
>>
>> Thanks,
>> Vishwas
>>
>> On Fri, Mar 2, 2012 at 8:08 AM, Tissa Senevirathne (tsenevir) <
>> [email-masked]> wrote:
>>
>>> Dear All****
>>>
>>> ** **
>>>
>>> Current draft-tissa-till-oam utilize ICMP extensions defined in RFC
>>> 4884. I have also heard preference of using UDP based messaging channel
>>> defined in RFC 4379.****
>>>
>>> ** **
>>>
>>> Advantage of using RFC 4379 methods is we can utilize the same framework
>>> and OAM challenges in TRILL and MPLS world are similar. However, we need to
>>> define new TLV series and message types. Question arise whether we should
>>> use the same wellknown UDP port used in MPLS OAM or a use a different UDP
>>> port.****
>>>
>>> ** **
>>>
>>> Advantage of ICMP method is we are utilizing the ICMP infrastructure
>>> that is commonly utilized in IP world. However, we need to define RFC 4884
>>> extensions and it also heavily depends on acceptance of individual
>>> submission draft-shen-traceroute-ping-ext-04.****
>>>
>>> ** **
>>>
>>> Would like to see the preference from the WG on specific method over the
>>> other ?****
>>>
>>> ** **
>>>
>>> Thanks****
>>>
>>> Tissa****
>>>
>>>
>> _______________________________________________
>> rbridge mailing list
>> [email-masked]
>> http://mailman.postel.org/mailman/listinfo/rbridge
>>
>>
>> _______________________________________________
>> rbridge mailing list
>> [email-masked]
>> http://mailman.postel.org/mailman/listinfo/rbridge
>>
>>
>
>
> --
> "Do not lie. And do not do what you hate."
>
>
_______________________________________________
rbridge mailing list
[email-masked]
http://mailman.postel.org/mailman/listinfo/rbridge

---

From: Sam Aldrin <[email-masked]>
Date: Sat, 31 Mar 2012 21:59:10 +0200

Hi All,

Whatever tools one implements is left to ones choice. Be it ping or something else. I don't think we are disagreeing on that front at all. The effort we put in here should make sure the framework supports all Oam aspects in Trill. Discussions we had focused on that aspects and resolved many issues, and clarified why we do not have one, at present. Hopefully we put to rest, the confusion, once we publish framework/requirements doc.

Cheers
Sam

Sent from my iPhone

On Mar 31, 2012, at 8:48 PM, Vishwas Manral <[email-masked]> wrote:

> 1. The OAM packets should be defined as far as possible to be independent of the lower layer. 
> 
> 2. As we know we already run OAM over all layers like TCP/ ICMP/ UDP/ IP or any thing else, so as to be able to replicate real world traffic.In a TRILL network, we can already run traffic/ OAM end to end. So if we sent IP/ ICMP ping over the TRILL network end-to-end, it would work similar to similar data traffic already. What is most required is how the OAM traffic is able to monitor traffic directly over Ethernet.
> 
> 3. We do not need to define every possible combination of OAM packets in the same draft. We first need a simple set of ping and unicast traceroute. 
> 
> The number one concern I hear from Users about anything UDP is that it can be dropped and is stateless. (big issue with VXLAN) As this is the same for ICMP I see no practical difference to the User which one is used. 
> 
> 
> Do not have much preference of reusing the same port or not. With a programmer hat on, who developed rfc4379 and it's implementation, it will be klugy, and have issues when process is/was implemented in h.w. For ex: had issue with vccv when used by lsp ping and bfd, due to incompatible hardware in the network.
> Having said that, idea is to use similar message or tlv formats, will help immensely in adopting the standard.
> 
> Cheers
> Sam
> 
> Sent from my iPad
> 
> On Mar 2, 2012, at 10:11 AM, Vishwas Manral <[email-masked]> wrote:
> 
>> Hi Tissa,
>> 
>> I am not sure we would want to use the same port for de-multiplexing MPLS OAM and UDP based TRILL OAM packets.
>> 
>> On another note, I do know that folks use different channels for testing real application behavior in current networks. So yes UDP based channels should be good too. 
>> 
>> My biggest concern is that we should not have different message formats when the application works over different layers. It is for that reason that BFD has been so successful (the same message format/ state machine) irrespective of the lower layer protocol.
>> 
>> Thanks,
>> Vishwas
>> 
>> On Fri, Mar 2, 2012 at 8:08 AM, Tissa Senevirathne (tsenevir) <[email-masked]> wrote:
>> Dear All
>> 
>>  
>> 
>> Current draft-tissa-till-oam utilize ICMP extensions defined in RFC 4884. I have also heard preference of using UDP based messaging channel defined in RFC 4379.
>> 
>>  
>> 
>> Advantage of using RFC 4379 methods is we can utilize the same framework and OAM challenges in TRILL and MPLS world are similar. However, we need to define new TLV series and message types. Question arise whether we should use the same wellknown UDP port used in MPLS OAM or a use a different UDP port.
>> 
>>  
>> 
>> Advantage of ICMP method is we are utilizing the ICMP infrastructure that is commonly utilized in IP world. However, we need to define RFC 4884 extensions and it also heavily depends on acceptance of individual submission draft-shen-traceroute-ping-ext-04.
>> 
>>  
>> 
>> Would like to see the preference from the WG on specific method over the other ?
>> 
>>  
>> 
>> Thanks
>> 
>> Tissa
>> 
>> 
>> 
>

---

From: Jon Hudson <[email-masked]>
Date: Sat, 31 Mar 2012 15:14:07 -0700

That's an interesting point Vishwas. I think I was too sleepy when I first
read this. To be able to choose to run OAM over whatever layer I choose in
TRILL would be highly desirable.

So then what you are saying is that while the end goal is to support
multiple options for OAM transport, for the sake of moving forward the goal
should be to choose a simple direct example for the draft so that we have
an example of ping and traceroute.

Then the end goal would be the ability to perform OAM function over
whatever transport was being tested in that case.

Is that correct?

On Sat, Mar 31, 2012 at 11:48 AM, Vishwas Manral <[email-masked]>wrote:

> 2. As we know we already run OAM over all layers like TCP/ ICMP/ UDP/ IP
> or any thing else, so as to be able to replicate real world traffic.In a
> TRILL network, we can already run traffic/ OAM end to end. So if we sent
> IP/ ICMP ping over the TRILL network end-to-end, it would work similar to
> similar data traffic already. What is most required is how the OAM traffic
> is able to monitor traffic directly over Ethernet.
>
>> The number one concern I hear from Users about anything UDP is that it
>> can be dropped and is stateless. (big issue with VXLAN) As this is the same
>> for ICMP I see no practical difference to the User which one is used.
>>
>>
>> On Fri, Mar 2, 2012 at 10:47 AM, Sam Aldrin <[email-masked]>wrote:
>>
>>> I am not sure we would want to use the same port for de-multiplexing
>>> MPLS OAM and UDP based TRILL OAM packets.
>>>
>>>> Advantage of using RFC 4379 methods is we can utilize the same
>>>> framework and OAM challenges in TRILL and MPLS world are similar. However,
>>>> we need to define new TLV series and message types. Question arise whether
>>>> we should use the same wellknown UDP port used in MPLS OAM or a use a
>>>> different UDP port.****
>>>>
>>>> ** **
>>>>
>>>> Would like to see the preference from the WG on specific method over
>>>> the other ?****
>>>>
>>>> ** **
>>>>
>>>> Thanks****
>>>>
>>>> Tissa****
>>>>
>>>>

---

From: Vishwas Manral <[email-masked]>
Date: Sat, 31 Mar 2012 15:24:32 -0700

Hi Sam,

I guess we agree.

All I am saying is, it is good to get the solution out. If you want to do
the framework in parallel as a guiding principal that's good enough.
However we should not wait for any framework etc to be finalized before we
get the OAM solution work going. Infact I think with the way we are, we
need to proceed with the solution, as we have an idea of the framework in
place too.

Thanks,
Vishwas

On Sat, Mar 31, 2012 at 12:59 PM, Sam Aldrin <[email-masked]> wrote:

> Hi All,
>
> Whatever tools one implements is left to ones choice. Be it ping or
> something else. I don't think we are disagreeing on that front at all. The
> effort we put in here should make sure the framework supports all Oam
> aspects in Trill. Discussions we had focused on that aspects and resolved
> many issues, and clarified why we do not have one, at present. Hopefully we
> put to rest, the confusion, once we publish framework/requirements doc.
>
> Cheers
> Sam
>
> Sent from my iPhone
>

---

From: Vishwas Manral <[email-masked]>
Date: Sat, 31 Mar 2012 15:28:05 -0700

Hi Jon,

I am saying one OAM mechanism, which can allow us to run over multiple
layers, With a particular layer binding done to start off. The mechanism
should be independent of the lower layer and that should allow it to be
extensible for the future.

If you see we can already do reach ability tests from server to server (so
ICMP Ping), as it traverses a TRILL network, or even a Server to Router
test.

Let me know if I am missing the point altogether?

Thanks,
Vishwas

On Sat, Mar 31, 2012 at 3:14 PM, Jon Hudson <[email-masked]> wrote:

>>>> On another note, I do know that folks use different channels for
>>>> testing real application behavior in current networks. So yes UDP based
>>>> channels should be good too.
>>>>

---

From: Sam Aldrin <[email-masked]>
Date: Sat, 31 Mar 2012 15:32:50 -0700

Hi Vishwas,

I will let Tissa to fill you in with details.

But we had lengthy discussions about the same here at IETF and the conclusion was opposite to what you have eluded to. We had laid out bare all the various proposals, I believe it is 3, on the table and had all the stake holders involved. The conclusion was that, we had to formalize the requirements first and ensure all the identified requirements to be met by the proposed solution/framework. On top of it, we were advised to ensure to check with other SDO's, in order to ensure the parity and no re-invention of the wheel.

HTH,
Sam

Sent from my iPad

On Mar 31, 2012, at 3:24 PM, Vishwas Manral <[email-masked]> wrote:

> Hi Sam,
> 
> I guess we agree.
> 
> All I am saying is, it is good to get the solution out. If you want to do the framework in parallel as a guiding principal that's good enough. However we should not wait for any framework etc to be finalized before we get the OAM solution work going. Infact I think with the way we are, we need to proceed with the solution, as we have an idea of the framework in place too. 
> 
> Thanks,
> Vishwas
>

---

From: Vishwas Manral <[email-masked]>
Date: Sat, 31 Mar 2012 17:34:46 -0700

Thanks Sam. Sounds great to me.

-Vishwas

On Sat, Mar 31, 2012 at 3:32 PM, Sam Aldrin <[email-masked]> wrote:

> But we had lengthy discussions about the same here at IETF and the
> conclusion was opposite to what you have eluded to. We had laid out bare
> all the various proposals, I believe it is 3, on the table and had all the
> stake holders involved. The conclusion was that, we had to formalize the
> requirements first and ensure all the identified requirements to be met by
> the proposed solution/framework. On top of it, we were advised to ensure to
> check with other SDO's, in order to ensure the parity and no re-invention
> of the wheel.
>
> HTH,
> Sam
>
> Sent from my iPad
>
> On Sat, Mar 31, 2012 at 12:59 PM, Sam Aldrin <[email-masked]>wrote:
>
>> Hi All,
>>