Subject: [trill] Queries on ESADI LSP process

From: somnath chatterjee <[email-masked]>
Date: Fri, 10 Aug 2012 17:37:07 +0530

Hi Authors,

Please consider this scenario when an ESADI RB1 has already 3
fragments of ESADI LSP from
ESADI RB2. And now it receives from RB2 an updated ESADI LSP-zero with
few changes(few MACs added
and few deleted) in MAC reachability TLV. How much time should the RB1
wait for other fragments
ESADI-LSP-1 ESADI_LSP-2 etc to come?
Also when all the fragmented ESADI LSPs have come, the comparison
between MAC  information in previously
received LSPs and new received LSPs will be easy if the MACs that are
lost are notified in some
way.Based on this comparisons the routes will be updated in hardware
(Egress Nickname, vlan, MAC1,MAC2).

Is it possible to set any field to mark the last ESADI LSP fragment
send? This will help the receiving RB
to know when to start comparing the LSPs for noticing any change in
MAC association. Also is it possible to send
the MACs that were lost(marking them by some flag), the comparison
algorithm will be quicker if that is done.

Thank you,
Regards,
Somnath

---

From: Ayan Banerjee <[email-masked]>
Date: Fri, 10 Aug 2012 08:15:16 -0700

Somnath,

This is no different than processing "routing" information for L3.

Also, you should probably take a look at this:
http://www.ietf.org/mail-archive/web/isis-wg/current/msg03006.html

Thanks,
Ayan

On Fri, Aug 10, 2012 at 5:07 AM, somnath chatterjee <
[email-masked]> wrote:

> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: somnath chatterjee <[email-masked]>
Date: Wed, 15 Aug 2012 21:25:42 +0530

Hi Ayan,

Thank you for the valuable information.

Regards,
Somnath

On Fri, Aug 10, 2012 at 8:45 PM, Ayan Banerjee <[email-masked]> wrote:
> On Fri, Aug 10, 2012 at 5:07 AM, somnath chatterjee
> <[email-masked]> wrote:
>>
>> Hi Authors,
>>