Subject: [trill] http://tools.ietf.org/html/draft-ietf-trill-oam-framework-00

From: Eric Gray <[email-masked]>
Date: Tue, 13 Nov 2012 23:34:35 +0000

Donald,

                I am confused about something.

                During the TRILL WG meeting, I believe we had a consensus of the room
to adopt the draft "draft-salam-trill-oam-framework" as a working group draft.

                It is the case that a "consensus of the room" is not sufficient to conclude
working group consensus has been achieved.  The room consensus needs to be
confirmed on the mailing list - usually with a one or two week poll.

                Yet draft-salam-trill-oam-framework has been posted as a working group
draft (under the name shown in the subject line of this message).

                I have looked though my mail and do not see an announcement of any
such poll for consensus

                Did the poll confirming the sense of the room happen, or have we had
a bit of a slip-up?

--
Eric

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 13 Nov 2012 18:41:13 -0500

Hi Eric,

The call by the Chairs to make this OAM framework draft a WG draft was
issued here
http://www.ietf.org/mail-archive/web/trill/current/msg05348.html

Technically, I could argue that there was no need to wait until the WG
meeting before making a determination but we did so the consensus in
the room merely ratified the consensus on the mailing list.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

On Tue, Nov 13, 2012 at 6:34 PM, Eric Gray <[email-masked]> wrote:
> confirmed on the mailing list – usually with a one or two week poll.
>
>
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 14 Nov 2012 10:47:20 +0100

Hi,

I agree with Donald. It looks to me that the proper process was followed
here, as the mail list call for consensus issued on 10/26 was asking
'Please indicate whether or not you think this is reasonable as a WG
document in the next week or so.' The five responses that followed on
the mail list were all in support. The consensus call in the room at
IETF-85 can be considered as a last opportunity to express concerns,
which again resulted in favorable consensus. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Donald Eastlake
> Sent: Wednesday, November 14, 2012 1:41 AM
> To: Eric Gray
> Cc: Ralph Droms ([email-masked]); TRILL Working Group
> Subject: Re: [trill]http://tools.ietf.org/html/draft-ietf-trill-oam-
> framework-00
> 
> Hi Eric,
> 
> issued here http://www.ietf.org/mail-
> archive/web/trill/current/msg05348.html
> 
the
> room merely ratified the consensus on the mailing list.
> 
> Thanks,
> Donald
>  155 Beaver Street, Milford, MA 01757 USA  [email-masked]
> 
> 
> >                 Yet draft-salam-trill-oam-framework has been posted
as
> > a working group
> >                 Did the poll confirming the sense of the room
happen,
> > or have we had
> >
> > a bit of a slip-up?
> >
> >
> >
> > --
> >
> > Eric
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill

---

From: Eric Gray <[email-masked]>
Date: Wed, 14 Nov 2012 17:55:02 +0000

Donald,

	Thanks for the clarification.  The request for support for adoption was sent out on
26 October, looking for responses "in the next week or so."

	The request was posted by Erik Nordmark and I had missed it.

	My confusion on this was worsened by the way that the usual procedure had been 
"turned around" in seeking confirmation "from the room" of an apparent consensus on the 
list.  

	As a matter of process, I wonder why the question was asked.  I believe that the list
result would have over-ridden the sense of the room, since the results from the list are - I
believe - expected to be definitive.  Ratification by room consensus should be unnecessary
and irrelevant.

	Asking the question in the room was unusual enough to conform my belief that the 
request to the list had not yet been sent.

	My apologies for spreading confusion on the issue...

--
Eric

-----Original Message-----
From: Donald Eastlake [mailto:[email-masked]] 
Sent: Tuesday, November 13, 2012 6:41 PM
To: Eric Gray
Cc: TRILL Working Group; Ralph Droms ([email-masked])
Subject: Re: http://tools.ietf.org/html/draft-ietf-trill-oam-framework-00
Importance: High

Hi Eric,

The call by the Chairs to make this OAM framework draft a WG draft was issued here http://www.ietf.org/mail-archive/web/trill/current/msg05348.html

Technically, I could argue that there was no need to wait until the WG meeting before making a determination but we did so the consensus in the room merely ratified the consensus on the mailing list.

Thanks,
Donald

---

From: Eric Gray <[email-masked]>
Date: Thu, 15 Nov 2012 20:46:57 +0000

Dan,

	Thanks!

	As explained in separate mail, I was confused by the order of the process in
this case (apparently using the meeting to confirm the - somewhat feeble - support
from the mailing list), in combination with having entirely missed the consensus call
on the mailing list.

	I also agree that the process was followed, if in a somewhat contorted way.

--
Eric

-----Original Message-----
From: Romascanu, Dan (Dan) [mailto:[email-masked]] 
Sent: Wednesday, November 14, 2012 4:47 AM
To: Donald Eastlake; Eric Gray
Cc: [email-masked]; TRILL Working Group
Subject: RE: [trill]http://tools.ietf.org/html/draft-ietf-trill-oam-framework-00
Importance: High

Hi,

I agree with Donald. It looks to me that the proper process was followed here, as the mail list call for consensus issued on 10/26 was asking 'Please indicate whether or not you think this is reasonable as a WG document in the next week or so.' The five responses that followed on the mail list were all in support. The consensus call in the room at
IETF-85 can be considered as a last opportunity to express concerns, which again resulted in favorable consensus. 

Regards,

Dan

the
as
happen,

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 15 Nov 2012 16:20:38 -0500

Hi Eric,

>         The request was posted by Erik Nordmark and I had missed it.

I believe, when I went over draft status at the beginning of the
meeting, I mentioned that a call to make this a working group draft
had gone out. But whether I did or not, I should probably have
mentioned this later in the meeting when it came up.

> believe - expected to be definitive.  Ratification by room consensus should be unnecessary

Well, a couple of points:
     In making a consensus judgement, WG Chairs can take into account
both the mailing list and the opinion of open WG meetings. A call for
opinions/comments on the mailing list that either begins or ends with
determining the opinion of an open meeting is fine.
     So far as I am aware, there is no IETF rule requiring a formal
consensus determination to make a draft a WG draft. We more or less
operate that way in the TRILL WG, at least requiring a clear
preference, and people seem to be happy with the procedure. But, while
it is less common recently, there have been IETF WGs in the past that
operated in what might be called a promiscuous mode where numerous
drafts were made WG drafts just by the action of the Chair, frequently
including mutually contradictory drafts. Of course, such WGs only ever
progressed a fraction of their WG drafts to RFC.

> request to the list had not yet been sent.

Different IETF WGs differ in this regard. For example, the procedure
of asking for an opinion and/or discussing a personal draft on the
mailing list followed by taking the opinion of an open meeting and
making the draft a WG draft if that meeting opinion is favorable is
the common process in the IETF DHC WG, at least as far as I have
observed.

Thanks,
Donald