Subject: Re: [trill] FW: New Version Notification for draft-dunbar-trill-scheme-for-directory-assist-03.txt

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 6 Nov 2012 14:39:45 -0800

I think the draft would benefit from having a section that discussed
the implications of this mechanism on the forwarding plane.  When
directory-assisted forwarding is in use, what happens if there is a miss.
I think there are 3 options for that:

(a) Discard the packet (because we're supposed to know where everything
is, a priori);

(b) Punt the packet to the control plane so that the control plane can
"pull"
the necessary directory entry and discard the frame if the "pull" fails;

(c) Flood the frame.

My guess is that there are scenarios where all 3 of these would make
sense and it would be good to have a description of these in the draft.

Anoop

On Tue, Oct 23, 2012 at 9:32 AM, Linda Dunbar <[email-masked]>wrote:

> TRILL WG,
>
> Here is a draft describing the detailed mechanism to achieve Directory
> Service for TRILL. We are proposing to re-use ESADI mechanism for directory
> servers to distribute mapping information. Your comments and suggestions
> are greatly appreciated.
>
> Thanks, Linda
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, October 22, 2012 12:12 PM
> To: Linda Dunbar
> Cc: [email-masked]; [email-masked]; Liyizhou; [email-masked]
> Subject: New Version Notification for
> draft-dunbar-trill-scheme-for-directory-assist-03.txt
>
>
> A new version of I-D, draft-dunbar-trill-scheme-for-directory-assist-03.txt
> has been successfully submitted by Linda Dunbar and posted to the
> IETF repository.
>
> Filename:        draft-dunbar-trill-scheme-for-directory-assist
> Revision:        03
> Title:           Mechanisms for Directory Assisting TRILL
> Creation date:   2012-10-22
> WG ID:           Individual Submission
> Number of pages: 13
> URL:
> http://www.ietf.org/internet-drafts/draft-dunbar-trill-scheme-for-directory-assist-03.txt
> Status:
> http://datatracker.ietf.org/doc/draft-dunbar-trill-scheme-for-directory-assist
> Htmlized:
> http://tools.ietf.org/html/draft-dunbar-trill-scheme-for-directory-assist-03
> Diff:
> http://www.ietf.org/rfcdiff?url2=draft-dunbar-trill-scheme-for-directory-assist-03
>
> Abstract:
>    This draft describes the mechanisms of using directory server(s) to
>    assist TRILL (Transparent Interconnection of Lots of Links) edge
>    switches in reducing ARP/ND and unknown unicast flooding across
>    TRILL domain in data center environment.
>
> Conventions used in this document
>
>    The term ''Subnet'' and ''VLAN'' are used interchangeably in this
>    document because it is common to map one subnet to one VLAN. The
>    term ''TRILL switch'' and ''RBridge'' are used interchangeably in this
>    document.
>
>
>
> The IETF Secretariat
>
> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: Linda Dunbar <[email-masked]>
Date: Tue, 6 Nov 2012 23:09:10 +0000

Anoop,

Thank you very much for the suggestion. Radia had similar suggestion, i.e. RBridge needs to have the policy to drop packet ( or flood the packet) if the Directory doesn't have the Egress RBridge information for the Target.

We will add it to the next revision.

Linda

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Tuesday, November 06, 2012 5:40 PM
To: Linda Dunbar
Cc: [email-masked]
Subject: Re: [trill] FW: New Version Notification for draft-dunbar-trill-scheme-for-directory-assist-03.txt

(b) Punt the packet to the control plane so that the control plane can "pull"
the necessary directory entry and discard the frame if the "pull" fails;

(c) Flood the frame.

Anoop

On Tue, Oct 23, 2012 at 9:32 AM, Linda Dunbar <[email-masked]<mailto:[email-masked]>> wrote:
TRILL WG,

Here is a draft describing the detailed mechanism to achieve Directory Service for TRILL. We are proposing to re-use ESADI mechanism for directory servers to distribute mapping information. Your comments and suggestions are greatly appreciated.

Thanks, Linda

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, October 22, 2012 12:12 PM
To: Linda Dunbar
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Liyizhou; [email-masked]<mailto:[email-masked]>
Subject: New Version Notification for draft-dunbar-trill-scheme-for-directory-assist-03.txt

Filename:        draft-dunbar-trill-scheme-for-directory-assist
Revision:        03
Title:           Mechanisms for Directory Assisting TRILL
Creation date:   2012-10-22
WG ID:           Individual Submission
Number of pages: 13
URL:             http://www.ietf.org/internet-drafts/draft-dunbar-trill-scheme-for-directory-assist-03.txt
Status:          http://datatracker.ietf.org/doc/draft-dunbar-trill-scheme-for-directory-assist
Htmlized:        http://tools.ietf.org/html/draft-dunbar-trill-scheme-for-directory-assist-03
Diff:            http://www.ietf.org/rfcdiff?url2=draft-dunbar-trill-scheme-for-directory-assist-03

Abstract:

The IETF Secretariat

_______________________________________________
trill mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/trill