Subject: [trill] Charter Revision TRILL Link Types Item

From: Donald Eastlake <[email-masked]>
Date: Thu, 2 May 2013 22:06:17 -0400

Hi,

"Item (4) Support of IP links between TRILL switches, for example to
connect branch office TRILL switches to a central campus over the
Internet.  (draft-mrw-trill-over-ip)"

Based on the discussion at the meeting, including the discussion of
draft-yong-pwe3-trill-o-pw, which has been tweaked and re-posted as
draft-yong-trill-o-pw, I suggest this item be replaced by

"Item (4) Support of TRILL over pseudowires and IP tunnels between
TRILL switches, for example to connect branch office TRILL switches to
a central campus over the Internet. (draft-yong-trill-o-pw)"

Comments?

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Sam Aldrin <[email-masked]>
Date: Tue, 7 May 2013 08:02:48 -0700

I am not comfortable with new text either.
It should rather say, TRILL extensions to support extension of TRILL campus over WAN/internet. Something like that.
Narrowing charter it to fit specific drafts or solutions will keep other work, outside of it, not in scope.

-sam

On May 2, 2013, at 7:06 PM, Donald Eastlake <[email-masked]> wrote:

> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 16 May 2013 04:09:53 -0400

Hi Sam,

> It should rather say, TRILL extensions to support extension of TRILL campus over WAN/internet. Something like that.

I see two parts to what you want: (1) various link technology
protocols, and (2) optionally a more restricted control protocol to
reduce the probability of error propagation, etc.

Looking at these separately:

(1) Generally TRILL over X link technology stuff gets done in the X
WG, if there is an X WG, not in the TRILL WG. For pseudo wires, we
have agreement from the PWE3 Chairs and AD that it should be done in
TRILL as long as there is not change to PWE3. For IP, there is no IP
WG. I'm not convinced we could get something that would imply we could
do TRILL over an WAN technology approved in our Charter.

(2) You might want to run the currently specified TRILL protocol over
a WAN link or you might want to run a reduced control protocol. This
is mostly orthogonal with the link technology. We already have the
current TRILL protocol and doing a reduced protocol is a separate item
in the draft Charter.

So, for the above reasons, I think the draft Charter item is reasonable.

> Narrowing charter it to fit specific drafts or solutions will keep other work, outside of it, not in scope.

Drafts mentioned in the draft Charter are just supposed to be
examples, not binding, and could be dropped.

Thanks,
Donald

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 16 May 2013 09:40:39 -0300

Hi Donald,

Inline for my comments.

Sent from my iPhone

On May 16, 2013, at 5:09 AM, Donald Eastlake <[email-masked]> wrote:

> protocols, and
Yes
> (2) optionally a more restricted control protocol to
No. I didn't imply that. See below for details.
> do TRILL over an WAN technology approved in our Charter.
IP is unique as there in no WG as such. Understand that. The premise of my comment is as follows. We do anticipate changes in TRILL like adding new TLV or something else, while extending TRILL over IP or PWE3 or other types. Instead of doing per WAN/link  type, considering general extensions for TRILL such that, one could extend TRILL over IP or MPLS or VXLAN or whatever. That is better effort spent by the WG rather than doing extensions again and again per each type. If this produces multiple drafts or not in not at all the point, but charter item shouldn't restrict to one or two types.
> current TRILL protocol and doing a reduced protocol is a separate item
See my above answer why I didn't imply that. If protocol doesn't already do that, (which it does as you say), we have bigger problem to deal first.
> So, for the above reasons, I think the draft Charter item is reasonable.

I do not think it is.
> examples, not binding, and could be dropped.
If they are not binding, drop them.

Sam

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 22 May 2013 15:41:05 -0400

Hi Sam,

On Thu, May 16, 2013 at 8:40 AM, Sam Aldrin <[email-masked]> wrote:
>>> It should rather say, TRILL extensions to support extension of
>>> TRILL campus over WAN/internet. Something like that.
>>
>> ...
> IP is unique as there in no WG as such. Understand that. The premise
> of my comment is as follows. We do anticipate changes in TRILL like
> adding new TLV or something else, while extending TRILL over IP or
> PWE3 or other types. Instead of doing per WAN/link type, considering
> general extensions for TRILL such that, one could extend TRILL over
> IP or MPLS or VXLAN or whatever. That is better effort spent by the
> WG rather than doing extensions again and again per each type. If
> this produces multiple drafts or not in not at all the point, but
> charter item shouldn't restrict to one or two types.

Actually, I do not agree. No new TLV is proposed in the IP or PWE3
draft.  TRILL, in my opinion, is a well designed and powerful
protocol. Specifying how to use it over a new link technology normally
involves no changes to TRILL or to the link technology. Generally, all
you have to do is profile how to use which existing facilities of the
link technology and how to use which existing facilities of TRILL. So,
I do not think there is some magic thing the TRILL WG can do that will
solve TRILL over X for many X.

Also, I just think it would be difficult to get approval for a general
Charter item to let TRILL do whatever it wants with TRILL over any
kind of link or over any wide ares network.

>> ...
>...

In some cases they may be useful starting points. I can look at them,
drop some that seem less important, and insert "for example" in front
of others.

Thanks,
Donald

---

From: Sam Aldrin <[email-masked]>
Date: Wed, 22 May 2013 15:15:24 -0700

Hi Donald,

> solve TRILL over X for many X.
Well, let us agree to disagree. x
One may have to do the similar model when RFC6361 did. It could be in TRILL or within that link technology
It is premature to think there will not be any changes to make TRILL extend over link types, just because those drafts didn't have any extensions.
For ex: capability negotiation.

Having said that, a better way to resolve this is to actually see what WG's interest is? i.e. what link types they perceive to extend TRILL upon.
If it is just IP, PWE3 and ppp, it is well and good and the existing charter item description suffice.
But if they are interested in other types, like VXLAN etc, they could be considered as well.

cheers
-sam