Subject: [trill] Call for WG Adoption of draft-mrw-trill-over-ip

From: Donald Eastlake <[email-masked]>
Date: Tue, 11 Feb 2014 20:29:11 -0500

Hi,

This is a call for WG adoption of draft-mrw-trill-over-ip-04.txt.

TRILL over IP is part of the work listed in our Charter and an earlier
version of this draft was presented to the TRILL WG. Please post
comments by February 25th. Comments suggesting improvements to the
draft will be interpreted as favoring its adoption unless the
explicitly state otherwise.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Radia Perlman <[email-masked]>
Date: Wed, 19 Feb 2014 03:56:54 +0530

I support TRILL WG adoption of this.

A couple of minor questions....should it be called "TRILL over IP" if it's
really "TRILL over UDP?"

And as for neighbor discovery over IP...I'd think in lots of cases where
two RBridges R1 and R2 are supposed to be neighbors by tunneling across the
Internet, R1 and R2 would need to be configured with each other's IP
addresses.

Also, section 3.3.3 mentions "the IP backbone scenario" and "the remote
office scenario".  I'm not sure I understand exactly what those are.  Is
this well-known (by everyone other than me) terminology that is defined
somewhere, and if so where?  If not, it might be useful to explain those in
3.3.3.

Anyway...definitely support adoption of this draft.

Radia

On Wed, Feb 12, 2014 at 6:59 AM, Donald Eastlake <[email-masked]> wrote:

> _______________________________________________
> trill mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/trill
>

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 18 Feb 2014 23:02:13 -0500

Hi Radia,

Just some quick responses:

> A couple of minor questions....should it be called "TRILL over IP" if it's

Well, I'd agree with you if I was sure the draft wasn't going to
change in that regard. But the Charter just says "IP" and we don't
know what the WG will decide to do to the draft. For example, the WG
might decide to add optional support of DCCP as well as UDP... The
title should probably be made more specific at some point later in the
process.

> And as for neighbor discovery over IP...I'd think in lots of cases where two
> RBridges R1 and R2 are supposed to be neighbors by tunneling across the

So, it will be common that a TRILL over IP port to be configured with
the address of what is supported to be some other such port. I think
that "discovery" in such a case is referring to figuring out if there
really is a TRILL switch at the other end by exchanging Hellos,
establishing adjacency, etc... Maybe this can be clarified.

> somewhere, and if so where?  If not, it might be useful to explain those in

I think Sections 3.1 and 3.2 are intended to describe the scenarios.

Thanks,
Donald

---

From: Radia Perlman <[email-masked]>
Date: Wed, 19 Feb 2014 11:48:01 +0530

Hi Donald,

I said:
> And you answered:

.................................................
Indeed!  I think I took a break after 3.2 and started reading again at 3.3,
so hadn't remembered reading those two sections.  Thanks!

Radia

---

From: Mingui Zhang <[email-masked]>
Date: Wed, 19 Feb 2014 09:36:47 +0000

A good quality draft. Support for adoption!

It's bare TRILL encapsulated in UDP then in IP, so it eventually provides connectivity for TRILL over IP? :)
With this kind of encapsulation, I think we can have another new link type (IP tunnel) besides TRILL in Ethernet/PPP/PW.

Thanks,
Mingui

>-----Original Message-----
>From: trill [mailto:[email-masked]] On Behalf Of Donald Eastlake
>Sent: Wednesday, February 19, 2014 12:02 PM
>To: Radia Perlman
>Cc: [email-masked]
>Subject: Re: [trill] Call for WG Adoption of draft-mrw-trill-over-ip
>
>Hi Radia,
>
>> A couple of minor questions....should it be called "TRILL over IP" if
>> it's really "TRILL over UDP?"
>
>Well, I'd agree with you if I was sure the draft wasn't going to change in that
>regard. But the Charter just says "IP" and we don't know what the WG will
>decide to do to the draft. For example, the WG might decide to add optional
>support of DCCP as well as UDP... The title should probably be made more
>specific at some point later in the process.
>
>> And as for neighbor discovery over IP...I'd think in lots of cases
>> where two RBridges R1 and R2 are supposed to be neighbors by tunneling
>> across the Internet, R1 and R2 would need to be configured with each
>> other's IP addresses.
>
>So, it will be common that a TRILL over IP port to be configured with the address
>of what is supported to be some other such port. I think that "discovery" in such
>a case is referring to figuring out if there really is a TRILL switch at the other end
>by exchanging Hellos, establishing adjacency, etc... Maybe this can be clarified.
>
>> Also, section 3.3.3 mentions "the IP backbone scenario" and "the
>> remote office scenario".  I'm not sure I understand exactly what those
>> are.  Is this well-known (by everyone other than me) terminology that
>> is defined somewhere, and if so where?  If not, it might be useful to
>> explain those in 3.3.3.
>
> 155 Beaver Street, Milford, MA 01757 USA  [email-masked]
>
>> Radia
>>
>>
>>> TRILL over IP is part of the work listed in our Charter and an
>>> earlier version of this draft was presented to the TRILL WG. Please
>>> post comments by February 25th. Comments suggesting improvements to
>>> the draft will be interpreted as favoring its adoption unless the
>>>  155 Beaver Street, Milford, MA 01757 USA  [email-masked]
>>>

---

From: hongjun ZHAI <[email-masked]>
Date: Wed, 19 Feb 2014 20:15:57 +0800

Hi,

I reviewed this draft, it looks good to me. The two scenarios are typical
for different parts of a TRILL campus to interconnect together.

I support adoption of it.

Thanks,
Hongjun Zhai
-----------------------------------------------------------------------------
Yuhuatai District, Nanjing City, People's Republic of China
Mobile: +086-139-5108-4536
Email: [email-masked]
-----------------------------------------------------------------------------

---

From: Sujay Gupta <[email-masked]>
Date: Fri, 21 Feb 2014 19:03:35 +0530

Looks fine to me, albeit the use cases are not *very* clear practically.
DTLS adoption again should not be a MUST

Thanks,
-Sujay

---

From: Jon Hudson <[email-masked]>
Date: Sat, 22 Feb 2014 13:29:23 -0800

I support working group adoption

Jon

> On Feb 11, 2014, at 5:29 PM, Donald Eastlake <[email-masked]> wrote:
> 
> Hi,
>